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1 Introduction

1.1 About the User Manual

About this document
The User Manual describes the main aspects of Bruker’s integrated software package
TopSpin. This manual enables all users who work with Bruker software to get an overview of
the various functionalities of TopSpin. The main aspects outlined in here describe the
possibilities and functionaries of the TopSpin interface and elucidate working processes for
data acquisition and processing.

Target audience
The Bruker User Manual for TopSpin 2.1 and newer supports all Bruker users who already
work with Bruker software products or who newly enter the software dimension of TopSpin.
The main aspect of this Manual is to enable new TopSpin users and experienced TopSpin
users to work with this software package.

How to get the User Manual
The User Manual is available as a hard copy just like an electronically copy on the TopSpin
DVD in the menu-section Help, where all other Bruker Manuals are provided, too. For
detailed information about all Bruker software manuals please refer to chapter 1.4. The latest
version of the User Manual is also provided on the Bruker Web Server:

How to read the User Manual
The User Manual describes especially the TopSpin interface with all its functionalities to
acquire, process and interpret spectrometer data. To find information more readily you can
read selected chapters, depending on your requirements, or read the User Manual in
succession for general information.

1.2 Safety Regulations
In order to work safely in laboratories with NMR-spectrometers all users have to follow the
safety regulations for magnetic, electrical, cryogenic and chemical safety. For detailed
information please refer to the safety instructions in the Beginners Guide Manual provided on
the TopSpin DVD.
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1.3 User Manual Conventions
The User Manual utilizes different script types in order to make selected text more
transparent and explicable to users. Please note that this document contains the following
conventions:

Font and Format Conventions

Type of Information Font Examples

Shell command,
Commands,
Button and Menu Names

“All what you can click or enter”

Arial bold Type or enter fromjdx,
zg,

use the Export To File button.
Click OK.

Click Processing…

Parameters Arial in
Capital
Letters

VCLIST

Program Code
(Pulse) Program Names
Macros
Functions
Arguments

Courier go=2

au_zgte

edmac

CalcExpTime()

XAU(prog, arg)

AU Macro Courier in
Capital
Letters

REX

PNO

Path, File, Dataset and Experiment
Names
Data Path Variables
Bruker Trademarks

Arial Italics $xwinnmrhome/exp/stan/nmr/lists
expno,  procno, 

IconNMR™, TopSpin™,
XWIN-NMR™

Table 1.1: Font and Format Conventions

User Action Conventions
• A single user action.

1. The first action of a sequence.
2. The second action of a sequence.
3. Etc.

– The first action of a sub-sequence.
– The second action of a sub-sequence.
– Etc.
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1.4 TopSpin Overview

Functionality
TopSpin is an integrated software package for:

• Displaying NMR spectra.
• Printing and plotting spectra.
• Exporting displays and plots in various graphics and metafile formats.
• Importing NMR data from files of various formats.
• Archiving spectra in various formats such as JCAMP-DX and ZIP.
• E-mailing data.
• Processing 1D-6D fids and spectra: window multiplication, various transforms (Fourier,

Hilbert, DOSY), phase correction, baseline correction, integration, peak picking, linear
prediction, smoothing, adding spectra etc.

• Displaying multiple superimposed spectra (1D and 2D).
• Simulating 1D and multi-dimensional fids, given a pulse program and a spin system

(“virtual spectrometer nmr-sim”).
• Calculating T1/T2 relaxation times.
• Fitting peaks with Lorentzian and Gaussian line shape models, deconvolve overlapping

peaks.
• Multiplet analysis.
• Automatic 1D, 2D and 3D peak picking.
• Automatic 1D, 2D and 3D integration.
• Line shape analysis of solids spectra.
• Data acquisition with Bruker Avance type spectrometers.
• Supporting automated and walk-up spectrometers (ICON-NMR).
• Remote spectrometer control including web-enabled ICON-NMR.
• Adding user defined functionalities to TopSpin (AU programs, Macros and Python

programs).

Available Documentation
In TopSpin 2.1 and newer the Help => Manuals submenu, contains list of available manuals
for the following items:
General
Beginners Guides
Acquisition - Users Guides
Acquisition - Application Manuals
Acquisition & Processing Reference
Automation and Plotting
Analysis and Simulation
Programming Manuals
Technical Manuals
Installation Guides
Good Laboratory Practice
Each document is listed with a short description of its contents.
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1.5 TopSpin License
TopSpin requires a license for startup. A license can be ordered online from:
https://www.bruker.com/nmr_license_requests.html
If your PC controls a spectrometer, TopSpin will start up without a license. Furthermore, you
can use TopSpin for developer purposes with restricted functionality. In this case you have to
start it from a Windows Command prompt or Linux shell as follows:
topspin -developer

1.6 TopSpin Program Versions
The TopSpin DVD (2.1 and newer)  contains the following program versions:

• TopSpin
• TopSpin Plot Editor
• ICON-NMR
• NMR-SIM
• NMR-GUIDE
• AUTOLINK

The following programs are distributed as part of the TopSpin DVD, but they must be
licensed separately:

• AMIX
• AUREMOL
• PERCH NMR TOOLS (only for Windows operating system)

https://www.bruker.com/nmr_license_requests.html
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2 Getting Started

2.1 Startup TopSpin

Under Windows
• Click the TopSpin icon on the desktop.

or
• Start TopSpin from a Command Prompt as follows:

– Click Start => Run, enter cmd and click OK.
– In the Command Prompt:

Enter cd <tshome>.
Enter topspin.

Where <tshome> is the directory where TopSpin is installed.

Under Linux
• Open a Linux Shell or Terminal Window.
• In the Shell/Terminal:

– Enter cd <tshome>.
– Enter ./topspin.

Where <tshome> is the directory where TopSpin is installed.

Startup TopSpin specifying dataset
TopSpin can be started with a dataset option:

• Open a Windows Command Prompt or Linux Shell.
• Enter topspin -j TOP_DATA:<dataset path>.

The specified dataset is automatically displayed after startup.
Examples:
topspin -j TOP_DATA:c:\bio\data\guest\nmr\exam1d_1H\1\pdata\1
topspin -j TOP_DATA:c:\bio\data\guest\nmr\exam1d_1H\1\pdata\1\1r
topspin -j TOP_DATA:c:\jcamp.dx
topspin -j TOP_DATA:c:\data-archive.zip

2.2 Configuration
After the installation of TopSpin, it must be configured once. TopSpin may be used in two
different ways:

On a computer which controls a spectrometer
The command cf must be executed once, to configure the spectrometer hardware. Just type
this command and follow the instructions on the screen. At the end of the dialog, further
configuration commands, like expinstall, are offered and can be started from there.
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On a computer which is used as data station
The only configuration command to be executed is expinstall. This allows you to install pulse
programs, AU programs, lists etc. Just type this command and follow the instructions on the
screen, selecting Installation for Data station (default).

Note that the commands cf and expinstall can be started from the command line or from the
Options or Spectrometer menu. However, the latter menu is only available after cf has
been performed once, choosing Installation for spectrometer.

After the configuration has finished, TopSpin is ready to be used. The configuration only
needs to be repeated when you have installed a new version of TopSpin or if your 
spectrometer hardware has changed.
More details on configuration can be found in the chapter Configuration [}  202] and the
descriptions of cf and expinstall in the Acquisition Reference Manual.

2.3 How to Display Spectra
In this chapter,  opening data in standard Bruker format is described. Opening other data
formats is described in chapter Dataset Handling [} 39].
Please note that a standard Bruker dataset is a directory tree rather than a single file:
<dir>\data\<user>\nmr\<dataset name>\<expno>\pdata\<procno>
e.g. c:\bruker\topspin\data\guest\nmr\exam1d_13C\1\pdata\1

How to locate NMR data in any arbitrary directory
With TopSpin 2.5 Preview and newer, NMR data can be located in any arbitrary directory.
As described in section How to Display Peaks, Integrals, ... together with the Spectrum
[} 16] the standard Bruker format can still be used.
The new storage format can be located in the following way:
<dir>/<name>/<expnos>/pdata/<procnos>
e.g. c:\mydir\sucrose\10\pdata\1
Please note the following facts about the usage of the old and new storage format:

• The old format is still valid because it is a special case of the new storage format.
• The old and new style data storage must not be mixed, this would confuse TopSpin data

browser.
• The browser command scroll to active dataset will not work for old style data storage.
• The Bruker example datasets (if installed at all) can be found with TopSpin 2.5 and newer

in <TOPSPIN INSTALLATION DIR>/examdata.
• This directory is automatically shown in the browser if enabled in the User Preferences

(command set).

How to Open Data from the Menu
Open the File menu and click Open... A dialog box appears. Select the first option, the
Browser type File Chooser and click OK. A file browser appears. Navigate to your data
directory and expand it to the level of names, expnos, or procnos (double-click a directory to
expand it). Select the desired item and click Display.
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The selected dataset replaces the contents of the currently selected (active) window. If no 
data window was displayed, a new one will be created. Alternatively, you can first create a
new window by clicking Window => New Window or [ Alt+ w n) and then open a dataset
from the file browser in that window.
The file browser can also be opened by entering reb on the command line.

How to Open Data from the Browser
TopSpin has data browser which, by default, displays the top level data directory (<dir>) with
Bruker example data. You can add your own data directories, local or remote, as follows:
1. Move the cursor into the browser area.
2. Right-click and choose Add New Data Dir... in the popup menu.
3. Enter the desired data directory (<dir>) and click OK.
Your data directory will now appear in the browser.
In order to display data from the Browser, proceed as follows:

• Expand your top level directory (<dir>) in the browser to the level of the data name, expno
or procno.

• Select the desired item and drag it into the data area.

How to Define Alias Names for Data
1. Open the dataset for which you want to define an alias name.
2. Click the Alias tab at the top of the data browser.
3. Right-click in the browser and choose Define alias for data in selected window.
Alternatively, you can enter the command alias on the command line.

How to Open Data in Archive Data Directories
TopSpin 2.0 and newer allows opening datasets that are stored in the following directory
structures:
<mydata>/<name>/<expno>/pdata/<procno>
You can do that with the TopSpin command reb or from the Operating System File Browser
with Copy & Paste or Drag & Drop. Actually, the data are copied to the data directory:
<tshome>/data/<user>/nmr/<name>/<expno>/pdata/<procno>
Where <tshome> is the TopSpin installation directory and <user> is the current (internal)
TopSpin user.

How to Open Data in Other Ways
TopSpin provides various other ways of displaying data. You can, for example, use command
line commands like re, rew, rep and dir. Details on these features can be found in chapter
Opening Data [} 46] and in the Processing Reference Manual.

2.4 How to Expand a Spectral Region
To expand a certain spectral region:

• Click-hold the left mouse button on one side of the region, drag the cursor to the other
side and release the mouse.

If you want to cancel the expansion while dragging the mouse, just move the mouse out of
the data area and release it.
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An alternative way of expanding a region is clicking the button repeatedly and then
shifting the spectrum to the proper position.

2.5 How to Display Peaks, Integrals, ... together with the Spectrum
When a spectrum is displayed, you can superimpose its title, parameters, integrals, and
peaks as follows:
1. Move the cursor into the data window that contains the spectrum.
2. Right-click and choose Display Properties... in the popup menu.
3. Check the desired items and click OK.
Please note that the selected items are only shown if they are available. For example, peaks
and integrals are only shown if peak picking and integration have been performed,
respectively (see also 1D Interactive Manipulation [} 123]. The number of displayed digits for
the integral and peak labels can be set in the User Preferences (click Options =>
Preferences => Spectrum).

2.6 How to Display Projections/1D Spectra with 2D Spectra
To display projections or 1D spectra in tandem with a 2D spectrum:
1. Open a 2D spectrum.

2. If no projections are shown, click the  button in the upper toolbar or enter .pr on the
command line.

3. Move the cursor into the F1 or F2 projection area.
4. Right-click and choose one of the options. With External Projection... an existing 1D

spectrum can be read. This can be a regular 1D spectrum or a 2D projection that was
stored as a 1D spectrum. With Internal Projection the positive projection can be
calculated and displayed.

An alternate way to calculate projections is the following:
• Click Processing => Display Projections...[ projd]

or
• Right-click on a 1D dataset in the browser and choose Display As 2D Projection.

2.7 How to Superimpose Spectra in Multiple Display
TopSpin allows you to compare multiple spectra in Multiple Display mode. To enter this

mode, click the button in the upper toolbar or enter  on the command line. When you
open a dataset now, for example drag one from the browser, it will be superimposed on the
current spectrum rather than replacing it. Several multiple display functions are available now
in the data window toolbar. Most importantly, you can scale and shift each spectrum
individually. This allows exact alignment of corresponding peaks of different spectra.
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2.8 How to Print or Export the Contents of a Data Window

How to Print Data
A TopSpin data window may contain various objects like an fid, a spectrum, expansions of a
spectrum, superimposed spectra, spectrum components such as parameters, peaks,
integrals, cross sections etc. Whatever the content of the data window is, it can be printed as
follows: type Ctrl + p or click File => Print..., select Print active window in the appearing
dialog box and click OK.
The other options in this dialog box enable you to use or create plot layouts. Details on this
can be found in the Plot Editor manual to be found under Help => Manuals =>Plotting.
The colors of the printed data can be chosen in the User Preferences dialog box. Just enter
the command set or click Options => Preferences... and click Printer in the left part of the
dialog box.

How to Copy a Data Window to Clipboard
Under MS Windows, you can easily copy the data window contents to other applications. To
do that, type copy or click Edit => Copy. This will copy the data window contents to the
clipboard. After that you can paste the clipboard contents to any Windows application.

How to Store (Export) a Data Window as Graphics File
The clipboard and metafile formats are resizable vector formats. In addition to this, TopSpin
allows you to save the contents of a data window in a graphics file of selectable type,
e.g. .png, .jpg, .jpeg, .bmp, .emf and .wmf. To do that, click File => Export.... The resolution
of such a screen dump equals the resolution of your screen. Note that when you import a
graphics file into another program and resize it you lose information. Therefore we
recommend to resample rather than resize graphics.

2.9 How to Process Data
Since this manual is not a general NMR text book, we assume here that you are familiar with
terms like window multiplication, Fourier Transform, phase correction, etc.
Any Fid or a spectrum displayed in a TopSpin window can be processed by:

• Typing a command on the command line, e.g. ft.
• Invoking a command from the Processing or Analysis menu, e.g. Processing =>

Fourier Transform...
• Entering an interactive mode by clicking a tool button, e.g.
• Entering a user defined command (usually an AU or a Python program, see Help =>

Manuals [ Programming Manuals].
Processing and analysis commands require certain parameters to be set correctly. Most
commands in the Processing or Analysis menu, like wm and ftf open a dialog box showing
the available options and required parameters for that command. Other commands such as
em, ft, ... start processing immediately. Before you use them, you must set their parameters
from the parameter editor. To do that, enter edp or click the ProcPars Tab of the data
window.
If you are a new or occasional user we recommend you to process your data with the
TopSpin Processing Guide. This will guide you through the typical sequence of processing
steps. To start the Processing Guide, click Processing => Data => Processing Guide. In
Automatic mode, the Processing Guide will simply execute each processing command when
you click the corresponding button. This requires the processing parameters to be set
correctly. In interactive mode (Automatic mode unchecked), the Processing Guide will, at
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each step, open a dialog box offering you the available options and required parameters. For
example, the phase correction button offers various automatic algorithms as well as an option
to enter interactive phasing mode.
A simple way to process 1D data is the following:
1. Click Processing => Process / Plot Current data.
2. In the appearing dialog (see below):

– Enable the desired processing/plotting steps.
– Set the parameter LB for Exponential multiplication.
– Select the desired LAYOUT for plotting.
– Click OK.

See also
2 Getting Started [} 13]

2.10 How to Archive Data
TopSpin 2.1 provides the following methods for data archiving:

• Automatic archiving of raw data after the acquisition as defined in the User preferences
(click Options => Preferences => Acquisition => Configure ..).

• Copying a dataset to a desired destination directory which could for instance be located
on a server. Type wrpa, click File => Save... or type Ctrl+ s.

• Saving a dataset in a ZIP file. A standard Bruker dataset is a directory tree which contains
several files. Zipping a dataset stores the entire data directory tree into a single file with
the extension .bnmr.zip. To zip a dataset, type tozip, click File => Save... or type Ctrl+ s.
To unpack and display a zipped dataset, enter fromzip. Note that .bnmr.zip files are fully
compatible with the well known PC zip format and can be unpacked with any common
unzip utility. Zipping can be applied to 1D, 2D, 3D and 4D data.

• Saving a dataset in JCAMP-DX format. This format is a IUPAC standard, and is available
for 1D and 2D datasets. Data and parameters are stored in readable text (ASCII) format.
To store data in JCAMP, type tojdx, click File => Save... or type Ctrl+ s. To convert and
display a JCAMP-DX file, type fromjdx.

• E-mailing data to a desired destination. Type smail or click File => Send To.... The
mailing format is either zip or JCAMP-DX, both of which allow for data compression in
order to keep the transferred data size as small as possible.
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2.11 How to Import NMR Data Stored in Special Formats
TopSpin allows you to convert various data formats to standard Bruker format for display and
processing. Click File => Open... and select Open NMR data stored in special formats.
Then follow the instructions on the screen.

2.12 How to Fit Peaks and Deconvolve Overlapping Peaks
Deconvolution is a useful tool to interprete complex spectra in which the peaks are not
definite and clear.
Peaks of a 1D and 2D NMR spectrum can be approximated by a Lorentzian, Gaussian, or a
mixture of these line shapes. Overlapping peaks may be deconvolved into a sum of such line
shapes.
TopSpin shows the deconvolution result, i.e. peak positions, line widths and integrals on the
screen and stores it in the file dconpeaks.txt. Furthermore, it switches to multiple display
mode to show the original spectrum and the sum of the computed line shapes,
superimposed.
To start deconvolution, expand the spectrum on the display to show the peak or peak group
of interest. Then type dcon or click Analysis −−> Line Shape Fitting −−> Deconvolution....

2.13 How to Compute FIDS by Simulating Experiments
TopSpin includes a virtual spectrometer that computes FIDs of any dimension. A real
spectrometer excites a sample with high frequency pulses defined by a pulse program and
measures the resulting FID . The virtual spectrometer performs this task mathematically by
solving the quantum mechanical Liouville equation. The sample must be entered in form of a
spin system description. For the computation, the same pulse program and acquisition
parameters are taken as for the real experiment. The result is a time domain signal which can
be processed with TopSpin in the same way a measured fid is processed. Techniques such a
selective excitation, gradient enhanced spectroscopy, and the handling of mixtures are
supported.
To start the virtual spectrometer:

• Enter nmrsim on the command line or click Analysis −−> Simulate Fid....

2.14 How to Add Your Own Functionalities
The TopSpin functionality can be extended with various user defined commands, programs
etc.

How to Create Macros
Writing a macro is the simplest way to create a user defined command. Just enter the
command edmac, create a file, and enter a sequence of regular TopSpin commands and/or
Python commands. Save the file under a name of your preference. You have created a new
TopSpin command. Just enter its name on the command line to execute it. edmac shows a
list of all available macros and allows you to execute one.

How to Create AU (automation) Programs
Writing an AU program is another way of creating a new TopSpin command. AU programs
are more complex and more powerful then macros. They are C-language programs, which
may contain C-statements, regular TopSpin commands, and various predefined AU macros
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and functions. AU programs can perform various tasks such as dataset handling, parameter
handling, acquisition, processing, analysis, and printing. Note that AU programs do not
support graphics related tasks.
TopSpin is delivered with a large set of Bruker AU programs for data processing and
acquisition. Just enter edau to see them listed in a dialog box. The easiest way to create a
new AU program is to select a Bruker AU program, save it under a new name and modify it to
your needs. The chosen name is now available as a new TopSpin command. Alternatively,
you can open a new file from the AU dialog box and write your AU program from scratch.
For details on Bruker AU programs and writing your own AU programs, click Help =>
Manuals => [ Programming Manuals] AU Programming.

How to Create Python Programs
Writing a Python program is yet another way of creating a new TopSpin command. Python is
a new generation scripting and object oriented programming language. Python programs are
even more powerful than AU programs. They are easy to use and allow you to execute
TopSpin commands, handle NMR data and parameters, generate graphics, and interact with
the TopSpin user interface via dialogs, windows etc. To create a Python program, enter the
command edpy, select a file and insert your Python statements. Graphics and interface
features programmed in Python look and work the same as regular TopSpin features.
For details on Python programming, click Help => Manuals => [ Programming Manuals]
Python Programming. The examples mentioned there, like pycmd1, are delivered with
TopSpin. Just enter their names on the command line to execute them.
The Python dialog window is also available from the TopSpin menu:
Click File => Open...and select Open other file => Python program.

2.15 How to Automate Data Acquisition
TopSpin provides special user interfaces for automation, walk-up, bio-molecular experiments,
etc. To open these interfaces:

• Type iconnmr or click Spectrometer => ICONNMR.
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3 The TopSpin Interface

3.1 New Flow User Interface with TopSpin 3.0
Beginning with TopSpin 3.0 a new flow user interface is introduced to alleviate all user
processes.
Per default the known TopSpin user interface is activated, but the new flow user interface can
be enabled in the User Preferences.
The new workflow-based interface, with its applicable arrangement of all working processes,
allows the user to control intuitional the workflows.

The Flow menu opens a horizontal feature list which stays open with one click and all
functionality concerning this process are available and can be started with one click.
Furthermore a mouse contact of the functionality opens a balloon help and one click leads to
the continuative menu.
The yellow data button in the upper left corner replaces the File menu. Accessorily all buttons
appear in a new design and can be detached from the default position.

3.2 The TopSpin Window
The  TopSpin window consists of a data area, a data browser, toolbars and a menu bar. Note
that the browser can be inactive [hit Ctrl+ d] or displayed as a separate window.
The next figure shows the TopSpin window with two data windows in the data area and the
browser as an integral part.
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Note that the menus and toolbars depend on the data dimensionality. The descriptions below
holds for 1D data. For 2D and 3D data, the menus and toolbars are similar and will be
discussed in the chapters 2D Display [}  105], nD Display [}  117] and 2D Interactive
Manipulation [} 151], respectively.

How to Use Multiple Data Windows
TopSpin allows you to use multiple data windows. Data windows can be opened from the
browser or from the Window menu. They can contain the same of different datasets. Data
windows can be arranged from the Window menu. One of them is the active (current) data
window. The active data window:

• is the only data window receiving commands from the command line.
• can be selected by clicking inside the window or hitting F6 repeatedly.
• has a highlighted title bar.
• has the mouse focus.

A cursor line (1D) or crosshair (2D) is displayed in all data windows at the same position.
Moving the mouse affects the cursor in all data windows.

How to Use the Menu bar
The menu bar contains the following menus:

• File : performing data/file handling tasks.
• Edit : copy & paste data and finding data.
• View : display properties, browser on/off, notebook, command history.
• Spectrometer : data acquisition and acquisition related tasks.
• Processing : data processing.
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• Analysis : data analysis.
• Options : setting various options, preferences and configurations.
• Window : data window handling/arrangement.
• Help : access various information, indices, manuals etc.

Experienced users will usually work with keyboard commands rather than menu commands.
Note that the main keyboard commands are displayed in square brackets [] behind the
corresponding menu entries. Furthermore, right-clicking any menu entry will show the
corresponding command, unless right-clicking is defined otherwise.

How to Use the Upper Toolbar (1D data)
The upper toolbar contains buttons for data handling, switching to interactive modes, display
settings, and starting acquisition.
Buttons for data handling:

The functions of the individual buttons are:

Create a new dataset [ Ctrl+ n, new].

Open a dataset [ Ctrl+ o, open].

Save the current dataset [ Ctrl + s, sav].

Email the current dataset [ smail].

Print the current dataset [ Ctrl + p, print].

Copy the data path of the active data window to the clipboard [ copy].

Paste the data path on the clipboard to the active data window [ paste].

Switch to the last 2D dataset [ .2d].

Switch to the last 3D dataset [ .3d].
For more information on dataset handling, please refer to chapter Opening Data [} 46].
Buttons for interactive functions

The functions of the individual buttons are:

Enter phase correction mode.

Enter calibration mode.

Enter baseline correction mode.

Enter peak picking mode.

Enter integration mode.

Enter multiple display mode.
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Enter distance measurement mode.
For more information on interactive functions, refer to chapter 1D Interactive Manipulation
[} 123] and Data Window Handling [} 169].
Buttons for display options

The functions of the individual buttons are:

Toggle between Hz and ppm axis units.

Switch the y-axis display between abs/rel/off.

Switch the overview spectrum on/off.

Toggle grid between fixed/axis/off.

How to Use the Lower Toolbar (1D data)
The lower toolbar contains buttons for display functions.
Buttons for vertical scaling (intensity)

Increase the intensity by a factor of 2 [ *2].

Decrease the intensity by a factor of 2 [ /2].

Increase the intensity by a factor of 8 [ *8].

Decrease the intensity by a factor of 8 [ /8].

Change the intensity smoothly.

Reset the intensity (baseline positions remains unchanged) [ .vr].
Note that vertical scaling can also be changed with the mouse wheel.
Buttons for horizontal scaling (zooming):

Reset zooming (horizontal scaling) to full spectrum [ .hr].

Display the entire spectrum (baseline position and intensity scaling are adjusted if
necessary) [ .all].

Zoom in to the center (spectrum) or left edge (FID) of the displayed region, increasing
the horizontal scaling. [ .zi].

Zoom in/out smoothly.

Zoom out from the center (spectrum) or left edge (FID) of the displayed region,
decreasing horizontal scaling) [ .zo].

Exact zoom via dialog box[ .zx].
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Toggle interactive zoom mode. When switched off, interactive zooming only selects a
horizontal region; baseline position and intensity scaling remain the same. When switched
on, interactive zooming draws a box selecting the corresponding area.

Undo last zoom [ .zl].

Retain horizontal and vertical scaling when modifying dataset or changing to different
dataset. Global button for all data windows [ .keep].
Buttons for horizontal shifting

Shift to the left, half of the displayed region [ .sl].

Smoothly shift to the left or to the right.

Shift to the right, half of the displayed region [ .sr].

Shift to the extreme left edge of the spectrum [ .sl0].

Shift to the extreme right edge of the spectrum [ .sr0].
Buttons for vertical shifting

Shift the spectrum baseline to the middle of the data field [ .su].

Smoothly shift the spectrum baseline up or down.

Shift the spectrum baseline to the bottom of the data field [ .sd].
For more information on display options, please refer to chapter 1D Display Options [} 99]
(1D data) and 2D Display Options [} 111] (2D data).

See also
2 The TopSpin Interface [} 21]

3.3 Command Line Usage
How to Put the Focus in the Command Line.
In order to enter a command on the command line, the focus must be there. Note that, for
example, selecting a dataset from the browser, puts the focus in the browser. To put the
focus on the command line:

• Hit the Esc key.
or

• Click inside the command line.

How to Retrieve Previously Entered Commands
All commands that have been entered on the command line since TopSpin was started are
stored and can be retrieved. To do that:

• Hit the ↑ (Up-Arrow) key on the keyboard.
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By hitting this key repeatedly, you can go back as far as you want in retrieving previously
entered commands. After that you can go forward to more recently entered commands as
follows:

• Hit the ↓ ( Down-Arrow) key on the keyboard

How to Change Previously Entered Commands
1. Hit the ← (Left-Arrow) or → (Right-Arrow) key to move the cursor.
2. Add characters or hit the Backspace key to remove characters.
3. Mark characters and use Backspace or Delete to delete them, Ctrl+ c to copy them, or

Ctrl + v to paste them.
In combination with the arrow-up/down keys, you can edit previously entered commands.

How to Enter a Series of Commands
If you want to execute a series of commands on a dataset, you can enter the commands on
the command line separated by semicolons, e.g.:
em;ft;apk
If you intend to use the series regularly, you can store it in a macro as follows:

• Right-click in the command line and choose Save as macro.

3.4 Command Line History
TopSpin allows you to easily view and reuse all commands, which were previously entered
on the command line. To open a command history control window; click View => Command
Line History, or right-click in the command line and choose Command Line History, or
enter the command cmdhist:

It shows all commands that have been entered on the command line since TopSpin was
started. You can select one or more commands and apply one of the following functions:

Execute
Execute the selected command(s).

Append
Append the (first) selected command to the command line. The appended command can be
edited and executed. Useful for commands with many arguments such as re.
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Save as...
The selected command(s) are stored as a macro. You will be prompted for the macro name.
To edit this macro, enter edmac <macro-name>. To execute it, just enter its name on the
command line.

See also
2 The TopSpin Interface [} 21]

3.5 Starting TopSpin commands from a Command Prompt
TopSpin commands can be executed outside of the TopSpin interface, from a Windows
Command Prompt or Linux Shell.

Under Windows
1. Open a Windows Command Prompt.
2. Enter a TopSpin command in the following format:

<tshome>\prog\bin\sendgui <topspincommand>, where <tshome> is the TopSpin
installation directory.

Examples:
C:\ts2.1\prog\bin\sendgui ft executes a 1D Fourier transform.
C:\ts2.1\prog\bin\sendgui re exam1d_1H 1 1 C:/bio joe reads the dataset C:/bio/joe/nmr/
exam1d_1H/1/pdata/1.

Under Linux
1. Open a Linux Shell.
2. Enter a TopSpin command in the following format:
<tshome>\prog\bin\scripts\sendgui <topspincommand>, where <tshome> is the TopSpin
installation directory.
or
sendgui <topspincommand>, if the TopSpin home directory is in the users search path.

Examples:
C:\ts2.1\prog\bin\scripts\sendgui ft executes a 1D Fourier transform.
sendgui re exam1d_1H 1 1 C:/bio joe reads the dataset C:/bio/joe/nmr/exam1d_1H/1/
pdata/1.
Note that commands are executed on the currently active TopSpin data window.

3.6 Function Keys and Control Keys
For several TopSpin commands or tasks, you can use a control-key or function-key short cut.

Focus anywhere in TopSpin

Esc Put the focus in the command line.

Shift+Esc Display menu bar and toolbars (if hidden).
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F2 Put the focus in the browser.

F1 Search for string in command help or NMR Guide
[ help].

F6 Select the next window in the data area.

Alt + F4 Terminate TopSpin [ exit].

Ctrl + d Switch the browser on/off.

Ctrl + o Open data [ open].

Ctrl + f Find data [ find].

Ctrl + n New data [ new].

Ctrl + p Print current data [ print].

Ctrl + s Save current data [ sav].

Ctrl  w Close active window [ close].

Ctrl  c Copy a text that you selected/highlighted in an
error box, dialog box, pulse program, title etc., to
the clipboard.

Ctrl + v Paste text from the clipboard into any editable
field.

Table 3.1: Focus anywhere in TopSpin

Focus in the Command Line

Ctrl+ Backspace Kill current input.

Ctrl+ Delete Kill current input.

UpArrow Select previous command (if available).

DownArrow Select next command (if available).

Table 3.2: Focus in the Command Line

Focus in the "striped" tables (e. b. edsolv, ednuc, peaks, ints, cortab etc.

Ctrl + C copy the currently selected table rows to the
system’s clipboard as a CSV-formatted table.

Home The table package assumes that data will always
be represented by complete rows rather than
individual cells. This makes a re-binding of [Home]
necessary, to enforce the behavior of jumping to
the first row.

End The table package assumes that data will always
be represented by complete rows rather than
individual cells. This makes a re-binding of [End]
necessary, to enforce the behavior of jumping to
the last row.

Shift + Home The table package assumes that data will always
be represented by complete rows rather than
individual cells. This makes a re-binding of [Shift +
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Home] necessary, to enforce the behavior of
selecting all rows starting from the current anchor
to the first row.

Shift + End The table package assumes that data will always
be represented by complete rows rather than
individual cells. This makes a re-binding of [Shift +
End] necessary, to enforce the behavior of
selecting all rows starting from the current anchor
to the last row.

Ctrl + Numpad + Auto-resizes all columns such that the data fits
optimally.

Ctrl + Shift + X Opens the export dialog.

Ctrl + Shift + I Opens the import dialog.

Ctrl + Shift + P opens the table properties dialog.

Ctrl + Shift + V Opens the print preview.

Table 3.3: Focus in the "striped" tables (e. b. edsolv, ednuc, peaks, ints, cortab etc.

Focus in the peak table

Delete Deletes the current selection of peaks.

Enter Zooms the spectrum pane in the current MDI
window such that all selected objects are visible.

Ctrl + E Starts the annotation editor of the currently
anchored peak.

Ctrl + Shift + R Opens the "rotate peaks" dialog.

Ctrl + Shift + S Opens the "shift peaks" dialog.

Ctrl + Shift + D Opens a window displaying detailed information of
the current selection of peaks.

Ctrl + Shift + A Opens the "annotate by reference" dialog.

Table 3.4: Focus in the peak table

Focus in the Browser

UpArrow Select previous dataset.

DownArrow Select next dataset

Enter dir/user/name/expno selected: expand node or
collapse node, depending on the current state.

Enter procno selected: display this dataset.

Ctrl+Enter name/expno selected: display this dataset.

Enter multiple procnos selected: show in multiple display

Delete one or more name/expno/procno nodes selected:
delete these datasets.

Table 3.5: Focus in the Browser



The TopSpin Interface

30 H9469SA3_2_003

Focus anywhere in TopSpin

Scaling Data

Alt+ PageUp Scale up the data by a factor of 2 [ *2].

Alt+ PageDown Scale down the data by a factor 2 [ /2].

Ctrl+ Alt+ PageUp Scale up by a factor of 2, in all data windows.

Ctrl+ Alt+ PageDown Scale down by a factor of 2, in all data windows.

Alt+ Enter Perform a vertical reset.

Ctrl+ Alt+ Enter Perform a vertical reset in all data windows.

Zooming data

Alt+ Plus Zoom in [ .zi].

Alt+ Minus Zoom out [ .zo].

Ctrl+ Alt+ Plus Zoom in, in all data windows.

Ctrl+ Alt+ Minus Zoom out, in all data windows.

Shifting Data

Alt+ UpArrow Shift spectrum up [ .su].

Alt+ DownArrow Shift spectrum down [ .sd].

Alt+ LeftArrow Shift spectrum to the left [ .sl].

Alt+ RightArrow Shift spectrum to the right [ .sr].

Ctrl+ Alt+ UpArrow Shift spectrum up, in all data windows.

Ctrl+ Alt+ DownArrow Shift spectrum down, in all data windows.

Ctrl+ Alt+ LeftArrow Shift spectrum to the left, in all data windows.

Ctrl+ Alt+ RightArrow Shift spectrum to the right, in all data windows.

Table 3.6: Focus anywhere in TopSpin

Focus in a Table (e.g. peaks, integrals, nuclei, solvents)

delete Delete the selected entries.

home Select the first entry.

end Select the last entry.

Shift+ Home Select the current and first entry and all in
between.

Shift+ End Select the current and last entry and all in
between.

DownArrow Select next entry.

UpArrow Select previous entry.

Ctrl+ a Select all entries.

Ctrl+ c Copy the selected entries to the clipboard.

Ctrl+ z Undo last action.

Ctrl+ y Redo last undo action.

Table 3.7: Focus in a Table (e.g. peaks, integrals, nuclei, solvents)
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Focus in a Plot Editor

F1 Open the Plot Editor Manual.

F5 Refresh.

Ctrl+F6 Display next layout.

ctrl+ Shift+ F6 Display previous layout.

Ctrl+ tab Display next layout.

delete Delete the selected objects.

Ctrl+ a Select all objects.

Ctrl+ i Open TopSpin Interface.

Ctrl+ c Copy the selected object from the Clipboard.

Ctrl+ l Lower the selected object.

Ctrl+ s Save the current layout.

Ctrl+ m Unselect all objects.

Ctrl+ n Open a new layout.

Ctrl+ o Open an existing layout.

Ctrl+ p Print the current layout.

Ctrl+ q Close the Plot Editor window (Linux only).

Ctrl+ r Raise the selected object.

Ctrl+ t Reset X and Y scaling of all marked objects.

Ctrl+ v Paste the object from the Clipboard.

Ctrl+ w Open the attributes dialog window.

Ctrl+ x Cut the selected object and place it on the
Clipboard.

Ctrl+ z Undo the last action.

Table 3.8: Focus in a Plot Editor

Note that the function of function keys can be changed as described in chapter How to Print
or Export the Contents of a Data Window [} 17].

3.7 Help in TopSpin
TopSpin offers help in various ways like online manuals, command help and tooltips.

How to get a Panorama Tour
For a quick overview over TopSpin Interface, Acquisition, Processing, Analysis and
Documentation:

• Click Help => Panorama Tour.

How to Open Online Help documents
The online help manuals can be opened from the Help => Manuals submenu. For example

• To open the manual that you are reading now:
Click Help => Manuals => [General] User Manual.
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• To open the Avance Beginners Guide:
Click Help => Manuals => [Beginners Guides] <language>.

• To open the Processing Reference guide:
Click Help => Manuals => [Acquisition & Processing References] Proc. Commands
and Parameters.

Note that most manuals are stored in the directory:
tshome>/prog/docu/english/xwinproc/pdf
The most recent versions can be downloaded from<:
www.bruker.com

How to Get Tooltips
If you hold the cursor over a button of the toolbar, a tooltip will pop up. This is a short
explanation of the buttons function. For example, if you hold the cursor over the interactive
phase correction button, you will see the following:

The corresponding command line command, in this case .ph, is indicated between square
brackets.
Note that the tooltip also appears in the status bar at the bottom of the TopSpin window.

How to Get Help on Individual Commands
To get help on an individual command, for example ft:

• Enter ft?
or

• Enter help ft
In both cases, the HTML page with a description of the command will be opened.
Note that some commands open a dialog box with a Help button. Clicking this button will
show the same description as using the help command. For example, entering re and
clicking the Help button in the appearing dialog box:

Opens the same HTML file as entering help re or re?.

http://www.bruker.com
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How to Use the Command Index
To open the TopSpin command index:

• Enter cmdindex.
or
Click Help => Command Index
From there you can search for and click any command and jump to the corresponding help
page.

3.8 User Defined Functions Keys
The default assignment of functions keys is described in chapter How to Display
Projections/1D Spectra with 2D Spectra [} 16] and in the document:
Click Help => Manuals => [ General] Control & Function Keys.
You may assign your own commands to functions keys. Here is an example of how to do
that:

1. Open the file cmdtab_user.prop, located in the subdirectory userdefined of the user
properties directory (to locate this directory, enter hist and look for the entry "User
properties directory="). The file cmdtab_user.prop is initially empty and can be filled with
your own command definitions.

2. Insert e.g. the following lines into the file: _f3=$em_f3ctrl=$ft_f3alt=$pk_f5=
$halt_f5ctrl=$reb_f5alt=$popt

3. Restart TopSpin.
´ Now, when you hit the F3 key, the command em will be executed. In the same way,

Ctrl+ F3, Alt+ F3, F5, Ctrl+ F5 and Alt + F5 will execute the commands ft, pk, halt,
reb and popt, respectively. You can assign any command, macro, AU program or
Python program to any function keys. Only the keys Alt+ F4, F6, Ctrl + F6, and Alt +
F6 are currently fixed. Their function cannot be changed.

See also
2 The TopSpin Interface [} 21]

3.9 How to Open Multiple TopSpin Interfaces
TopSpin allows you to open multiple User Interfaces. This is, for example, useful to run an
acquisition in one interface and process data in another. To open an addition interface, enter
the command newtop on the command line or click Window => New TopSpin. To open yet
another interface, enter newtop in the first or in the second interface. The display in each
interface is completely independent from the others. As such, you can display different
datasets or different aspects of the same dataset, e.g. raw/processed, regions, scalings etc.
When the dataset is (re)processed in one interface, its display is automatically updated in all
TopSpin interfaces.
The command exit closes the current TopSpin interface. Interfaces that were opened from
this interface remain open. Entering exit in the last open TopSpin interface, finishes the entire
TopSpin session. The position and geometry of each TopSpin interface is saved and restored
after restart.
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4 Troubleshooting

4.1 General Tips and Tricks
On a spectrometer, make sure the commands cf and expinstall have been executed once
after installing TopSpin. cf must be executed again if your hardware configuration has
changed. Sometimes, executing cf is useful in case of acquisition problems.
On a datastation, a default configuration is automatically done during the installation. No
configuration commands are required. Only if you want to use AU programs, you must run
expinstall once.

4.2 History, Log Files, Spooler Reports, Stack Trace
If you have a problem with TopSpin and want to contact Bruker, it is useful to have as much
information as possible available. If TopSpin is still running, you can view log files with the
commands hist and ptrace. If TopSpin hangs, you can create a stack trace by hitting Ctrl+\
(Linux) or Ctrl+Break (Windows) in the TopSpin startup window.

4.2.1 Topspin Command Log

By default, the history (protocol) feature is switched on. This means all TopSpin commands
will be protocolled and can be examined by entering hist on the command line.
If, for some reason, history is switched off, you can switch it on as follows:
1. Click Options => Preferences, click Miscellaneous.
2. Check the entry Record commands in protocol file.
3. Click OK.

4.2.2 Topspin Spooler Report

TopSpin reports all queued, delayed and cron jobs in the so called spooler report file. The
spooler report stores all jobs since TopSpin installation and can become very large.
Therefore it should be cleaned from time to time. To do that:
1. Enter the command spooler.
2. Click Tools => Show spooler report.
3. Mark the entries to be deleted.
4. Right-click in the dialog and choose Delete.
5. Close the Spooler report.
Note that the spooler report can also be opened from Spooler field (if enabled) in the
Acquisition Status Bar by right-clicking the word Spooler and choosing Show spooler
report.

4.2.3 Topspin Command, Data Server and Network Log

A full protocol including not only TopSpin commands but also data server and network traffic
is show by the command ptrace. This opens the following dialog window:
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Here TopSpin log messages from various log files are displayed time sorted.
Messages from different log files are shown in different colors. The color assignment and
location of the files is shown in the lower part of the dialog window.
ptrace supports the following functions:

Search keywords
To search the displayed log files for a certain keyword, just enter it in the text bar at the top of
the window and hit Enter.

Anchor specific entries
To anchor an entry:

• Double-click in the first column of the entry.
The entry is marked with an X. Now you can use the < > buttons at the upper right of the
window to go to the previous or next entry, respectively.

Add log files
By default, the procol.txt, history and data server log files are shown. To include additional log
files to the ptrace list:

• Click File => Add, specify the file and click Open.
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Note that most log files are stored in the directory:
<tshome>/prog/curdir/<user>

Save the log messages
To save log messages in a text file:

• Click File => Save and specify the output text file.

4.2.4 Create a Stack Trace

If TopSpin hangs it can be useful to send Bruker a stack trace about a possible cause. You
can create a stack trace as follows.
1. Move the cursor into the TopSpin startup window.
2. Under Windows: hit Ctrl+Break ( =Ctrl+Pause)Under Linux: hit Ctrl+\ (Control

backslash).
3. Copy the appearing text into a text file.

4.2.5 Store Complete Log with => savelogs

A complete set of TopSpin log files can be made automatically with the command savelogs if
the user assertively confirms.
For saving log files with the command savelogs do the following:
Under Windows:

• Click the Bruker Utilities<topspin version> icon on your desktop. An Explorer will be
opened.

• Double-click Miscellaneous.
• Execute the script savelogs.

Under Linux:
• Open a shell.
• Type savelogs

All <tshome>/prog/curdir/<user>/* files will be saved with savelogs.
The stored files can be found under following path name:

• Under Windows XP:
<userhome>\AppData\Local Settings\Temp\TopSpinSupportFiles_<Support-
Token><operating-system-user><year><month><day><hour><minute>.tar.gz

• Windows Vista:
<userhome>\AppData\Local\Temp\TopSpinSupportFiles_<Support-Token><operating-
system-user><year><month><day><hour><minute>.tar.gz

• Linux:
/tmp/TopSpinSupportFiles_<Support-Token>_<operating-system-
user><year><month><day><hour><minute>.tar.gz

For detailed information about saving all possible log files and about the upload to the Bruker
FTP-server please refer to the Processing Reference Command Manual.

4.3 How to Show or Kill TopSpin Processes
To show the currently running TopSpin processes, enter the command show or kill on the
command line. A list of processes will appear showing the process command, dataset etc.
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The figure above shows a list with one process (command xfb). To kill a process, select it in
the list and click the button Kill...
The command show all or kill all work like show and kill, except that they also show
TopSpin system processes. Note that killing such processes may kill TopSpin.

4.4 What to do if TopSpin Hangs
If, for some reason, TopSpin hangs, please do the following.
Under Linux:
1. Open a Shell.
2. Enter <tshome>/prog/bin/script/killtopspin, where <tshome> is the TopSpin installation

directory.
Under Windows:
1. Click Start => Programs => Bruker TOPSPIN => TOPSPIN 2.1 => Bruker Utilities 2.1

=> Miscellaneous.
2. In the appearing window:

Click killtopspin.
Normally, this kills all TopSpin processes including cpr, cprserver, dataserver and java.

4.5 How to Restart User Interface During Acquisition
If TopSpin hangs up during a data acquisition, you can restart the user interface without
disturbing the acquisition. To do that:
1. Open the file: <tshome>/prog/curdir/<user>/history where <tshome> is the TopSpin home

directory and <user> is the user who started TopSpin. Look for the term ’Java Virtual
Machine’ and check its PID.

2. Open the Task Manager (Windows) or System Monitor (Linux).
3. Stop the Java(w).exe process with the PID found in the history file.
4. Open a Windows Command Prompt or Linux Shell.
5. Go to the TopSpin Installation directory.
6. Enter topspin –client.
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5 Dataset Handling

5.1 The Topspin Browser
TopSpin offers a data browser from which you can browse, select, and open data.
The browser dialog offers the following tabs (see the figure below):

• Browser - data browser showing the data directory hierarchy.
• Last50 - list of the 50 last open datasets.
• Groups - list of user defined groups of datasets.
• Alias - list of user defined alias name.
• The Experiement Selector - easy access to the vast experiment library of standard

experiments
The browser appears at the left of the TopSpin window and can be shown/hidden with Ctrl+d
or by clicking the arrow buttons at the upper right of the browser.

The Browser Tab
The browser shows data directory trees and allows you to expandcollapse their elements.
The figure below shows the browser with three top level data directories and one dataset fully
expanded.

The dimensionality of the data is indicated with different colors:
• Black for 1D data.
• Blue for 2D data.
• Magenta for 3D data.

Furthermore, the browser shows:
• The pulse program with the dataset EXPNO (e.g. 1 - hxcoqf in the figure below).
• The title with the dataset PROCNO (e.g. CH-CO Cyclosporin in the figure below).

Note that the displayed pulse program is the:
• Status pulse program if an acquisition has been done (raw data exist).
• Setup pulse program if no acquisition has been done (raw data do not exist).
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The display of title and pulse program can be switched of (see table below).

Display => Display in current data window.

Display in New Window => Display in new data window.

Display As 2D Projection => Display 1D data as projection of active 2D data.

Schroll to active dataset => Scroll to PROCNO of active data window.

Fully Expand Selection => Fully expand selected node.

Show PULProg/Title => Switch pulsprogram/title display on/off.

Show Date => Show acq. date (expno) or last mod. date (name).

Sort by Date => Sort data by last modified date.

Copy => Copy dataset entry to clipboard.

File Properties => Show dataset properties.

Delete... => Delete selected entry (name,expno or procno).

Rename => Rename dataset name, expno or procno.

Files => Show files in selected entry (expno or procno).

Add New Data Dir... => Add new top level data directory.

Remove Selected Data Dirs... => Remove selected top level data directory.

The Last50 Tab
Clicking the Last50 tab displays the list of the last 50 displayed datasets. Each dataset that
you open is automatically added to the current list. The figure below shows a Last50 list with
four datasets. As in the browser, different colors are used to indicate the data dimensionality.

• Hit the Enter key to display the highlighted dataset in the current window.
• Double-click a dataset to display it in the current window.

Remove Selected Items From List => Remove the selected dataset from the list.

Open Saved Last 50 List... => Open a dialog to select a Last50 list.

Save Last 50 List As... => Open a dialog for saving the current Last50
list.

Each line displays one dataset showing its name, expno, procno, top level directory and user.

The Groups Tab
Clicking the Groups tab displays the list of user defined dataset groups. Here you can create,
modify and display groups of datasets. Defining a group is useful is you work on projects
where each project involves multiple datasets. It allows you to easily organize your projects
and access all data belonging to a certain project.

Display => Display selected dataset(s) in active window.

Display In New Window => Display selected dataset(s) in new window.
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Display Group => Display all datasets in group in new windows.

Add Selected Data Window => Add selected data window to selected group.

Add all Open Data Windows => Add all open data windows to selected group.

Update Window Bounds &
Display Limits

=> Update window bounds and display regions.

Remove Selected Datasets
From Group

=> Remove selected datasets from group.

Collapse All Groups => Collapse all groups.

Toggle Dim/Pulprog./Title => Show/hide dimension, pulse program, title.

Add new Dataset Group => Add a new (empty) dataset group to the list.

Close All Group Windows => Close all data windows of selected group.

Process Selected Datasets => Process selected dataset with serial processing.

File Properties => Show file properties of selected dataset.

Files => Show file list of selected dataset.

Copy => Copy pathnames of selected data to clipboard.

Note that a group not only defines the datasets involved, but also their data window positions
and dimensions and the displayed region of each spectrum.
The entry Update window bounds & displays regions

The Alias Tab
Clicking the Alias tab displays the list of user defined alias names for datasets. Just right-
click any entry to define, remove or interpret alias names.

Define Alias For Data In Selected Window => Define alias for data in selected window.

List Selected Alias => Show selected data name, expno etc.

List All Aliases => Show all data names, expnos etc.

Remove Selected Aliases... => Remove selected aliases from list.

List Available Alias Commands => Show available alias commands.

The Experiment Selector
The Experiment Selector is a new GUI. It provides an easy access to the vast experiment
library of standard experiments that is available in the standard release of TopSpin. It is also
a tool that allows the users to personalize their most frequently used standard experiments
into a separate library and therefore provides a simplified overview and a quick and easy
access to their most routinely used experiments. It should be pointed out that the current
version of the Experiment Selector does not provide access to the user libraries, only to the
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standard TopSpin experiment libraries. However, the potential and functionality of the
Experiment Selector is set to expand and improve in the future releases of the TopSpin
making it an important and valuable tool for the TopSpin users.

The Experiment Selector GUI may not appear in the browser area by default and can be
activated by selecting the “Browser Preferences” item from the drop-down menu pane that is
activated by a right click of the mouse with the pointer in the Browser area. Once the “Show
Experiments Tab” checkbox is selected click the “Apply” button and restart the TopSpin. The
“Experiments” tab should now appear in the browser area.
The experiments are grouped according to their application areas, such as small molecules,
proteins or drug discovery. Further grouping into sub-groups according to the type of
experiments may occur depending on the number of experiments that is available within a
particular group. For instance, the protein experiments are grouped into backbone
experiments, side-chain experiments and similar. Some experiments, for instance the multi-
receiver experiments, may also have an associated action item, in this case for adding a child
experiment. The action items are au-programs that reside in the standard au-program library.
The Personalized Library initially is empty and can be populated by simply dragging and
dropping individual experiments or groups from the standard TopSpin Library. Alternatively,
the experiments can be added manually by selecting the desired group of experiments and
selecting the “Create Data Set” entry from the drop down menu that is activated by a right
click of the mouse:
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How to Open the Browser in a separate window
The browser can be opened in a separate window as follows:
Click Options => Preferences [ set], click Window settings and check Display dataset
browser in a separate window.
You must restart TopSpin for the change to take effect.

How to Put the Focus in the Browser
• Hit the F2 key.

or
• Click inside the browser.

How to Select Folders in the Browser
To select a particular folder:

• Left-click the folder button.
or

• Hit the arrow-up/down keys while the focus is in the browser.

To select multiple folders:
• Hold the Ctrl key and left-click multiple folders to select them.

or
• Hold the Shift key and left-click two folders to select these two and all in between.

How to Expand/Collapse a Folder in the Browser
To expand a collapsed folder:

• Click the +(plus) button to the left of the folder button.
or

• Double-click the folder button.
or

• Hit the Right-Arrow key while the folder is highlighted.
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To fully expand a collapsed folder:
• Right-click the DIR, NAME or EXPNO node and choose Fully Expand Selection.

To collapse an expanded folder:
• Click the –(minus) button to the left of the folder button.

or
• Double-click the folder button.

or
• Hit the Left-Arrow key while the folder is highlighted.

How to Show/Hide Pulse program and Title in the browser
• Right-click the data name folder button and choose Show PULPROG /Title from the

popup menu:

To display Dataset Dates in the Browser.
• Right-click the data name folder button and choose Show Date.

The last modified date is shown to the right of the dataset NAME, whereas the acquisition
date is shown to the right of the dataset EXPNO:

How to change the default Top Level Data Directory
By default, the browser shows the TopSpin installation directory with the Bruker example
datasets. To suppress this feature click Options => Preferences [ set], click Administration
and uncheck Show TopSpin data examples directory in data browser.
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How to Add, Remove or Interpret Alias Names
To add an alias name:
1. Click the Alias tab in the browser.
2. Right-click in the Alias table to open the popup menu (see the figure below). Click Define

alias names for data in selected window.
3. Enter an alias name in the appearing dialog box and click OK. Note that alias names must

begin with a letter.

To remove an alias name:
1. Right-click the alias name.
2. Click Remove selected aliases... from the popup menu (see the figure below).
Furthermore, the popup menu offers entries to display the dataset, list its properties and print
the full dataset specification.

5.2 Creating Data

How to Create a New Dataset
1. Click File => New [ new, Ctrl+ n].

or

Click the button in the upper toolbar.
2. Specify the dataset name, expno, procno, dir, and user in the appearing dialog box. If one

or more datasets are open, the fields are initialized with the current dataset (see the figure
below).

3. Click the down-arrow of the Solvent box and choose a solvent from the list, or type a
solvent name.

4. Click the down-arrow of the Experiment box and choose a parameter set from the list, or
type a parameter set name.

5. Type the dataset title in the TITLE box.
6. Click OK.
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A dataset will be created and initialized with the parameters of the chosen experiment. No
FID or spectrum is available yet. They can be created by data acquisition and data
processing, respectively.

5.3 Opening Data
TopSpin allows you to open data in several ways, from the browser, the menu, the Windows
Explorer or the command line. Furthermore, data can be opened:

• In an existing data window replacing the current dataset.
• In a data window which is in multiple display mode, being superimposed on the current

spectra.
• In a new data window which becomes the active window.

Note that if a dataset is already displayed in one window and it is opened in a second existing
window, it still replaces the dataset in the latter one. As a result, the same dataset will be
displayed in two windows (see also command reopen).

How to Open Data Windows Cascaded
By default, a new data window appears maximized, filling the entire data field and covering
possibly existing windows. You can, however, configure TopSpin to open new windows
cascaded. This is convenient if you want to open several data windows and then select one.
To open new windows cascaded:
1. Click Options => Preferences [ set].
2. Click Window Settings in the left part of the dialog box. The right part of the dialog box

shows the window settings:

3. Check Open new internal windows ’cascaded’ rather than ’max’.
4. Optionally you can configure the cascaded windows by clicking the respective Change

button. This will open the dialog box shown below:
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5. Here you can specify the data window sizes and offsets as fractions of the maximum
window sizes.

6. Click OK to close the dialog box.

How to Open Data from the Browser
In the browser:

• Left-click-hold a data name, expno or procno and drag it into the data area. The data will
be displayed in a new data window.

or
• Left-click-hold a data name, expno or procno and drag it into an open data window. The

data will replace the currently displayed data.
or

• Left-click-hold a data name, expno or procno and drag it into an empty data window
created with Alt+ w n.

or
• Left-click-hold a data name, expno or procno and drag it into a multiple display data

window. The data will be superimposed on the currently displayed data.
or

• Right-click a data name, expno or procno and choose Display from the popup menu; the
data will be displayed in the current data window.

or
• Right-click a data name, expno or procno and choose Display in new window from the

popup menu; the dataset will be displayed in a new data window.
or

• Hold the Ctrl key and left-click several datasets to select them or hold the Shift key and
left-click two datasets to select these two and all in between. Then right-click one of the
selected datasets and choose Display from the popup menu. A new window will be
opened showing the selected datasets in multiple display mode. However, if the current
window was already in multiple display mode, the selected spectra will be superimposed
on the currently displayed spectra.
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How to Automatically Select the first expno/ procno of a dataset
If you open a dataset from the Browser by clicking a data name, there might be more that one
expno and/or procno available. By default, TopSpin then opens a dialog box from which you
can select the desired expno/procno combination (see the figure below). Clicking Open will
open the selected dataset, whereas clicking Print will print the displayed dataset list.
You can, however configure TopSpin to automatically open the first available expno/procno
combination. To do that:
1. Click Options => Preferences [ set].
2. Click Miscellaneous in the left part of the dialog box.
3. Uncheck the item Display EXPNO/PROCNO list when opening data..
4. Click OK to close the dialog box.

Note that the command rel also opens the dialog shown in the figure above, showing the
available EXPNO’s under the current dataset. Similarly, repl shows the available PROCNO’s
under the current dataset EXPNO.

How to Open Data from the TopSpin menu
To open a dataset:

• Click the File button in the upper toolbar.
or

• Click File => Open [ open, Ctrl+ o].

In the appearing dialog box:
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• Select the option Open NMR data stored in standard Bruker format.
• Select the browser type RE Dialog.
• Click OK.

In the appearing dialog box:

• Specify the dataset name, expno etc.
• Click OK.

Note that the dataset specification consists of the five variable parts of the data directory tree,
in this case:
C:\bio\data\ guest\nmr\ exam1d_1H\ 1\pdata\ 1
The text boxes are initialized with the dataset in the current data window.

How to Open Data from the Explorer, Konqueror or Nautilus
You can open a dataset from the Windows Explorer as follows:

• Open the Windows Explorer either:
– From the Windows Start button. Navigate to the data name, expno or procno.

or
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– By entering the command expl in TopSpin. The Explorer shows the contents of the
current dataset procno directory. Navigate to the desired data name, expno or procno.
expl can also be used with the argument top to open the TopSpin installation
directory, home to open user home directory or with an absolute pathname to open
that directory.
The command expl spect opens the Explorer in <tshome>/conf/instr/ current
instrument>
The command expl prop opens the Explorer in the user’s properties directory User-
HOME/topspin<name_of_PC>/propBy entering expl <illegal argument> all
available options are shown.

• Now you can open a dataset with:
– drag & drop: click-hold a dataset name or any of its sub-folders or files and drag it

into the TopSpin data area or data window.
or

– copy & paste: right-click a dataset and choose copy from the popup menu. In
TopSpin, click Edit => Paste [ paste]:

Likewise, a dataset can be opened from the Windows window or Internet Browser.

How to Open Data from the Command Line
To open a dataset from the command line:
1. Enter re.
2. Specify a dataset in the appearing dialog box.
3. Click OK.

To open a new procno of the current dataset:
1. Enter rep.
2. Specify a procno in the appearing dialog box.
3. Click OK.

To open a dataset in a new window:
1. Enter rew.
2. Specify a dataset in the appearing dialog box.
3. Click OK.

To open a new procno of the current dataset in a new window:
1. Enter repw.
2. Specify a procno in the appearing dialog box.
3. Click OK.
To open a data browser and read a dataset from there:
1. Enter reb.
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2. Select a dataset from the appearing dialog box.
3. Click Display.
Note that re, rep and reb:

• Replace the data in the currently selected data window.
• Open the data in a new window when they are used after typing Alt+ w n.
• Add the data in the currently selected window if this is in multiple display mode, whereas

rew and repw always open the dataset in a new window.
TopSpin 2.0 and newer allows opening datasets stored in the following directories structures:
<mydata>/<dataname>/<expno>/pdata/<procno>
To do that:
Enter reb on the command line, browse to the desired dataset and click the Display button.

Open the Operating System File Browser, browse to the desired dataset and open it in
TopSpin with Copy & Paste or Drag & Drop.
Note that this will create a copy of the dataset in the standard TopSpin data path:
<tshome>/data/<user>/nmr/<dataname>/<expno>/pdata/<procno>
Where <user> is the current internal TopSpin user. This copy can be processed, deleted or
overwritten, even if the original dataset is write protected. The original data set is left
unchanged.

How to Open Special Format Data
Apart from the standard Bruker data format, TopSpin is able to read and display various other
formats. To do this:
Click File => Open [ open, Ctrl+ o].
Select the option Open NMR data stored in special formats, select the desired file type
(see the figure below) and click OK.
A dialog will appear which depends on the chosen file type. Just follow the instructions on the
screen.
The following file types are supported:

• JCAMP-DX - Bruker TopSpin data stored in JCAMP-DX format. Note that the TopSpin
data format is identical to the XWIN-NMR data format.

• Zipped TopSpin - Bruker TopSpin data stored in ZIP format.
• WINNMR - Bruker WINNMR data.
• A3000 - Bruker Aspect 3000 data.
• VNMR - data acquired on a Varian spectrometer.
• JNMR - data acquired on a Jeol spectrometer.
• Felix - 1D data, FID or spectrum, which are stored in FELIX format.

Note that in all cases, the data are stored in a single data file which is unpacked/converted to
standard Bruker format, i.e. to a data directory tree.
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How to Open a ZIP or JCAMP-DX file from the Windows Explorer
Data stored in ZIP or JCAMP-DX format can also be opened directly from the Windows
Explorer. You can do that in one of the tree following ways:
Drag & drop

• Click-hold a file with the extension .dx or .zip and drag it into the TopSpin data area or 
data window.

Copy & paste
1. Right-click a file with the extension .dx or .zip and choose copy from the popup menu.
2. In TopSpin, click Edit => Paste [ paste].
Associate JCAMP-DX files with a script
1. Create a file with the extension .cmd (e.g. jcamp.cmd) with a text editor.
2. Enter the following line:

<tshome>\prog\bin\sendgui.cmd fromjdx %1
and store the file.

3. Open the Explorer and find the JCAMP-DX file.
4. Right-click the filename and choose Open with => Choose program => Browse.
5. Find and select the script and click OK.
Now, every file with the extension .dx will automatically be opened in TopSpin when double
clicked.

5.4 Saving/Copying Data

How to Save or Copy Data
You can save the current dataset as follows:
1. Click File => Save [ Ctrl+ s].

This will open a dialog box:
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2. Select an option and, if applicable, a file type.
3. Click OK to execute the option.
The options correspond to the following command line commands:

• wrpa - copies the current data to a new data name or expno.
• toccpn - convert experiment information to ccpn format.
• tozip  - convert a dataset of any dimension to ZIP format.
• tojdx  - convert a 1D or 2D dataset to JCAMP-DX format.
• totxt  - convert a 1D or 2D dataset text format.
• wpar  - write parameter set.
• convdta  - save digitally filtered data as analog filtered data.
• wrp , wra, genfid, wmisc - write various files.

How to Save an Entire Dataset
1. Click File => Save [ Ctrl+ s].
2. Select the option Copy dataset to a new destination [ wrpa] and click OK.
3. Specify the dataset variables and click OK.

How to Save Processed Data
1. Click File => Save [ Ctrl+ s].
2. Select the option Save other file.
3. Select File type Processed data as new procno [ wrp] and click OK.
4. Enter a processing number (procno) and click OK.

How to Save Acquisition Data
1. Click File => Save [ Ctrl+ s].
2. Select the option Save other file.
3. Select File type Acqu. data as new expno [ wra] and click OK.
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4. Enter a experiment number (expno) and click OK.

How to Save Processed Data as Pseudo Raw Data
1. Click File => Save [ Ctrl+ s].
2. Select the option Save other file.
3. Select File type 1r/1i as fid [ genfid] or 2rr/2ii as ser [ genser].
4. Click OK.
5. Enter a destination expno.
6. Click OK (optionally, you can specify further data path specifications).

5.5 Deleting Data

How to Delete a Specific Dataset
• Right-click the data name, expno or procno in the browser, then click Delete...

A confirmation dialog will appear. Just click OK, if you are sure you want to delete. Note that
TopSpin does not allow you to delete the last available dataset, e.g. the last procno under an
expno, the last expno under a name or the last name under a user.

How to Delete Types of Datasets
To delete certain types of data like 1D raw data, 2D processed data etc.:

• Click File => Delete...
or

• Enter delete on the command line.
The dela dialog window will appear (see Renaming Data [}  54]). Here you can select the
data type and selection criteria.

5.6 Renaming Data

How to Rename a Specific Dataset
1. Right-click the data name, expno or procno in the browser, then click Rename...
2. In the appearing dialog: Enter the new name, expno or procno.
3. Click OK.



Dataset Handling

H9469SA3_2_003 55

4. Select a data type option
For each option, the corresponding command appears in the title of the dialog box. These
commands can also be used to delete data from the command line.

5. Specify the Required parameters
Note that you can use the wildcards:

– Asterix (*) for any character and any number of characters.
– Question mark (?) for any single character.

6. Click OK
A dialog box will appear showing the matching datasets. For example, if you select the
option An entire dataset ...:

– Select dataset entries for deletion (selected entries are highlighted). To select multiple
entries: click them holding the Shift or Ctrl key.

– Click OK to delete the entire data directory.
If you select the option Acquisition data or Processed data, you can choose between
deleting the data files only and deleting the entire expno or procno directory, respectively:

5.7 Searching/Finding Data

How to Find Data
You can find TopSpin data according to various criteria. To start searching, do the following:
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1. Click Edit => Find data [ Ctrl+f | find]to open the Find data window:

2. Enter the search items in the upper part of the dialog. Note that:
– There will be searched for items containing the specified string.
– Exact matching is performed for dataset variables, NAME, EXPNO, PROCNO and

USER, if the checkboxes at the right are enabled.
– The search is restricted to data created between the specified dates. Note that this

refers to the acquisition date.
– The Reset mask button allows you to reset the default criteria.

3. Select the Data directories to be searched in the lower part of the dialog. If no directories
are selected, all will be searched.

4. Click OK to start the search. A list of data that fulfill the defined criteria will appear:

Note that on exiting TopSpin, the search criteria will be rest to default.

How to Display one of the Found Datasets
In the search result window (see figure above):
1. Click one or more datasets to select them.
2. Click Display to display the selected dataset(s) in the current data window. If multiple

datasets are selected they are displayed in a new data window in multiple display mode.
The search result window offers a right-click context menu with various options:
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Display
Display the selected dataset(s) in the current data window. If multiple datasets are selected
they are displayed in the same data window in multiple display mode. Equivalent to clicking
the Display button or pressing Enter.

Display In New Window
Display the selected dataset(s) in a new window. If multiple datasets are selected they are
displayed in the one new data window in multiple display mode.

Display As 2D Projection
Display the selected dataset as a projection of the current 2D dataset. A dialog will appear
allowing you to choose F1-projection, F2-projection or both. If multiple datasets are selected,
only the first one is considered. If the current dataset is not a 2D dataset, nothing happens.

Sort This Column
Sort the selected column in ascending order.

Sort + Reverse
Sort the selected column in descending order.

Save Selection in file...
Save the list of selected datasets in a text file. First opens a file dialog where you can select
or specify a filename. The saved dataset list can, for example, be used for serial processing
(command serial, see also Process Selected Datasets below).

Add selection to dataset group...
Selected datasets can be defined as dataset group.

File properties
Show main dataset parameters like Dimension, Pulse program, Acquisition Date, Nuclei,
Spectrometer frequency and Solvent.

Files
Show the files in the processed data directory of the selected dataset.
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Process Selected Datasets
Perform serial processing on the selected datasets. Opens a dialog where you can change or
edit the dataset list and specify the command, macro or Python program to be executed
(starts the command serial).
The Close button allows you to close the search result dialog.

5.8 Handling Data Files

How to List/Open the Current Dataset Files
A Bruker dataset is represented by a directory tree which contains files in the expno and
procno subdirectories. These files contain the actual data, parameters, lists etc.

• Right-click inside the data window and choose Files from the popup menu.

If the spectrum is displayed, the files in the procno subdirectory are shown. If the Fid is
displayed, the files in the expno subdirectory are shown.

• Select a file and click Open to view its contents.
Note that this only makes sense for ascii files.

How to List/Open the current Dataset Files in the Windows Explorer
To list the current dataset files in the Windows Explorer:
1. Click File => Run...
2. Select Open file explorer [ expl] in the appearing dialog box.
3. Click OK.
Alternatively, you can enter the command expl on the command line.The Windows Explorer
will be opened showing the processed data files (the files in the procno directory) of the
current dataset. Under Linux a Web browser like KDE Konqueror or Gnome Mozilla will be
opened.
To open a file:
Double-click the file or right-click the folder icon and choose Open
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If TopSpin data area contains no datasets, the expl command opens the Explorer showing
the users home directory. When entered on the command line, expl can also be used with
the argument top to open the TopSpin installation directory, home to open user home
directory or with an absolute pathname to open that directory.
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6 Parameter Handling

6.1 Processing Parameters
Processing parameters can be set/changed in three different ways:

• From the parameter editor: click the ProcPars tab or enter edp.
• From the command line: e.g. enter si.
• From a command dialog box: e.g. wm.

How to Set a Processing Parameter from the Command Line
Enter the parameter name on the command line. For example to set the size:
1. Enter si.

For 1D data, the following dialog box will appear:

For 2D data, the following dialog box will appear:

2. Specify the desired value(s), e.g. 32768 or 32k.
3. Click OK.

How to Set Processing Parameters from the Parameter Editor
To open the processing parameter editor:

• Click the ProcPars tab in the Tab bar of the data window.
or

• Enter edp on the command line.
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At the left of the parameter editor window you will see a list of parameter sections.
The processing parameter editor supports the following functions:

• Collapse/expand a parameter section by clicking the  button. Note that the section
Window function is collapsed.

• Collapse/expand all parameter sections by clicking the large  button of the data window
toolbar.

• Enter (part of) a parameter name in the search field and click .
• Click a parameter section, e.g. Phase at the left of the dialog box. The section becomes

highlighted and the corresponding parameters will appear in the right part of the dialog
box.

• Click in a parameter field, e.g. PHC0, to set the parameter value.

• Click the button to the right of parametes like AUNMP to open a list of the
corresponding programs/lists.

• Right-click the  button to the right of parameters like AUN-MP to open the current
program/list with an editor.

• Hit the Tab key to jump to the next parameter field.
• Hit Shift + Tab to jump to the previous parameter field.
• Use the scroll bar at the right of the dialog box to move to parameters further up or down

in the dialog box.

How to Undo the Last Processing Parameter Change
• Click the following button:

Undo last parameter change.

How to Display Processing Status Parameters
• Click the following button:

Show processing status parameters.
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Note that the command dpp opens the parameter editor and automatically shows the status
parameters.

How to Switch to Maxent parameters
• Click the following button:

Switch to Maxent parameters.

How to Change Processed Data Dimensionality
• Click the following button:

Change data dimensionality.
This changes the number of parameter columns and value of the processing parameter 
PPARMOD. Topspin 2.1 and newer support data dimensionalities up to 8D.
The parameter editor does not allow you to modify status parameters. Processing status
parameters reflect the status of the processed data and are used for further processing,
display or plotting. Changing them can make the dataset inconsistent. In rare cases,
however, it can be useful to change a status parameter and Topspin allows you to do that
from the command line. If, for instance, you want to change the F1 status parameter MC2 of
a 2D dataset, you have to enter:
s mc2
Note that the command s is used for 1D, 2D and 3D dataset. Topspin automatically
recognizes the dimensionality of the data and displays the parameter in all relevant
dimensions. Note that, for example, the parameter MC2 only exists in F1.

6.2 Acquisition Parameters

How to Set Acquisition Parameters
Acquisition parameters can be set/changed as follows:

• From the parameter editor: click the AcquPars tab or enter eda.
• From the command line: e.g. enter td.
• From the interactive parameter adjustment window (enter gs).

How to Set an Acquisition Parameter from the Command Line
Enter the parameter name on the command line. For example to set the time domain size:
1. Enter td for 1D data, the following dialog box will appear:

For 2D data, the following dialog box will appear:
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2. Specify the desired value(s), e.g. 65536 or 64k.
3. Click OK.

How to Set Acquisition Parameters from the Parameter Editor
To open the acquisition parameter editor:

• Click the AcquPars tab in the Tab bar of the data window.
or

• Enter eda on the command line.

The figure below shows an example of the acquisition parameter editor with the Experiment
parameters displayed.

The processing parameter editor supports the following functions:

• Collapse/expand a parameter section by clicking the  button. Note that the section
Width is collapsed.

• Collapse/expand all parameter sections by clicking the large  button of the data window
toolbar.

• Enter (part of) a parameter name in the search field and click .
• Click a parameter section, e.g. Experiment at the left of the dialog box. The section

becomes highlighted and the corresponding parameters will appear in the right part of the
dialog box.

• Click in a parameter field, e.g. TD, to set the parameter value.
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• Click the button to the right of parameters like PULPROG to open a list of the
corresponding programs/lists.

• Right-click the  button to the right of parameters like PULPROG to open the current
program/list with an editor.

• Hit the Tab key to jump to the next parameter field.
• Hit Shift + Tab to jump to the previous parameter field.
• Use the scroll bar at the right of the dialog box to move to parameters further up or down

in the dialog box.

How to Undo the Last Acquisition Parameter Change
• Click the following button:

Undo last acquisition parameter change.

How to Set Pulse Program Parameters
• Click the following button:

 Show pulse program parameters [ ased].

The button will change to . To make this the default setting:
Click Options => Preferences, click Miscellaneous, check the entry Show ased parameter
selection with eda and click OK.

How to Display Acquisition Status Parameters
• Click the following button:

Show acquisition status parameters.
Note that the command dpa opens the acquisition parameter editor and automatically shows
the status parameters.

How to Get Probehead/Solvent dependent Parameters
• Click the following button:

Set probe/solvent dependant parameters [ getprosol].
Probe and solvent dependent parameters can be set up with the command edprosol.

How to Change Acquisition Data Dimensionality
• Click the following button:

Change data dimensionality.
This changes the number of parameter columns and value of the acquisition parameter 
PARMODE.

How to Set Lock Parameters
Enter the command edlock and set the lock parameters in the appearing dialog box. For a
detailed description of edlock, please refer to the Acquisition Reference manual or enter
edlock? on the command line.
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How to Set Routing Parameters
Enter the command edasp and set the routing parameters in the appearing dialog box. For a
detailed description of edasp, please refer to the Acquisition Reference manual or enter
edasp? on the command line.
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7 Data Processing

7.1 Interactive Processing
Interactive processing allows full control over the processing sequence. However, it requires
detailed knowledge about the required parameters (see chapter Startup TopSpin [} 13]) and
commands. Therefore, it is only suitable for the advanced user. New or intermediate users
are recommended to use the Processing Guide for semi-automatic processing (see chapter
Configuration [} 13]).

How to Process Data with Single Commands
Data can be processed by entering single commands on the command line. A typical 1D
processing sequence would be:
em: exponential window multiplication.
ft: Fourier transform.
apk: automatic phase correction.
sref: automatic calibration (referencing) .
abs: automatic baseline correction.
This allows you full control over each individual processing step.

How to Process data with Composite Commands
Data can also be processed with so called composite commands. These are combinations of
single processing commands. The following composite commands are available.

• ef: Exponential multiplication + Fourier transform.
• efp: Exponential multiplication + Fourier transform + phase correction.
• fmc: Fourier transform + magnitude calculation.
• fp: Fourier transform + phase correction.
• gf: Gaussian multiplication + Fourier transform .
• gfp:  : Gaussian multiplication + Fourier transform + phase correction.

They can be entered on the command line or clicked from the menu. For the latter option:
Click Processing => More transforms => Shortcuts
Just like single commands, composite commands can be used in Macros, AU programs and
Python programs.

7.2 Semi-automatic Processing

How to Use the 1D Processing Dialog
1D data processing often involves the same sequence of steps, which can easily be
performed as follows: 
1. Click Processing => Process / Plot Current data.
2. In the appearing dialog (see the figure below):

– Enable the desired processing/plotting steps.
– Set the parameter LB for exponential multiplication.
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– Select the desired LAYOUT for plotting.
– Click OK.

How to Use the Processing Guide in Automatic mode
The Processing Guide in automatic mode guides you through the entire processing sequence
of data selection, processing, printing and archiving with minimum user interaction.
1. Click Processing => Data => Processing Guide.

The Processing Guide window will appear as an integral part of the current data window
(see the figure below).
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2. In the Processing Guide window:
– Check Automatic mode.
– Click Open data set and click OK to open a dataset manually, e.g. from the browser

or click Browse to open the File Chooser.
– Click Window function => Fourier Transform => etc.

Each processing step will be executed without user interaction.
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How to Use the Processing Guide in Interactive mode
The Processing Guide in interactive mode guides you through the entire processing
sequence of data selection, processing, printing and archiving requiring some user
interaction.
1. Click Processing => Data => Processing Guide

The Processing Guide window will appear as an integral part of the current data window.
2. In the Processing Guide window:

– Uncheck Automatic mode.
– Click Open data set and click OK to open a dataset manually, e.g. from the browser

or click Browse to open the File Chooser.
– Click Window function => Fourier Transform => etc.

For each step a dialog box will appear where you can enter options, parameters etc. For
details on these items, please refer to the corresponding commands in the Processing
Reference Guide.

7.3 Processing Data with AU programs
Data processing can be performed by using AU programs. An AU program is actually a C-
program which contains TopSpin commands (macros) and/or C-language statements.
Various standard AU programs are delivered with TopSpin. A typical 1D processing AU
program is proc_1d. A simplified version of this AU program is:
EF
APK
SREF
ABS
AUTOPLOT
QUIT
It executes the commands ef, apk, sref, abs and autoplot. To run this AU program, just
enter proc_1d on the command line. Before you can use any Bruker AU program, expinstall
must have been executed once. You can create your own AU programs with the command
edau. Note that an AU program must end with QUIT or QUITMSG("your message"), and that
all statements must be specified in capital letters. For more information on AU programs,
please refer to the AU programming manual:
Click Help => Manuals => [ Programming Manuals] AU Programming
As an alternative to AU programs, you can also write Python programs, which allow you to
use TopSpin commands, User Interface functions and Graphic functions. For more
information:
Click Help => Manuals => [ Programming Manuals] Python Programming

7.4 Serial Processing
TopSpin allows you to process a series of datasets using serial scripts. The dataset list and
command(s) to be used can be easily setup from the TopSpin interface as follows. Enter the
command serial on the command line. This will open the dialog window shown in the figure
below.
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The same dialog window will be shown by using the menu bar Processing Serial Processing.
The dialog offers you the following options:
Browse for list
This buttons opens an Explorer in which you can locate an existing dataset list.
Find Datasets
You can for Datasets in all data directories marked in the appearing dialog window list:

Edit List
This button will open a text editor in which you can edit the current or a new dataset list.
Next
After having defined the full dataset path and clicking next the following dialog will appear:
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Continue with command definition, for example for Macros or Python programs. You can
even browse for Macros or Python programs. The following dialog will appear, dependent
from your selection:

After having chosen a Python program or a Macro, push the button execute for finishing
serial processing command. In the figure below you can see the look of the actual dialog.
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After executing the serial processing, TopSpin 2.1 and newer displays following feedback-
dialog:

Cancel
Leave this dialog.
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8 Printing/Exporting Data

8.1 Printing/Plotting Data

How to Print/Plot from the Menu
The current data window can be printed as follows:
1. From the TopSpin menu:

– Click the button  in the upper toolbar.
– Or click File => Print.
– Or enter print or Ctrl+p.

All these actions are equivalent; they open the Print dialog box (see the figure below).

2. In the Print dialog box:
– Select Print active window [prnt].
– Click OK.

Before printing starts, the operating system print dialog box will appear. Here you can, for
example, select the printer name and the printer properties.

The Print dialog box (see the figure below) contains two further options:
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• Print with layout - start Plot Editor [Plot]  - If you select this option and click OK , the
Plot Editor will be started. This option is equivalent to entering on the command line." /
>[ plotIf you select this option and click , the Plot Editor will be started. This option is
equivalent to entering on the command line." />]If you select this option and click OK, the
Plot Editor will be started. This option is equivalent to entering plot on the TopSpin
command line.

• Print with layout - plot directly [autoplot] - Selecting this option activates the Plot Editor
layout list box. Select the desired layout and click to print. Standard layouts are delivered
with TopSpin. They use the Windows default printer. User defined layouts use the printer
defined in the Plot Editor. On a 1D dataset, only 1D layouts are listed, on a 2D dataset
only 2D layouts are listed etc.

For the last two options, the following required Parameters are available:
Use plot limits

• From screen/ CY - The plot limits and maximum intensity are used as they are on the
screen (processing parameter F1P, F2P and CY, respectively).

• From Plot Editor Reset Actions - The plot limits and maximum intensity are set
according to the Plot Editor Reset Actions (right-click inside the Plot Editor data field and
choose Automation to set the Reset Actions).

• As saved in Plot Editor - The plot limits and maximum intensity are set in the specified
layout

Fill dataset list
• From your default portfolio - The portfolio contains the current TopSpin dataset plus the

data from the default Plot Editor portfolio.
• From portfolio saved in dataset - The portfolio contains the current TopSpin dataset

plus the data from the portfolio stored in this dataset.

Override Plotter saved in Plot Editor
If enabled, the plotter defined in the Plot Editor layout will be overridden by de plotter defined
by the processing parameter CURPLOT.

How to Plot Data from the Processing guide
Printing/plotting data can be done from the Processing guide by clicking the Plot/Print
button. If Automatic mode is checked, the active data window will be printed as it appears in
the screen. If Automatic mode is unchecked, you will get the dialog box as displayed in the
figure below.

How to Plot Data with the Plot Editor
The Plot Editor can be started from the Print dialog or from the command line (command
plot). The Plot Editor allows you to create layouts and plot data. The complete functionality is
described in the online manual, which can be opened as follows:
Click Help => Manuals => [Automation and Plotting] Plotting

How to Print the Integral list
1. Click the Integrals tab of the data window (see the figure below).
2. Enter print or Ctrl+ p to print it.
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How to Print the Peak list
1. Click the Peaks tab of the data window (see the figure below).
2. Enter print or Ctrl+ p.

8.2 Exporting Data

How to Copy data to Other Applications
Under MS Windows, you can easily copy the data window contents to other applications. To
do that:
Click Edit => Copy [ copy].
This will copy the data window contents to:

• The clipboard. After that you can paste the clipboard contents to any Windows application.
On Windows systems the command Edit => Copy [ copy] saves bmp-format, whereas the
command copy wmf stores the old wmf-format.
On Linux systems the command copy stores png-files into a temporary file. The pathname of
this file is copied to clipboard.
Please note:
Some programs, when importing spectra from the clipboard or metafile, do not display the
contained information correctly. Particularly when you resize the imported graphics, sections
of the text, the spectrum, or the axis sometimes have disappeared. Usually this is only a
display problem. When you print the respective page, the representation is correct.

How to Store (Export) a Data Window as Graphics File
The clipboard and metafile formats are resizable vector formats. In addition to this, TopSpin
allows you to save the contents of a data window in a graphics file of selectable type.
Supported formats are .png, .jpg, .jpeg, .bmp, .emf, .wmf and .pdf. To do that:
1. Click File => Export.... [ exportfile].
2. Navigate to the storage folder.
3. Enter the destination filename and extension.
4. Click Export.
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The resolution of such a screen dump equals the resolution of your screen. When you import
a graphics file into another program, you may lose information when resizing the graphics.
Note that exporting a data window to PDF-format is only supported in TopSpin 2.1 and
newer.

How to export projections of peak lists
Certain situations may require that the user wants to store a projection of a peak list (e. g. in
order to evaluate an assignment in a 3D by verifying the annotated projected 2D-HSQC peak
list on the respective 2D spectrum). Therefore it is useful and timesaving to use the option
"export projections of peak lists".
In order to create such a peak list projection, the following steps must be executed:
1. Switch to the peaks tab of the data set from which the peak list projection should be used.
2. Choose Export... from the peak table context menu (right-click).
3. Select the Project Peaks flag in the options panel of the appearing export dialogue.

Please note that the active flag Project Peak invokes the export of the entire projections
peak list. If separate peaks should be exported, they must be selected in the peak table
and the flag Export selected data must be set.
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In the dialogue box the file format can be changed according to the required application.
4. Define the desired options in the upcoming projections dialogue window (i.e. target

dimension and axis mapping).

The exported peak list is now of the specified dimension, where the axis are projected
according to the specified axis mapping.
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9 1D Display

9.1 The 1D Data Window
The 1D data window consists of a data field, a title bar, a Tab bar and buttons. The figure
below shows a data window with a 1D spectrum.

9.2 Displaying one Dataset in Multiple Windows
TopSpin allows you to display one dataset in multiple data windows. This is, for example,
convenient to view various regions or various objects (spectrum, fid, parameters etc.) of the
same dataset.

How to Reopen a Dataset in a Second/Third etc. Window
1. Select (activate) the desired dataset.
2. Click File => Reopen [ reopen].
Multiple data windows with the same dataset are indicated with a number in square brackets,
e.g. [1], in the title bar:
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How to Rescale or Shift one Dataset in Multiple windows

Display buttons like and only work on the active data window.  The same counts for the
keys Alt+ PageUP and Alt+ PageDown. However, when used with the control key, they
work on all windows, for example:

Hit Ctrl+  Ctrl+Alt+PageUp or Ctrl+Alt+PageDown.

9.3 Changing the Display of a 1D Spectrum or FID
TopSpin offers buttons to scale or shift the spectrum vertically and horizontally.

How to Change the Vertical Scaling of the FID or Spectrum
Hit one of the following the keys:

• Alt+ PageUp: Increase the intensity by a factor of 2.
• Alt+ PageDown: Decrease the intensity by a factor of 2.
• Alt + Enter: Reset the intensity.

or
Click one of the following buttons:

 Increase the intensity by a factor of 2 [ *2].

 Increase the intensity by a factor of 8 [ *8].

 Decrease the intensity by a factor of 2 [ /2].

 Decrease the intensity by a factor of 8 [ /8].

 Reset the intensity [ .vr].
Alternatively, you can enter the corresponding commands as specified between square
brackets [].
To manipulate all data windows, press the Ctrl key while clicking one of the above buttons.
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How to Smoothly Change the Vertical Scaling of the FID/Spectrum

• Click-hold the  and move the mouse.
or

• Turn the mouse wheel while the cursor is in the data window.

How to Change the Horizontal Scaling of the FID or Spectrum
• Click-hold the button and move the mouse:

 Zoom in/out smoothly.
or

• Click one of the following buttons:

 Zoom in to the center (spectrum) or left edge (FID) of the displayed region, increasing
the horizontal scaling. [.zi].

 Zoom out from the center (spectrum) or left edge (FID) of the displayed region,
decreasing horizontal scaling) [.zo].

 Perform an exact zoom via a dialog box [.zx].
• Enter the coordinates of the desired region in the dialog box:

• Click OK

 Undo last zoom [ .zl].

 Reset horizontal scaling to show the full spectrum [ .hr].

 Display the entire spectrum (baseline position and intensity scaling are adjusted if
necessary) [.all]

 Toggle interactive zoom mode. When switched off, interactive zooming only selects a
horizontal region; baseline position and intensity scaling remain the same. When switched
on, interactive zooming draws a box selecting the corresponding area.

 Retain horizontal and vertical scaling when modifying dataset or changing to different
dataset [.keep]. Effects all data windows.
Alternatively, you can enter the corresponding commands as specified between square
brackets [].

How to Shift a Spectral Region to the Left or to the Right
• Click-hold the following button and move the mouse:
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 Smoothly shift to left or right. 
or

• Click one of the following buttons:

 Shift to the left, half of the displayed region [ .sl].

 Shift to the right, half of the displayed region [ .sr].

 Shift to the extreme left edge of the spectrum [ .sl0].

 Shift to the extreme right edge of the spectrum [ .sr0].
Alternatively, you can enter the corresponding commands as specified between square
brackets [].

How to Shift the Spectrum Up or Down
To shift the FID or spectrum display up or down:

• Click-hold the button and move the mouse:

 Smoothly shift the spectrum baseline up/down.
or

• Click one of the following buttons:

 Shift the spectrum baseline to the middle of the data field [ .su].

 Shift the spectrum baseline to the bottom of the data field [ .sd].
Alternatively, you can enter the corresponding commands as specified between square
brackets [].

9.4 Using the Tab Bar
Tabs of the data window can be activated by clicking them or by entering the corresponding
commands, as specified between square brackets, on the command line. Note that command
line commands always work on the currently selected (active) data window.
The Tab bar can be configured from the User Preference box (command set).

How to Display the Spectrum
• Click the Spectrum tab [ spec].

This displays the processed data. If these do not exist, the text ‘ No processed data available’
appears.
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How to Set Processing Parameters
• Click the ProcPars tab [ edp].

This opens the processing parameter editor (see also chapter Startup TopSpin [} 13]). The
following extra buttons are available:

 Undo last value change. Can be used to undo multiple changes.

 Switch to Maxent parameters.

 Status parameter display. The button turns green when activated [ dpp].

 Change processed dataset dimensionality (parameter PPARMOD).

 Collapse/expand all parameter sections.

 Search for specified parameter.
Changed parameters are automatically saved.

How to Set Acquisition Parameters
• Click the AcquPars tab [ eda].

This opens the acquisition parameter editor (see also chapter Startup TopSpin [} 13]). The
following extra buttons are available:

 Undo last value change. Can be used to undo multiple changes.

 Show pulse program parameters [ased].

 Status parameter display. The button turns green when activated [ dpa].

 Set probe/solvent dependent parameters [getprosol].

 Set nuclei and routing [edasp]

 Change raw dataset dimensionality (parameter PARMODE).

 Collapse/expand all parameter sections.

 Search for specified parameter.
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Changed parameters are automatically saved.
Note that the ... and E button to the right of the PULPROG parameter allow you to show the
pulse program list or edit the current pulse program, respectively.

How to Edit the Title
Click the Title tab [edti].

This allows you to edit the title that appears in the data window and on the plot.

 Save the title file under its current name.

 Save the title file under a new name.

 Reload the title file. Undo modifications since the last save.

 Open the title file with the external editor (defined in User Preferences).

How to Edit the Pulse Program
• Click the PulsProgtab].

This allows you to edit the current pulse program. The following extra buttons are available
here:

 Toggle status pulse program.

 Start the graphical pulse program display [ edcpul].

 Show the pulse program in an external editor [ nmrsim].

 Search for more info in the knowledge base.

How to Display the Peak list
Click the Peaks tab.
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This displays the peak list. By default, the peak list shows the following entries:
Peak: the peak number.
v(F1) [ppm]: the chemical shift.
Intensity [abs]: the absolute peak intensity.
Intensity [rel]: the relative peak intensity.
Half width [ppm]: the peak width at half-height.

Display the spectral region around a peak
Right-click the desired peak.
this will open the popup menu shown in the figure below:

Here you can choose from the following options:
Show spectrum => In correlated window to open a new data window showing the full
correlated spectrum.
Expand spectrum => In current window to change the current data window to spectrum
display, showing the region around the selected peak.
Expand spectrum => In correlated window to open a new data window showing the region
around the selected peak.
Edit AnnotationEdit the annotation of the current peak.
Define as reference => Complete table Define the entire peak table as a reference for
annotation.
Define as reference => Selection Define the selected peaks as a reference for annotation.
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Annotate by reference... Create annotations according to the peak list of the reference
dataset. You will be prompted for the allowed variation in chemical shift.
Shift peaks... Shift all peaks. You will be prompted for the number of ppm to be shifted.
Show detailed information Show peak information, dataset information and peak picking
parameters.

Export entries of the peak list
Entries of the peak list can easily be exported to Excel or any other program as follows:
1. For multiple peaks:

Select the desired entries while pressing the Ctrl or Shift key.
2. Right-click a peak entry to open the popup menu.
3. Click Export... to export the selected peaks.
4. This opens a dialog box where you can specify the filename and file type. For the latter

you can choose from:
• Auremol peaklist (.ml).
• Comma Separated Values (.cvs).
• Mixed Shape deconvolution peak list (peaklist).
• TOPSPIN peak list (.xml).
• XEASY peak list (.peaks).
• XWIN-NMR peak list (.txt).

Important: Check the box in the lower-left corner to export the selected peaks only or
uncheck it to export the entire list. Then click Export.

Delete/remove peaks from the peak list
To delete one peak:
Right-click the peak and choose Delete from the popup menu.
To delete multiple peaks:
1. Select the peaks while pressing the Ctrl or Shift key.
2. Right-click one of the peaks and choose Delete from the popup menu.
To remove possible duplicate peaks:
Right-click any entry and choose Remove => Duplicate peaks.
To remove possible peaks outside of the spectrum:
Right-click any entry and choose Remove => Peaks positioned outside of the spectrum.
To remove solvent peaks:
Right-click any entry and choose Remove => Solvent Peaks.

Copy the peak List
Instead of exporting entries of the peak list, they can also be copied to the Clipboard and
pasted to another application like Excel. To do that:
1. For multiple peaks:

Select the desired entries while pressing the Ctrl or Shift key.
2. Right-click a peak entry to open the popup menu.
3. Click Copy... to copy the selected peaks to the Clipboard.
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Print the peak List
To print the peak list:
Right-click a peak entry and choose Print...
or
Enter print on the command line.
or
Press Ctrl-p.
All actions will print the entire peaklist.
To preview a print:
Right-click a peak entry and choose Print preview...

Import a peak List
A peak list from a different dataset or program can be imported as follows:
1. Right-click an entry to open the popup menu.
2. Click Import...
3. In the appearing dialog box, navigate to the directory where the list resides and select the

peak list, choosing from:
• Auremol peaklist (.ml).
• MULABEL peak list (labels).
• TOPSPIN peak list (.xml).
• XEASY peak list (.peaks).
• XWIN-NMR peak list (.txt).

As such you can import a peak list from a different dataset or program or a previously
exported list from the current dataset. Note that peak picking commands store the peak list in
the processed data directory under the name peak.xml (TopSpin 2.1 or newer) or peak.txt
(Xwin-nmr and TopSpin 2.0 or older).

Shortcuts
Double-click a peak: zoom into spectrum, i.e. show region around that peak.
Enter key: zoom into spectrum, i.e. show region around selected peak(s).
Delete key: delete the selected peak(s) from the peak list.
Ctrl+ c: copy selected peaks to the Clipboard.
Ctrl+ a: select all peaks.
Home: select the first peak.
End: select the last peak.
Shift+ Home: select current and first peak and all in between.
Shift+ End: select current and last peak and all in between.
Note that these keys only work when the cursor focus is in the data window.

Table properties:
Various properties of the peak table can be configured. To do that:
1. Right-click an entry to open the popup menu.
2. Click Table properties...
3. In the appearing dialog box, with 3 tabs:
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• Column: Allows you to select the columns to be displayed, set the column width and the
number of fraction digits. Furthermore, you can switch on/off scientific notation of values
for each column individually.

• Colors: Allows you to set various colors of the table.
• Spacings: Allows you to set various spacings of the table.

When you move the cursor over the peak list, the active peak will, by default, be highlighted
in blue (see peak 3 in the figure below). If the correlated spectrum is also displayed, a vertical
line moves along, showing corresponding position in the spectrum.
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As soon as you click a peak, it is selected and, by default, displayed in red (see figure below).
Note that this peak remains selected, i.e. is used by Enter and Delete, until a different peak
is selected.
To extend the peak list, for example with Regions, Type and Index entries, right-click any part
of the header bar.
To sort the peaks according to peak number, ppm value or intensity, click the header of the
respective entry.
Peaks are only available if peak picking has been done (command pp). The peak list can be
printed with print [ Ctrl+ p]. List items can be selected with the mouse, copied with Ctrl + c
and pasted to other applications, e.g. a text editor.

How to Display the Integral list
• Click the Integrals tab [ li, lipp, lippf].
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This displays the integral list (upper part of figure). By default, this shows the following items:
Object: the integral number.
Integral [abs]: the absolute integral value.
Integral [rel]: the relative integral value.
Peaks: the number of peaks within the integral range.
Range (F1) from: the left edge of the integral range.
Range (F1) to: the right edge of the integral range.
Please note the difference between the following items:

• Selected integral: the entry that has been clicked last (Integral 3 in the figure above). If
you right-click an entry, it is selected and you can execute one of the commands from the
popup menu (see figure below). The keys Enter and Delete work on the selected entry.

• Active integral: the entry on which the cursor resides (Integral 1 in the figure above). The
active integral is also marked in the correlated spectrum by a black vertical line (see lower
part of the figure above and description below). When you move the cursor over the
integral list, the vertical line in the correlated spectrum moves along with it and vice versa.

Note that the colors of the selected and active integral can be set in the table properties (see
below).
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Display the spectral region around an integral
To display the spectral region around a particular integral:
Right-click the desired integral.
This will open the popup menu shown in the figure.

Here you can choose from the following options:
Show spectrum => In correlated spectrum To open a new data window showing the full
correlated spectrum.
Expand spectrum => In current window To change the current data window to spectrum
display, showing the region around the selected integral.
Expand spectrum => In correlated window To open a new data window showing the
region around the selected integral (lower part of the figure above).
Note that clicking the marked entry in the right-click popup menu is equivalent to pressing the
Enter key.

Export/Import Entries of the Integral List
Entries of the integral list can easily be exported to Excel or any other program as follows:
1. For multiple integrals:

Select the desired entries while pressing the Ctrl or Shift key.
2. Right-click an entry to open the popup menu (see the figure above).
3. Click one of the following menu items:

• Copy Copy the selected integral(s) entry to the Clipboard. Equivalent to clicking Edit =>
Copy or hitting Ctrl+c. Copied integrals can easily be pasted in any other application such
as Excel.

• Export...Export selected integrals. Check the box in the lower-left corner to export the
selected integrals only or uncheck it to export the entire list. Then click Export.

Calibrate Integrals to Compare Spectra
Integrals from the current and other spectra can be calibrated with respect to a reference
integral. To do that:
1. Right-click the reference integral and choose Define as reference from the popup menu.

This will determine the calibration constant.
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2. Right-click any integral and choose Calibrate by reference. This will divide all integrals by
the calibration constant, setting the reference integral to 1.0.

Now you can read any other spectrum, and calibrate its integrals with respect to the
reference integral defined above. To do that:
1. Read the spectrum.
2. Enter int to define the integral ranges (if this has not been done yet).
3. Click the Integrals tab.
4. Right-click any integral in the list and choose Calibrate by reference from the popup

menu.
Note that the calibration constant is lost when TopSpin is restarted.

Display the integral list with peaks
The integral list in the figure above shows only integrals. However, if peak picking has been
done, the integral list also shows the peaks within each integral range:

Note that the integral entries can be collapsed, (hiding the peaks) or expanded (showing the
peaks). As soon as one or more integrals entries are expanded, two extra columns appear
showing:
v(F1) [ppm]: the chemical shift of the peak.
Intensity: the peak intensity
Depending on whether or not integrals are expanded, the right-click popup menu contains the
following extra items:

• Expand Expand the current integral showing all peaks within it.
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• Expand all Expand all integrals showing all peaks within them.
• Collapse all Collapse all integrals hiding all peaks within them.

In addition to the integral entry, an individual peak within an integral can be activated (by
placing the cursor on it) or selected (by clicking it). In the figure above, peak 7 is selected and
the correlated spectrum is displayed. Peak 5 is active which is also shown by the vertical line
in the correlated spectrum.

Delete an Integral from the Integral List
To delete one integral:
Right-click the integral and choose Delete from the popup menu.
To delete multiple integrals:
1. Select the integrals while pressing the Ctrl or Shift key.
2. Right-click one of the integrals and choose Delete from the popup menu.
Note that these keys only work when the cursor focus is in the data window.

Table properties:
Various properties of the integral table can be configured. To do that:
1. Right-click an entry to open the popup menu (see figure below).
2. Click Table properties...
3. In the appearing dialog box, with 3 tabs:
4. Column Allows you to select the columns to be displayed, set the column.

• Width and the number of fraction digits. Furthermore, you can switch on/off scientific
notation of values for each individual column.

• Colors Allows you to set various colors of the table.
• Spacings Allows you to set various spacings of the table.

Shortcuts
Enter key: zoom into spectrum, i.e. show region around selected integral(s).
Delete key: delete the selected integral(s) from the integral list.
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Ctrl+c: copy selected integrals to the Clipboard.
Ctrl+ a: select all integrals.
Home: select the first integral.
End: select the last integral.
Shift+ Home: select current and first integral and all in between.
Shift+ End: select current and last integral and all in between.
Double-clicking an integral will show the peaks within the integral region if they exist. It they
do not exist, it will zoom into spectrum showing the integral region.
Note that these keys only work when the cursor focus is in the data window.

How to view Sample Information
• Click the Sample tab [ edsam].

This table can be used to fill out any sample information you want to store with the dataset.
The table can easily be modified or extended with the following functions:
To select an item: double-click it!

 Save the sample information table with the dataset.

 Save the sample information table as default.

 Reload the original table discarding any changes.

 Add a new item to the table. You will be prompted for an identification name and the
desired number of lines.

 Remove the selected item from the table.

 Move the selected item one place up in the table.

 Move the selected item one place down in the table.
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How to Display the FID
• Click the Fid tab [ fid].

Displays the raw data. If these do not exist, the text ’ No raw data available’ appears. The
following additional buttons appear at the right of the lower toolbar:

Show FID in shuffled mode.

Show FID in unshuffled mode.
If you open a new dataset, the Spectrum tab is activated, no matter which tab was selected
before. If you enter any interactive mode, for example phase correction mode, the Tab bar is
replaced by a toolbar for that mode.

See also
2 1D Display [} 81]

9.4.1 2D molecule structure editor

The new 2D molecule structure editor is integrated into the Structure tab of the TopSpin
spectrum window.
The user interface of the editor consists of several main parts:

• The top horizontal quick access toolbar contains buttons to activate the main features of
the editor like: drawing structures, selection and rotation capabilities, undo/redo support,
file features, editing of the structure properties etc.

• Other toolbars allow selection of an element from the periodic table of elements to be
used in a drawing. The user may also use a template to draw the structure more quickly.

• The drawing area: Used to draw and visualize the structure.
• The popup menu: Provides access to the same features as the toolbar in an alternative

way.
• The status bar: Displays the full path and file name of the opened file.
• The user interface was designed to follow this criteria:

– State of the art UI.
– Simplified use, one click adds an atom (defined bond angle and length).
– Smart utilization of Drag & Drop.
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Figure 9.1: Molecule Structure Editor

The editor is similar to other chemical structure drawing programs, but a brief description of
the key buttons is included here:

•  - Used to activate selection mode where object can be selected and moved.

•   - Used to control the zoom level.

•  - Used to scale the structure to its actual size.

•   - Activates the drawing mode for normal bonds or chains.

•  - Activates erase mode and deletes all touched bonds or atoms (highlighted in red
before deleting).

•  - Deletes the selection.

•    - Used for stereo bond definition (note that at this time CMC-se ignores the
stereo chemistry).

•  - Used to undo the last step.

•       - Simple ring templates.

•   - Used to save or open a user defined template.

•   - Used to open a structure or save changes.

•    - Used to copy and paste a selection.

•        - Used to rotate or flip structures.

•  - Used to clean a structure.
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•
- Use to add an atom.

•  - Used to add a pseudo atom.

•  - Used to open the periodic table to select additional elements. Refer to the CMC-
se User Manual for a list of the atoms that are supported in CMC-se.

9.5 1D Display Options

How to Toggle between Hertz and ppm Axis Units
Click the following toggle button in the upper toolbar: .

Toggle between Hz and ppm axis units [ .hz].

How to Switch on/off the Spectrum Overview display
The spectrum overview shows the entire spectrum at the top of the data window. It is useful
when only a certain region of the spectrum is displayed. In the overview, the displayed region
is marked as a green area. To switch on the spectrum overview, click the following toggle
button in the upper toolbar:

Switch the spectrum overview display on/off [ .ov].
To shift the displayed region, simply click-hold the green area in the overview spectrum and
move the mouse (see figure below).

How to Switch Y-axis Display
Click the following toggle button in the upper toolbar: .

Switch the y-axis display between abs/rel/off [ .y].
The following figure shows a data window with the spectrum overview on, ppm axis units, and
absolute y-axis display.
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See also
2 1D Display [} 81]

9.6 Show Display Properties/Regions/Files
If you right-click inside the data window, the following popup menu will appear:

If you choose Display Properties..., the following dialog box will appear.

Here you can check or uncheck the spectrum components that you want to be displayed in
the data window.
Note that the Display Properties... dialog box can also be opened from the View menu.

How to Superimpose the Cursor Information
To superimpose the cursor information on the spectrum:
1. Right-click in the data window and choose Display Properties [ .dopt].
2. Check Cursor information in the appearing dialog box and click OK.

How to Superimpose the Title on the Spectrum
1. Right-click in the data window and choose Display Properties... [ .dopt].
2. Check Title in the appearing dialog box and click OK.

How to Superimpose the main Status Parameters on the Spectrum
These are the status parameters that also appear on the plot.
1. Right-click in the data window and choose Display Properties... [ .dopt].
2. Check Status parameters in the appearing dialog box and click OK.

How to Superimpose the Integral Trails/Labels on the Spectrum
1. Right-click in the data window and choose Display Properties... [ .dopt].
2. Check Integrals and, if desired, Integral labels in the appearing dialog box.
3. Click OK.
If no integrals appear, the integral regions have not been determined yet. This can be done
with the int command.



1D Display

H9469SA3_2_003 101

How to Superimpose Peak Labels on the Spectrum
1. Right-click in the data window and choose Display Properties... [ .dopt].
2. Check Peak labels in the appearing dialog box and click OK.
If no peak labels appear, peak picking has not been done yet. This can be done with the pp
command.

How to Show Peak Annotations on the Spectrum
1. Right-click in the data window and choose Display Properties... [ .dopt].
2. Check Peak labels and Peak Annotations in the appearing dialog box and click OK.
Peak annotations appear, on peaks for which annotations have been defined, instead of
regular peak labels showing chemical shift values. If no peak labels or annotations appear,
peak picking has not been done yet. This can be done with the pp command.

How to Show Individual Data Points of the Spectrum
1. Right-click in the data window and choose Display Properties... [ .dopt].
2. Check Show data points in the appearing dialog box and click OK.
3. Expand the spectral region where you want to see individual points.

How to Superimpose the Electronic Signature on the Spectrum
1. Right-click in the data window and choose Display Properties... [ .dopt].
2. Check Electronic Signature in the appearing dialog box and click OK.
The electronic signature, entered with esign, will appear below the title.

How to Display the Main Dataset Properties
• Right-click inside the data window and choose File Properties.

An information box will appear:

Note that this is status information which cannot be changed.

How to Display a List of Files of a Dataset
• Right-click inside the data window choose Files.

The following figure shows the file list when the Fid tab is active, i.e. when the raw data are
displayed. It is the contents of the expno directory.
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The next figure shows the file list that appears when the Spectrum tab is active, i.e. when the
processed data are displayed. It is the contents of the procno directory.

The contents of any file in the list can be displayed as follows:
1. Select a filename (it will be highlighted).
2. Click Open.
Note that this only makes sense for ascii files, e.g. acqu*, proc* or files with the extension .txt.
Dataset files can also be displayed/opened with the command expl. This opens the Windows
Explorer, or under Linux, the Konqueror or Mozilla, showing the contents of the procno
directory.

See also
2 1D Display [} 81]

9.7 Saving Display Region
The currently displayed spectral region can be stored as follows:

• Right-click in the data window and choose Save Display Region To...
This will open the following dialog box:
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Here the following options are available:
• Parameters F1/2 [ dpl]

To save the displayed region for restoring the display later. The region is stored in the
parameters F1P and F2P.
To restore the saved region, right-click in the data window and choose:

– Restore Display Region from Params F1/2
• Parameters ABSF1/2

To save the displayed region for baseline correction (command absf) or phase correction
(command apkf). The region is stored in the processing parameters ABSF1 and ABSF2.

• Parameters STSR/STSI
To save the displayed region for Strip FT (commands like ft and trf). The region is stored
in the processing parameters STSR and STSI.

• Parameters NOISF1/2
To save the displayed region as the signal region for Signal to Noise calculation
(command sino). The region is stored in the processing parameters SIGF1 and SIGF2.

• Parameters SIGF1/2
To save the displayed region as the noise region for Signal to Noise calculation (command
sino). The region is stored in the processing parameters NOISF1 and NOISF2.

• A text file for use with other programs
To save the displayed region in a text file. This file can be viewed with any editor or used
by external programs.

9.8 Synchronize Visible Region of all Data Windows
The visible region of all data windows can be synchronized as follows.

• Zoom in or out one dataset while holding the Ctrl key.
or

• Zoom in or out one dataset and then enter the .sync command.
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10 2D Display

10.1 The 2D Data Window
The 2D data window consists of a data field, a title bar, a Tab bar and buttons.
The following figure shows a data window with a 2D spectrum.

10.2 Changing the Display of a 2D Spectrum
TopSpin offers various buttons to scale or shift a 2D spectrum both vertically and horizontally.

How to Change the Intensity Scaling (contour levels)

• Click the button .
– To change the intensity scaling (contour levels) [edlev].

or
• Hit one of the keys:

– Alt+ PageUp: Increase the intensity by a factor of 2.
– Alt+ PageDown: Decrease the intensity by a factor of 2.
– Alt + Enter: Reset the intensity.

or
• Click one of the following buttons:

– Increase the intensity (decrease the levels) by 2 [*2].

– Increase the intensity (decrease the levels) by 8 [*8].

– Decrease the intensity (increase the levels) by 2 [/2].
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– Decrease the intensity (increase the levels) by 8 [/8].

– Reset the intensity to the last saved intensity (contour levels) [ .vr].
Alternatively, you can enter the corresponding commands as specified between square
brackets [].
To manipulate all data windows, press the Ctrl key while clicking one of the above buttons.

How to Smoothly Change the Vertical Scaling (contour levels)
To change levels, multiplying all levels with the same factor:

• Click-hold the  button and move the mouse.
or

• Turn the mouse wheel while the cursor is in the data window.

To change the level distance (increment), leaving the base level the same:

• Click-hold the  button and move the mouse.

How to Display a Contour Levels Bar in the Data Window
1. Right-click in the data window and choose Display Properties... [.dopt]
2. Check Contour Levels Bar in the appearing dialog box and click OK:

How to Switch on/off Square 2D layout
Right-click inside the data field and click Square Layout On/Off.

The F2 scaling will be adjusted to reach a square display.
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How to Zoom a 2D spectrum in/out
Click one of the following buttons:

• Zoom in to the center (spectrum) or left edge (FID) of the displayed region, increasing
the horizontal scaling [.zi].

• Zoom out from the center (spectrum) or left edge (FID) of the displayed region,
decreasing horizontal scaling) [.zo].

• Perform an exact zoom via a dialog box [.zx].

– Enter the coordinates of the desired region in the dialog box.
– Click OK

• Undo last zoom [.zl].

• Show full spectral width in F2 [.f2r].

• Show full spectral width in F1 [.f1r].

• Show full spectrum [.all].

• Retain horizontal and vertical scaling when modifying dataset or changing to different
dataset. Effects all data windows [ .keep].

Alternatively, you can enter the corresponding commands as specified between square
brackets [].

How to Shift a Spectral Region in the F2 direction (left/right)
• Click one of the following buttons:

Shift to the left, half of the displayed region [.sl].

Shift to the right, half of the displayed region [.sr].
or

• Click-hold the button and move the mouse:

Smoothly shift in any direction.
Alternatively, you can enter the corresponding commands as specified between square
brackets [].
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How to Shift a Spectral Region in the F1 direction (up/down)
Click one of the following buttons:

• Shift the spectrum up, half of the displayed region [.su].

• Shift the spectrum down, half of the displayed region [.sd].
or

• Click-hold the button and move the mouse:

Smoothly shift up/down and left/right.
Alternatively, you can enter the corresponding commands as specified between square
brackets [].

10.3 Show Display Properties/Regions/Files
If you right-click inside the data window, the popup menu shown in the figure below:

Here you can select various display properties, region setting and file properties. If you
choose Display Properties..., a dialog box will appear.

Here you can set various display options including parameters, integrals, peaks, contours,
projections and electronic signature. The number of displayed digits for the integral and peak
labels can be set in the User Preferences (click Options => Preferences => Spectrum).

10.4 Using the Tab Bar
The 2D data window is a tabbed pane. This means its content depends on the currently
active tab in the Tab bar. The individual tabs are basically the same as for 1D display (see
chapter How to Expand a Spectral Region [}  15]). There are, however, some differences,
which are discussed below.

How to Set Processing Parameters
• Click the ProcPars tab [edp].
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The 2D processing parameter editor contains a column for each of the two dimensions F2
and F1. Note that not all parameters exist in both dimensions.

How to Set Acquisition Parameters
• Click the AcquPars tab [eda].

The 2D acquisition parameter editor contains a column for each of the two dimensions F2
and F1. Note that not all parameters exist in both dimensions.
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How to Display the Peak list
• Click the Peaks tab.

This displays list of peaks if these have been calculated (command pp). The list is basically
the same as for 1D spectra. The only difference is that there are two columns for the two
directions:
v(F2) [ppm]: the chemical shift in the F2 direction.
v(F1) [ppm]: the chemical shift in the F1 direction.
To specify or edit an annotation, click inside the Annotation field and enter a character
string. The peak annotations are shown in the correlated spectrum:

How to Display the Integral list
• Click the Integrals tab.
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This displays the list of integrals if these have been calculated (command int). The list is
basically the same as for 1D spectra. The only difference is that, when peaks are shown,
there are two columns for the chemical shift:
v(F2) [ppm]: the chemical shift in the F2 direction.
v(F1) [ppm]: the chemical shift in the F1 direction.
Furthermore, a stored or exported 2D integral list can be imported as follows:
1. Right-click an entry to open the popup menu.
2. Click Import...
3. In the appearing dialog box, navigate to the directory where the list resides and select the

integral list.
As such you can import an integral list from a different dataset or a previously exported list
from the current dataset. Note that integration commands store the integral list in the
processed data directory under the name integrals.txt. Exported integrals are stored in the
files <name>.txt and <name>.reg, where <name> is the name specified by the user.

How to Display the FID
• Click the Fid tab [fid].

2D raw data consist of a series of FIDs which are displayed in a row. Individual FIDs can be

displayed by zooming in. To do that, click  repeatedly. Now you can shift and zoom in/out
the data to display different FIDs:

10.5 2D Display Options

How to Switch between Hertz and ppm Axis Units in F2 and F1
• Click the following multi-state button in the upper toolbar:

Switch between Hz and ppm axis units in F2 and F1 [.hz].

How to Switch on/off the Spectrum Overview display
• Click the following toggle button in the upper toolbar:
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Switch the spectrum overview display on/off [.ov] .
With the spectrum overview on, the data window will, for example, look like this:

How to Switch on/off the Projection display
• Click the following toggle button in the upper toolbar:

Switch the projection display on/off [.pr].
With the projections displayed, a 2D dataset looks like this:

In this example, the F1 projection is selected as indicated by the filled blue square whereas
the F2 projection is not selected. A selected projection can be rescaled using the toolbar
rescale buttons of function keys. If you right-click inside the projection area of the data
window, the following popup menu appears:
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Clicking External Projection opens a dialog box where you can specify or search for a 1D
dataset and display this as a projection of the current 2D dataset.
Clicking Internal Projection calculates and displays the positive projection and displays it
along with the 2D spectrum.
Clicking Baseline at Bottom or Baseline at Center allows you to put the projection baseline
at the respective positions.
Alternative ways to calculate/display projections are:

• Right-click on a 1D dataset in the browser and choose:
– Display As 2D Projection

or
• Click Processing => Calculate projections [proj] .

This will open the dialog box shown in:

From here, you can calculate positive, negative, sum and disco projections and either show
them with the 2D spectrum or display them in separate data window as a 1D data. For more
details on the corresponding commands (as shown in the header of the dialog box), please
refer to the Processing Reference Manual.

How to Switch on/off the Grid display
• Click the following multi-state button in the upper toolbar:

Switch between ’no grid’, ’axis aligned grid’ and ’fixed grid’ [.gr].
The following figure shows an example of axis aligned grid display.



2D Display

114 H9469SA3_2_003

How to Display a 2D Spectrum in Contour Mode
• Click the following button in the upper toolbar:

– Switch to contour display mode [.co].
In contour mode, a spectral region looks like this:

How to Set the 2D Contour Levels
• Click the following button in the lower toolbar.

– Edit contour levels [edlev, .lv]
This will open the following dialog box shown in the next figure. Contour levels can be
entered manually or they can be calculated.

Manual setup
This allows you to create an arbitrary sequence of levels:
1. Enter the level values in the fields 1, 2,... at the top of the dialog box.
2. Click Apply to update the display or OK to store the levels, update the display and close

the dialog box.

Calculation
This allows you to easily create a geometric or equidistant sequence of levels.
1. Click one of the following items:

– Multiply with increment To create a geometric sequence of levels.
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– Add increment To create a equidistant sequence of levels.
2. Enter the desired Base level, Level increment and Number of levels.
3. Click Fill to display and activate the sequence.
4. Click Apply to update the display or OK to store the levels, update the display and close

the dialog box.
The Contour level sign allows you to select positive levels, negative levels or both.

How to Store interactively set Contour Levels

To store contour levels that were set interactively, for example by clicking  or pressing Alt
+ PageUp:
Click the following button in the lower toolbar:

Store contour levels [ .ls].
The levels are stored in the file:
/< dir>/data/<user>/nmr/< name>/<expno>/pdata/<procno>/clevels

How to Display a 2D spectrum in Pseudo Color Mode
• Click the following button in the upper toolbar:

Switch to image color display mode [ .im].
In pseudo color mode, a spectral region looks like this:

Note that in pseudo color mode, the contours are superimposed, in black, when you zoom in
on a small region of the spectrum.
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How to Display a 2D Spectrum in Oblique Mode
• Click the following button in the upper toolbar.

Switch to oblique display mode [ .st]
In oblique mode, a spectral region looks like that in the following figure:

In this mode you can manipulate the display in various ways. Just right-click inside the data
window and choose one of the options from the appearing popup menu:

How to Rotate a 2D Spectrum in Oblique Mode
Click-hold one of the following buttons and move the mouse up/down:

Rotate around x-axis.

Rotate around y-axis.

How to Switch between Displaying Positive and Negative levels
Click the following multi-state button in the lower toolbar:

Switch between positive, negative and both contours [ .lt].
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11 nD Display

11.1 Display Planes of 3D Data
3D data can be displayed as 2D planes or as a 3D cube. By default, the first F3-F1 plane is
displayed (see the figure below) The plane orientation and number is shown. The cube in the
lower left corner graphically indicates which plane is displayed. The full 2D display
functionality is available (see chapter Getting Started [} 13]).

How to Switch to 2D Plane Display
If the 3D cube is displayed you can switch to 2D plane display by clicking one of the following
buttons:

 Switch to 2D contour display.

 Switch to 2D image display.
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 Switch to 2D oblique display.

How to Display various Plane Orientations
Click one of the following buttons:

Show F1-F2 planes.

Show F2-F3 planes.

Show F3-F1 planes.

How to Display various Plane Positions (numbers)
Click one of the following buttons:

Show the next plane.

Show the previous plane.

Scan planes smoothly.

Enter the exact plane number. This will open the dialog shown in the figure below. Here,
you can specify the desired plane number as well as switch to a different plane orientation.

11.2 3D Cube Display Mode

How to Display the 3D Cube
Click the following button:

Show 3d cube:



nD Display

H9469SA3_2_003 119

How to Rotate the 3D Cube
Click-hold one the following buttons and move the mouse up/down:

Rotate cube around x-axis.

Rotate cube around y-axis.

Rotate cube around z-axis.

How to Scale Up/Down the 3D Cube
1. Right-click inside the data window.
2. Choose Larger or Smaller from the popup menu (see following figure).

How to Reset the Cube Size and Orientation
Click the following button:

Reset to default size and orientation.

How to Switch Depth Cueing on/off
1. Right-click inside the data window.
2. Choose Depth Cueing On/off (see following figure).
Depth cueing makes data points which are closer to the viewer appear brighter and those
that are further away appear dimmer. This increases the depth effect of the 3D image.
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How to Display a Cube Front or Side view
Click one the following buttons:

Show F1-F2 plane.

Show F2-F3 plane.

Show F3-F1 plane.

11.3 nD Parameter Display
TopSpin 2.1 and newer support parameter display of up to 8D data. To show processing
parameters:
Click the ProcPars tab of the data window.
or
Enter edp on the command line.
Parameters of each direction are shown in a separate column.
The figure below shows the processing parameter display of a 3D dataset.

To show acquisition parameters:
• Click the AcquPars tab of the data window.
• Enter eda on the command line.



nD Display

H9469SA3_2_003 121

Parameters of each direction are shown in a separate column. The following figure shows the
acquisition parameter display of a 3D dataset.

11.4 nD FID Display
nD raw data can be displayed as a series of 1D FIDs. To do that:

• Click the FID tab of the data window.
or

• Enter fid on the command line.

11.5 nD Peak and Integral Display
TopSpin 2.1 and newer support peak and integral display of up to 8D data.
To show the nD peak list:

• Click the Peaks tab of the data window.
or

• Enter peaks on the command line.

The following figure shows the peak list of a 3D dataset.
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The chemical shift in each of the three dimensions is shown in a separate column.
To show the nD integral list:

• Click the Integrals tab of the data window.
or

• Enter ints on the command line.

The following figure shows the integral list of a 3D dataset.

The chemical shift in each of the three dimensions is shown in a separate column.
Peaks and integrals only appear if they have been calculated (commands pp and int,
respectively).
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12 1D Interactive Manipulation
The upper toolbar of the 1D menu offers various buttons for interactive manipulation. If you
click such a button, the active data window will switch to the corresponding mode. An
interactive manipulation mode is data window specific, i.e. it only applies to the active
window.

12.1 1D Interactive Window Multiplication
TopSpin 2.0 and newer supports 1D interactive window multiplication.

12.1.1 1D Interactive Window Multiplication Procedure

How to Switch to Window Multiplication Mode
• Click the Processing => Window Multiplication [ wm], enable Manual window

adjustment in the appearing dialog and click OK.
or

• Enter .winf on the command line.

The Tab bar of the active data window will be replaced by a toolbar (see figure below) and
the data window itself will be divided into three parts:

• A parameter part at the left.
• A spectrum part at the upper right.
• An FID part at the lower right.
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Show both spectrum and FID.

Show FID only.

Show spectrum only.

Switch cursor information on/off (toggle).

Save windows settings to source 2D data set (see note below) and return.

Save window settings and return.

Return without save.
Note: 2D from which current 1D data set was extracted, e.g. with rser.

You can perform interactive window manipulation as follows:
1. Select the window function (parameter WDW).
2. Set the corresponding parameter(s), e.g.

– LB for exponential.
– LB and GB for Gaussian.
– SSB for sine bell and squared sine.

The displayed spectrum and/or FID will be automatically adjusted as you change the
window function and parameters.
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3. Click the Save button to store the window settings and return.
Now you can perform further processing steps like Fourier transform, phase correction etc.

12.2 1D Interactive Phase Correction
Manually acquired spectra can be phase corrected automatically, with commands like apk or
apks or, interactively, in phase correction mode.

12.2.1 1D Interactive Phase Correction Procedure

How to Switch to Phase Correction Mode
Click the indicated button in the upper toolbar:

Or enter .ph on the command line.
The Tab bar of the active data window will be replaced by a toolbar:

The yellow button indicates that you are in phase correction mode.

Some buttons will turn green when they are clicked. As long as a button is green, it is
active.

How to Perform a Typical 1D Interactive Phase Correction
For a typical 1D phase correction, take the following steps:

1. Click-hold the button and move the mouse until the until the reference peak is exactly
in absorption mode.

2. Click-hold the button and move the mouse until the entire spectrum is exactly in
absorption mode.

3. Click the button  to save and execute the phase correction and return.
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12.2.2 1D Interactive Phase Correction Details

How to Set the Phase Pivot Point
By default, the phase pivot point is set to the biggest magnitude intensity of the displayed
region of the spectrum. To change the pivot point:
1. Right-click on the desired pivot point position.
2. Choose Set pivot point from the popup menu (see previous figure).

How to Perform Default Zero Order Phase Correction
1. Right-click in the data window.
2. Choose Calculate ph0 in the popup menu (see previous figure).
The spectrum will automatically be corrected according to the calculated value.

How to Perform Interactive Zero Order Phase Correction
1. Click-hold the following button (button turns green):

Zero order phase correction (parameter PHC0).
2. Move the mouse until the reference peak is exactly in absorption mode.
3. Release the mouse (button turns grey).

How to Perform Interactive First Order Phase Correction
1. Click-hold the following button (button turns green):

First order phase correction (parameter PHC1).
2. Move the mouse until the entire spectrum is exactly in absorption mode.
3. Release the mouse (button turns grey).

How to Perform 90, -90 or 180° Zero Order Phase Correction
• Click one of the following buttons:

Perform 90 zero order phase correction [ .ph90].

Perform -90° zero order phase correction [ .phm90].

Perform 180° zero order phase correction [ .ph180].

How to Reset the Phase to the Original Values
• Click the following button:

Reset zero and first order phase values [ .phr].

How to Change the Mouse Sensitivity
• Click one of the following buttons:

Increase (double) the mouse sensitivity [ .inc].



1D Interactive Manipulation

H9469SA3_2_003 127

Decrease (halve) the mouse sensitivity [ .dec].

Reset the mouse sensitivity.

How to Return from Phase Correction Mode with/without Save
To return while saving the phase correction to the current dataset:

• Click the following button:

Save, execute and return [ .sret].
This will perform the following tasks:

• Execute phase correction (command pk).
• Save the current phase correction values.
• Leave the phase correction mode.

To return without save:
• Click the following button:

Return, discarding any changes [ .ret].
To return while saving the phase correction to the source 2D dataset:

• Click the following button:

Save to 2D [ .s2d].
This is only applicable on rows or columns extracted from 2D data. The phase values will be
saved to the 2D dataset from which the current 1D dataset was extracted.

12.3 1D Interactive Integration
Integration of 1D data can be done automatically, with the commands abs and li or,
interactively, as described in this paragraph.

How to Switch to Integration Mode
• Click in the flow bar the Process menu and use the Integrate Button.
• Use the command .int in the command line.

The Tab bar of the active data window will be replaced by a toolbar (see the following figure).
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The yellow button indicates that the data window is in integration mode.
If integral regions have already been determined, for example with abs or with a previous
interactive integration, these regions are displayed in the data window, along with the integral
values. You can remove them, change them or add to them, as described below.

How to Define Integral Regions
For a manual definition use one of the two following buttons:

• : Define new region in the given spectra with manual selection (toggle)

•  : Define new integral with automated baseline correction in the selected region
(toggle)

Or define a new integral with exact coordinates via a dialog:

•  Define region via dialog (see the following figure).

Figure 12.1: Enter the exact values for the region limits and press OK.

Follow the next steps for a manual definition:
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1. Put the red cursor line at one edge of a peak or multiplet.
2. Left-click-hold and drag the cursor line to the other edge of the peak or multiplet. In case

of a baseline correction the interpolated baseline will be displayed automatically on screen
(see the next figure). The integral is calculated considering the new baseline.

3.
4. Do step 2 and 3 for all regions to be defined.
5. Click the button again to leave the "define region" mode.

How to Read Integral Regions from Disk
You can read integrals regions from disk which have been stored by automatic integration
(command abs) or by a previous interactive integration.
To read integrals:
1. Click the following button:

Read integral regions.
The following popup menu will appear:

2. From the popup menu, choose one of the following entries:
– Read ’ intrng’: To read the last saved integral regions and apply the saved slope and

bias correction values.
– Read ’intrng’ no slope & bias corr: To read the last saved integral regions but do

not apply the saved slope and bias correction values.
– Read ’intrng’ use last slope & bias: To read the last saved integral regions applying

the last slope and bias correction values.
– Import integration regions: To read integral regions from external file.
– Import ’intrng’ from Relaxation Experiment: To read the last stored integral regions

of the T1/T2 relaxation experiment.
– Edit ’intrng’: To edit the file (intrng) that contains the integral regions and slope and

bias correction values. Changes in this file are automatically shown on the screen,
when the file is saved.
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How to Select / Deselect Integrals
Call the context menu (see following figure) with right-clicking in the integral region and
choose the menu item Select / Deselect to toggle the selection.

Figure 12.2: Context Menu in Integration Mode

How to Perform Interactive Bias and Slope Correction
To perform interactive bias correction:
1. Select the integral(s) that you want to correct (right-click in the region and choose Select /

Deselect in the context menu).
If no integral is selected, bias correction will work on all integrals.

2. Click-hold the button Integral bias correction and move the mouse until the integral
bias is correct.

To perform interactive slope correction:
1. Select the integral(s) that you want to correct (right-click in the region and choose Select /

Deselect in the context menu).
If no integral is selected, slope correction will work on all integrals.

2. Click-hold the Integral slope correction button  and move the mouse until the integral
slope is correct.

How to Set the Limit for Bias Determination
• Click the following button:

Limit for bias determination.

How to Change the Mouse Sensitivity
• Click one of the following buttons:

Increase (double) the mouse sensitivity [ .inc].

Decrease (halve) the mouse sensitivity [ .dec].

Reset the mouse sensitivity.
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How to Calibrate/Normalize Integrals
Calibrating integrals means setting the value of a reference integral and adjusting all other
integrals accordingly. To do that:
1. Right-click in the reference integral region.
2. Choose Calibrate Current Integral from the popup menu:
3. Enter the desired value for the reference integral and click OK.

Normalizing integrals means setting the sum of all integrals and adjusting individual integral
values accordingly. To do that:
1. Right-click in the reference integral region.
2. Choose Normalize Sum of Integrals from the popup menu.
3. Enter the desired sum of all integrals and click OK

Calibrating and normalizing only effects the current data set. To scale integrals with respect
to a reference data set, choose lastscal from the right/click popup menu (see below).

How to Scale Integrals with respect to Different Spectra
Integrals can be scaled with respect to the last spectrum that was integrated interactively. To
do that:
1. Right-click in the reference integral region.
2. Choose Use Lastscale for Calibration from the popup menu.

As such, you can compare integrals of different spectra. Note that this only makes sense for
spectra which have been acquired under the same experimental conditions. The scaling
factor is stored in the file:
<tshome>/prog/curdir/<user>/intscale

How to Delete Integral Regions from the Display
To delete the selected integral regions from the display:

• Click the button  to delete selected integral regions from the display.
• Choose Delete Current Integral from the context menu (right-click in the integral region).

To delete all integral regions from the display:

• Click the button  to delete all integral regions from the display.
Note that regions are only deleted from the screen. Regions which are saved on disk (in the
intrng file) are not affected.

How to Scale Selected Integrals
Integral scaling only manipulates selected integrals. However, if no integrals are selected, it
works on all integrals.

• Click one of the following buttons:

Scale up selected integrals by a factor of 2.

Scale down selected integrals by a factor of 2.
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Scale selected integrals up/down smoothly.
To scale up/down integrals by a factor entered via a dialog:
1. Click the following button:

Scale integrals via a dialog.
2. Enter a scaling factor, e.g. 2.5. in the appearing dialog.

3. Click OK to apply this factor.

To scale all selected integrals to the same height:
• Click the following button:

Scale/unscale all integrals to the same height.
The individual scaling factor for each region is displayed above the integral. Clicking this
button again rescales all integrals to their original height.

How to Move the Integral Trails Up/Down
To move the integrals (selected and unselected) up or down:

• Click one of the following buttons:

The left edge of the selected integral is put just above the baseline. If no integral is
selected, the lowest integral is used.

The right edge of the selected integral is put at 3/4 of the window height. If no integral
is selected, the highest integral is used.

Shift all integral trails up/down smoothly.

How to Cut Integral Regions

1. Click the button  to activate or deactivate the cutting mode (toggle).
2. Move the red cursor line into an integral region to the position where it must be cut and

click the left mouse button.
3. Do step 2 for each integral region that must be cut.

In case of overlapping integrals, you must select the integral to be cut before you actually cut
it. Note that if one or more integrals are selected, cutting only works on selected integrals.
With TopSpin 2.2 1D Interactive Integration command cut integral can be called directly from
right-click context menu. Right mouse click on the integral opens a popup menu in which cut
current integral must be selected.
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How to Save Integral Regions
1. Click the following button:

Save integral regions.
The following popup menu will appear:

2. Choose one of the following entries:
– Save regions to ’intrng’: Save the currently displayed integral regions including the

slope and bias correction values.
– Save Regions to ’reg’: Save the integral regions to the file reg.
– Export Regions To Relaxation Module and .sret: Used on relaxation data only.

Exports the integral regions for T1/T2 relaxation analysis and exits from integration
mode.

– Save & show list: Save the currently displayed integral regions including the slope
and bias correction values and show the integrals on the screen.

How to Undo the Last Region Operation
• Click the following button:

Undo the last region operation.

How to Return from the Integration Mode with/without Save
To return and save the integrals to the current dataset:

• Click the following button:

Save integrals and return [ .sret].
As such, you will:

• Save the integral regions and corresponding slope and bias corrections to the file intrng.
• Save the integral regions, slope and bias corrections and integral values to the file

integrals.txt. This file is displayed when you click the Integrals Tab.
• Leave the integration mode.

To return without save:
• Click the following button:

Return, discarding any changes [ .ret].

How to deconvolve overlapping peaks from integration mode
Deconvolution, the line shape tool to interpret complex 1D and 2D spectra with overlapping
peaks can be started directly from within integration mode. As described in the Analysis
chapter deconvolution calculates theoretical signals with different methods, i. e. Gaussian,
Lorentzian or a mixture of these line shapes. The values are stored in the file dconpeaks.txt
and displayed graphically. For further information please look up the Analysis chapter and the
Processing Reference Manual (commands gdcon, ldcon, mdcon, ppp, dconpl and dcon).
From within the integration mode, after the integration of the respective peak or peak groups,
deconvolution can be started by right clicking on the peak. The following window will appear:
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Choosing Deconvolution offers the following options:
• Deconvolve and display regions.
• Change Peak Picking Parameters for Deconvolution.
• Edit Peak List & Deconvolve.
• Show Deconvolution Fit (graphical display).

With the latter function it is possible to display results after deconvolution graphically:
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The integral values of each of the deconvolved signals are available in the integrals tab within
the originally defined integral (column ’Intensity [abs]’):
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12.4 1D Interactive Calibration
A 1D spectrum can be calibrated (referenced), automatically, with the command sref or,
interactively, as described below.

How to Switch to Calibration Mode
• Click the indicated button in the upper toolbar.

Or enter .cal on the command line. The Tab bar of the active data window will be replaced
by a toolbar.



1D Interactive Manipulation

H9469SA3_2_003 137

The yellow button indicates that the data window is in calibration mode.

How to Calibrate a Spectrum Interactively
In calibration mode:
1. Position the red cursor line at the reference peak.
2. Left-click at that position.

The following dialog box will appear:

Note that the units (Hz or ppm) correspond to the axis units of the display.
3. Enter the frequency you want to assign to the reference peak.
4. Click OK.

The spectrum will be calibrated and re-displayed. TopSpin will automatically leave calibration
mode.

12.5 1D Multiple Display
The multiple display mode allows you to display multiple superimposed spectra. The spectra
will be ppm aligned or Hz aligned, according to the selected axis unit. Each spectrum can be
individually shifted and scaled allowing exact alignment of corresponding peaks in different
spectra. The number of superimposed spectra is unlimited.
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Although multiple display is normally used for spectra with matching nuclei, it allows you to
superimpose spectra with non-matching nuclei. You will get a warning that the nuclei do not
match. Just just click OK to continue.

How to Switch to Multiple Display Mode and Read Multiple Spectra
One way to superimpose data in multiple display is to read one dataset, switch to multiple
display mode and add other datasets:
1. Read a 1D dataset.

2. Click the  button in the upper toolbar, or type .md on the command line.
The data window will switch to multiple display mode.

3. Add a dataset as follows:
Left-click-hold the dataset in the browser and drag it into the data window.
or
Right-click the dataset in the browser and choose Display from the popup menu.
or
Enter re and specify the additional dataset in the appearing dialog box.

Another way to superimpose data in multiple display is to read multiple datasets
simultaneously:
1. In the browser:

– Hold down the Ctrl key and click multiple datasets to select them.
or

– Hold down the Shift key and click two datasets to select these two and all datasets in
between.

2. Right-click any of the selected data:
– Choose Display from the popup menu.This will show the data in the active data

window if that is in multiple display mode or, otherwise, show the data in a new
window.
or

– Choose Display in new window from the popup menu.This will show the data in a new
window.

In multiple display mode, the Tab bar of the active data window is replaced by a toolbar. The
following figure shows three comparable 1D spectra and the sum of all three.
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The yellow button indicates that the data window is in multiple display mode.

Some buttons will turn green when they are clicked. As long as a button is green, it is
active.
Furthermore, the browser is split in two parts:

The additional lower part shows:
• Which data sets are displayed in the active data window.
• Which data sets are selected (these are highlighted).

How to work with multiple display command .md
The following arguments of .md for controlling data sets from command line, AU-programs or
Python programs are available:
1. Specified data set names can be shown in the display by command .md: Enter command

and full pathname for a specified dataset in the TopSpin command line:
.md <PathToDataset1>\<expno1>\pdata\<procno> <PathToDataset2>\<expno2>\pdata
\<procno>

2. The command .md no_load ignores the datasets stored in the last multiple display
session and enters the multiple display.

3. The command .md write writes only the assoc file containing the data set list for multiple
display. Please note that the multiple display module is not started with this command.
Enter command and full path name of specified data set in the TopSpin command line:
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.md write <PathToDataset1>\<expno1>\pdata\<procno> <PathToDataset2>\<expno2>
\pdata\<procno>

Multiple display mode is supported for 1D and 2D spectra. For spectra with a dimension > 2
the selected slice (subplane) is shown.

How to Select/Deselect Data Sets
To select a data set:

• Click in the corresponding area in the data window.
or

– Left-click-hold the data set in the browser and drag it into the data window.
or

– Click the corresponding entry in the lower part of the browser.

In the lower part of the browser, you can:
• Click one data set to select it.

or
– Hold down the Ctrl key and click multiple data sets to select them.

or
– Hold down the Shift key and click two data sets to select these two and all data sets in

between.

When you select a data set, the corresponding small square is filled (see the figure above)
and its entry in the lower part of the browser is highlighted (see the figure above).
Note that:

• No spectrum selected = all spectra selected.
• Scale/shift buttons of the data window toolbar only work on selected spectra.

To deselect a data set:
• Select a different data set.

To deselect all data sets:
• Click the following button:

Deselect all data sets.

How to Remove a Data Set from Multiple Display
1. Select the data set(s) you want to remove.
2. Click the following button:

Remove selected data from the screen.
Note that the data on disk are not affected. Furthermore, the first spectrum cannot be
removed from the screen.

How to Display the Sum or Difference Spectra
• Click one of the following button (button turns green):
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Show the difference between the first and the sum of the other data sets.

Show the sum of all data sets in the multiple display window.

How to Save the Sum or Difference Spectra
1. Click the following button:

Save the displayed sum or difference spectrum.
2. In the appearing dialog box, specify the destination procno.

How to Display the Next/Previous Name/Expno
To compare a series of spectra you can interactively increment or decrement the dataset
name or expno. A dataset name is incremented according to the Icon-NMR naming
convention of increasing extensions, e.g. name.001, name.002 etc.

• Click one of the following button (button turns green):

Show the previous name/expno/procno of the last dataset.

Show the previous name/expno/procno of the last dataset.

Set the increment options. Clicking this button will open the following dialog:

Here you can choose to increment the procno, expno or name, set the expno increment and
switch individual scaling on/off.

How to Toggle between Superimposed and Stacked Display
• Click the following button:

Toggle between superimposed and stacked display.

How to Shift and Scale Individual Spectra
To compare the intensity and chemical shift of corresponding peaks, you can shift and scale
individual spectra. To do this:
1. Display the spectra in multiple display mode as described above.
2. Expand the spectra to display the desired region or peak.
3. Select one of the spectra (e.g. by clicking it in the lower part of the browser).

4. Click-hold the  button and move the mouse to align the intensities.

5. Click-hold the button and move the mouse to align the peak positions.
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The alignment can be facilitated by showing the difference spectrum (  button) and

minimize that. Note that you can also scale the selected spectra up/down with the buttons 

and . The  button allows you to move the selected spectra vertically. Clicking the 
button resets individual scaling and shifting.
The performed scaling and shifting are displayed in the data window:

How to move the selected spectrum one place up/down
• Click the following button:

Move the selected spectrum one place up in the list.
• Click the following button:

Move the selected spectrum one place down in the list.
Note that the first spectrum and calculated spectra (sum of difference) cannot be moved up/
down.
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How to Switch on/off the Display of Data Paths and Scaling Factors
• Click the following button:

Switch on/off display of data paths and scaling factors.

How to Return from Multiple Display mode
• Click the following button:

Return from multiple display mode [ .ret].

How to Set the Colors of the 1 st, 2 nd, .. Data Set
The colors of the different data sets in the multiple display mode can be set in the User
preferences dialog box. To set, for example, the color of the second spectrum:

• Click Options => Preferences and click the Change button for the item Color of 2nd 1D
spectrum.

TopSpin 2.0 and newer allows you to set 8 different colors for different spectra in multiple
display.

12.6 1D Interactive Baseline Correction
Baseline correction can be performed with commands like abs or absd or, interactively, as
described below.

How to Switch to Baseline Correction Mode
• Click the indicated button in the upper toolbar:

or enter .basl on the command line.
The Tab bar of the active data window will be replaced by a toolbar:

The yellow button indicates that the data window is in baseline correction mode.



1D Interactive Manipulation

144 H9469SA3_2_003

Some buttons will turn green when they are clicked. As long as a button is green, it is
active.

How to Perform Polynomial Baseline Correction
1. Click the following button (button turns green):

Perform polynomial baseline correction.
In the data window, a red horizontal line will appear as well as the equation that describes
the polynomial function:

2. Click-hold button A and move the mouse until the red line coincides with the first point of
the spectrum.

3. Repeat step 2 with the buttons B, C, D and E until the red line coincides with the entire
baseline of the spectrum.

How to Perform Sine Baseline Correction
1. Click the following button (button turns green):

Perform sine baseline correction.
A red horizontal line will appear as well as the equation describing the sine function:

2. Click-hold button A and move the mouse until the red line coincides with the first point of
the spectrum.

3. Repeat step 2 with the buttons B, C and D until the red line coincides with the entire
baseline of the spectrum.

How to Perform Exponential Baseline Correction
1. Click the following button (button turns green):

Perform exponential baseline correction.
A red horizontal line will appear as well as the equation describing the exponential
function:

2. Click-hold button A and move the mouse until the red line coincides with the first point of
the spectrum.

3. Repeat step 2 with the buttons B and C until the red line coincides with the entire baseline
of the spectrum.

How to Preview the Baseline Corrected Spectrum
Before actually performing the baseline correction, you can preview the result by displaying
the difference between the uncorrected spectrum and the red correction line.
To do that:
1. Click the following button (button turns green):
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Preview corrected spectrum (show difference).
The corrected spectrum will be displayed in red.

2. If the baseline is correct, click the  button to save the correction. If further correction is
needed, click the  button to show the original spectrum and the red correction line.

How to Reset the Baseline Correction Line
1. Click the following button:

Reset the red correction line to zero.

If the difference spectrum is displayed (the  button is active), clicking the reset button
will restore the original spectrum.

How to Change the Mouse Sensitivity
• Click one of the following buttons:

Increase (double) the Mouse Sensitivity [ .inc].

Decrease (halve) the Mouse Sensitivity [ .dec].

Reset the Mouse Sensitivity.

How to Save the Baseline Correction and/or Return
To return while saving the baseline correction:

• Click the following button:

Save baseline correction and Return [ .sret]
This will perform the following tasks:

• Execute the baseline correction [ bcm].
• Save the baseline correction values A, B, C, D and E.
• Leave the baseline correction mode.

To return while discarding any changes:
• Click the following button:

Return, Discarding any changes [ .ret].

How to Perform Cubic Spline Baseline correction
• Click the following button:

Define points for cubic spline baseline correction.

The toolbar of the data window will change:
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The cursor line in the data window turns red. If a list of baseline points already exists, you are
prompted to overwrite or append to these points. If you choose Append, the labels of the
existing points are displayed on the screen. If you choose Overwrite, no labels are displayed.
Nevertheless, the existing points are only overwritten when you define and save new points.
To define new baseline points:
1. Move the cursor line to a baseline point and left-click at that position.
2. Do this for at least five baseline points.

The figure above shows a spectrum with five defined baseline points. Note that here the
points have been chosen at the right part of the spectrum for display reasons only.

Note that the actual baseline correction is only performed when you click the  button in
the spline baseline and interactive baseline mode.

How to Delete Spline Baseline Points from the screen
To delete one baseline point:
1. Right-click the baseline point position in the data window.
2. Choose Delete Current from the popup menu:

To delete all baseline points:
1. Right-click any position in the data window.
2. Choose Delete All from the popup menu.
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How to Return from Cubic Spline Baseline mode with/without Save
To return while saving the baseline points:

• Click the following button:

Save baseline points and Return [ .retsab].

To return while discarding any changes:
• Click the following button:

Return, Discarding any changes [ .ret].
Alternatively, you can right-click in the data window and choose Save & Quit or Quit,
respectively.

12.7 1D Interactive Peak Picking
Peak picking can be performed, automatically, with the commands pps or, interactively, in
the peak picking mode.

How to Switch to Peak Picking Mode
• Click the indicated button in the upper toolbar or enter .pp on the command line:

The Tab bar of the active data window will be replaced by a toolbar:

The yellow button indicates that you are in peak picking mode.
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Some buttons will turn green when they are clicked. As long as a button is green, it is
active.

Note that the button is automatically activated, i.e. you are in Define peak picking range
mode

How to Define New Peak Picking Ranges
1. Put the cursor at the upper-left corner of a peak picking range.
2. Left-click-hold and drag the mouse to the lower-right corner of the range.

The peak picking range will be marked green. The minimum and maximum intensity are
set and the peaks in the range are picked and displayed.

3. Repeat step 1 and 2 for each peak picking range to be defined.
4. Click the green button to leave the "Define peak picking range" mode.

Note that the parameters MI and MAXI are set to the lowest minimum and the highest
maximum intensity, respectively, of all ranges.

How to Change Peak Picking Ranges
1. Click the following button (button turns green):

Change peak picking ranges.
2. Put the cursor on one of the edges of the peak picking range.

The cursor turns into a double-headed arrow.
3. Left-click-hold and drag the peak range edge to its new position.
4. Optionally: repeat step 2 and 3 for the other edge and for other peak ranges.
5. Click the green button to leave the "Change peak picking range" mode.

How to Pick Peaks in Peak Picking Ranges only
Peaks in a peak range are automatically picked when the range is defined. If peaks have
been deleted from a rang, they can be picked again as follows:
1. Right-click in the data field.
2. Choose Pick Peaks On Ranges from the popup menu.
Alternatively, you can enter ppl on the command line. This command can be entered in
Interactive peak picking mode or in the normal display mode.

How to Delete all Peak Picking Ranges

• Click the button in the data window toolbar.
or

• Right-click in the data field and click Delete All Regions in the popup menu.

How to Define Peaks Manually
1. Click the following button (button turns green):

Define peaks manually.
A red vertical line will appear in the data window.
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2. Put the red cursor line at the desired peak and click the left mouse button. The peak label
will appear at the top of the data window.

3. Repeat step 2 for each peak to be defined.
4. Click the green button to leave the "Define peaks" mode.

How to Pick Peaks Semi-Automatically
1. Click the following button (button turns green):

Define peaks semi-automatically.
2. Move the cursor into the data window.
3. Put the cursor line near the desired peak.
4. Left-click to pick forward.

or
Right-click to pick backward (see the figure below).
A red cursor line will appear at the nearest peak whose intensity is between MI and MAXI.

5. Right-click to add the selected peak to the peak list:

The peak label will appear at the top of the data window.
6. Click the green button to leave the "define peaks semi-automatically" mode.

How to Delete Peaks from the Peak List
To delete a specific peak:
1. Right-click on a defined peak.
2. Choose Delete peak under cursor from the popup menu:

To delete all peaks:

• Click the  button in the data window toolbar.
or

• Right-click in the data field and click Delete All Peaks in the popup menu.

How to Return from Peak Picking Mode with/without Save
To return while saving the peak list and peak ranges:

• Click the following button:
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Save the Peak Region and Peak List and Return [ .sret].
This will:

• Save the peak list to the file peak.xml and the peak ranges to the file peakrng.
• Leave the peak picking mode.

To return while discarding any changes:
• Click the following button:

Return, discarding any changes [ .ret].

How to save Peak Lists and Regions in 1D Interactive Mode

In 1D interactive Peak Picking the  Save as ... button opens a window in which three
options of saving can be selected:

• Save Peak Lists and Regions.
• Save Peak List for Deconvolution (The peak list will be saved in a format which is

needed for deconvolution).
• Save Peak list and start Deconvolution (The peak list is saved and the Deconvolution

will be started, after that returning to Peak Picking).
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13 2D Interactive Manipulation
The upper toolbar of the 2D menu offers various buttons for interactive manipulation. If you
click such a button, the active data window will switch to the corresponding mode. An
interactive manipulation mode is data window specific, i.e. it only applies to the active
window.

13.1 2D Interactive Phase Correction
2D spectra can be phase corrected interactively in both the F2 and F1 direction by selecting
certain rows and/or columns and phase correct them.

13.1.1 2D Interactive Phase Correction Procedure

How to Switch to 2D Interactive Phase Correction
Click the corresponding button in the upper toolbar as indicated below:

or enter .ph on the command line.
The Tab bar of the active data window will be replaced by a toolbar. The figure below shows
an example of an unphased 2D inverse spectrum.

Data window in phase correction mode

The yellow button indicates that you are in phase correction mode.

Toggle the contour display on/off.

Switch to phase row mode to display rows of selected peaks.
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Switch to phase columns mode to display columns of selected peaks.

Save the phase values to the 3D data from which this 2D was extracted.

Return.

How to Perform a Typical 2D Interactive Phase Correction
In this example we will perform F1 phase correction (columns) only. Take the following steps:
1. Select two or more peaks in different parts of the spectrum. To do that:

– Zoom in on a peak by drawing a box around it. To do that, click-hold the left mouse
button and move the mouse.

– Right-click at the peak position and choose Add from add:peak in 2D phase correction
the popup menu.

– Click the  button to display the full spectrum.
– Zoom in on the next peak and add in the same way as the first one.
– Zoom in on the next peak etc.

The following figure shows an example of three selected peaks.

2. Click the button  to phase correct the columns (F1).
A new data window called Phase 2D will appear showing the columns of the selected
peaks:



2D Interactive Manipulation

H9469SA3_2_003 153

Note that the toolbar and the right-click popup menu offer the full 1D phase correction
functions.
By default, all columns are selected as indicated by the filled blue squares . The red
vertical line indicates the default pivot point in the upper column.

3. A typical way to perform phase correction is:

– Click-hold the  button for zero order correction and move the mouse until the
reference peak of the first column is exactly in absorption mode.

– Click-hold the button for first order correction and move the mouse until the
reference peak in other column is exactly in absorption mode.

– Click the  button to execute, save and return.

13.1.2 2D Interactive Phase Correction Details

How to Scale or Shift Individual Rows/Columns
To select one row or column:

• Click in the corresponding part of the data window.
The selected row/column will be marked with a filled blue square  whereas unselected
rows/columns will be marked with an unfilled blue square . Selecting a single row /column
allows you to shift and scale it separately from the other rows/columns as shown in:
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To select all rows or columns:
• Click the following button:

Select all rows or columns.

How to Perform Smooth Phase Correction
To perform zero order phase correction:
1. Click-hold the following button (it turns green) and move the mouse:

Zero order phase correction.
Until the reference peak of the first row/column is exactly in absorption mode.

2. Release the mouse (button turns grey).
The parameter PHC0 will be set accordingly.

To perform first order phase correction:
1. Click-hold the following button (it turns green) and move the mouse:

First order phase correction.
Until the reference peak of the second and further rows/columns is exactly in absorption
mode.

2. Release the mouse (button turns grey).
The parameter PHC1 will be set accordingly.

How to Perform 90, -90 or 180° Zero Order Phase Correction
Click one of the following buttons:

90° zero order phase correction.

-90° zero order phase correction.

180° zero order phase correction.
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How to Reset the Phase to the Original Values
Click the following button:

Reset zero and first order phase.

How to Change the Mouse Sensitivity
Click one of the following buttons:

Increase (double) the mouse sensitivity [ .inc].

Decrease (halve) the mouse sensitivity [ .dec].

Reset the mouse sensitivity to 2.0.

How to Show the Next/Previous Row or Column
To show the next row/column, click the following button:

Show next row/column.
Note that only the selected row/column is increased. If all rows/columns are selected, only
the first one is increased.
To show the previous row/column, click the following button:

Show previous row/column.
Note that only the selected row/column is decreased. If all rows/columns are selected, only
the first one is decreased.

How to Arrange Rows or Columns
Click one of the following buttons:

Arrange rows/columns  horizontally.

Arrange rows/columns vertically.

Arrange rows/columns vertically in a split window.

How to Return from Multi-1D Phase to 2D Phase Display
Click the following button:

to save, execute and return.

This will perform the following tasks:
• Execute phase correction.
• Save the current phase correction values.
• Leave the multi-1D phase mode.

Click the following button:

To return to the 2D phase display without save.
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How to Return from 2D Phase Mode
Click the following button:

Return.

13.2 2D Interactive Integration
TopSpin 2.1 and newer supports interactive 2D integration.

13.2.1 How to Switch to 2D Interactive Integration

Click the corresponding button in the upper toolbar as indicated below:

Or enter .int on the command line.
The Tab bar of the active data window will be replaced by a toolbar. The figure below shows
an example of a 2D inverse spectrum.

Figure 13.1: Data window in interactive integration mode

The yellow button indicates that you are in integration mode.

"Define integral region" mode (active when green).
Move integral region (green when active).
Copy a region.

Delete all integral regions.

Read/import integral regions.

Save/Export integral regions.

Integrate current regions/define reference.
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Save integral regions and return.

Return without save.

13.2.2 2D Interactive Integration Procedure

When you switch to 2D integration mode, the "Define integral region" mode is active by
default. This means you can immediately start defining the integral regions. To do that:
1. Click and hold the left mouse button at any corner of a region to be defined, move the

mouse to draw a box around that region and release the mouse.
2. Choose one of the following options from the appearing popup menu:

Integrate: a: to add up all intensities in the region.
Integrate: +: to add up all positive intensities in the region.
Integrate: - : to add up all negative intensities in the region.
Integrate: a + -: to add up all intensities in the region and store separate entries for all,
positive and negative intensities.
Integrate: a +: to add up all intensities in the region and store separate entries for all and
positive intensities.
Integrate: a - : to add up all intensities in the region and store separate entries for all and
negative intensities.
Integrate: + -: to add up all intensities in the region and store separate entries for positive
and negative intensities.
The integral regions will be displayed along with their storage numbers and modes:

3. Click the  button and choose Integrate current regions from the pulldown menu to
integrate the defined regions.

4. Click the  button again and choose List integral values from the pulldown menu to
show the list of integrals.

The table below shows the list of integrals based on the regions defined in the figure above.
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# SI_F1 row1 row2 row1 ppm row2 ppm Abs. Int. Integral

SI_F2 col1 col2 col1 ppm col2 ppm

1 1024 666 689 50.14583 46.43132 9.2529e+008 882.42 a

1024 510 522 6.04420 5.89291

2 1024 597 632 61.28934 55.71759 1.1135e+009 1062 +

1024 520 533 5.91452 5.74162

3 1024 652 692 52.46739 45.96701 -3.7699e+007 -35.953 -

1024 566 579 5.31659 5.15089

4 1024 683 721 47.35995 41.32388 1.0072e+009 960.57 a

1024 589 605 5.02122 4.81230

5 1024 683 721 47.35995 41.32388 1.064e+009 1014.7 +

1024 589 605 5.02122 4.81230

6 1024 683 721 47.35995 41.32388 -5.6725e+007 -54.097 -

1024 589 605 5.02122 4.81230

7 1024 502 543 76.61168 70.11130 1.2637e+009 1205.2 a

1024 637 649 4.38726 4.23598

8 1024 502 543 76.61168 70.11130 1.2911e+009 1231.3 +

1024 637 649 4.38726 4.23598

Alternatively, you can define a reference integral and integrate the defined regions of the

same or of a different dataset, relative to this integral. For this purpose the  button offers
the following menu items:

• Integrate current regions rel. to reference: You will be prompted for the reference
integral number and value.

• List integral values: The output list will now show an additional column with the
normalized integral values.

• Define current dataset as reference: You will be prompted for the reference integral
number and value.

• Integrate and use ref. dataset for calibration: The integral value defined on the
reference dataset is used for calibration.

How to Move an Integral region

1. Click the button  (it turns green).
2. Move the mouse into the region to be moved.
3. Left-click-hold and move the mouse to move the region.
4. Release the mouse at the desired position.

How to Copy an Integral region

1. Click the button  (it turns green).
2. Move the mouse into the region to be copied.
3. Left-click-hold and move the mouse to the desired position.
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4. Release the mouse to copy the region.

How to Delete all Integral Regions

1. Click the button .
2. Click OK to confirm deletion.

How to Read/Import Integral Regions

1. Click the button .
2. Click Read intrng to read the last stored integral ranges

or
Click Import Integration Regions to import an exported integral region file (see below)

How to Save/Export Integral Regions

1. Click the button .
2. Click Save Regions to intrng to save the regions to the current dataset PROCNO (file

int2drng)
or
Click Export Integration Regions to export the integration region file for general usage;
i.e. usage with other datasets.

How to Return from 2D Integration mode
Click the following button:

To save the current integral regions and return.
Click the following button:

To return to the 2D integration mode without save.

13.3 2D Multiple Display and Row/Column Handling
2D multiple display shows a 2D spectrum with an arbitrary number of 1D and/or 2D spectra
superimposed.
Spectra are ppm aligned or Hz aligned, according to the selected axis unit.
A superimposed 1D spectrum is automatically displayed in the direction of the matching
nucleus (for a hetero-nuclear 2D) or in the F2 direction (for a homo-nuclear 2D).
Although multiple display is normally used for spectra with matching nuclei, it allows you to
superimposed spectra with non-matching nuclei. You will get a warning that the nuclei do not
match. Click OK to continue.

How Switch to Multiple Display mode and Read Multiple Spectra
Switching to multiple display and reading multiple spectra can be done in two different ways:

• Read a 2D data set and click the button  to switch to multiple display mode. Then add
1D and/or 2D spectra, e.g. from the browser or with the command re.
or
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• Select multiple spectra in the browser, right-click one of them and click Display.
or

• Use the command .md in the command line.
For a more detailed description of reading multiple data in multiple display mode, see chapter
1D Multiple Display [} 137].
In multiple display mode, the Tab bar of the active data window is replaced by a toolbar:

Figure 13.2: Multiple display with two 2D spectra superimposed

Figure 13.3: Multiple display with a 1D spectrum superimposed on a 2D spectrum

The browser in multiple display lists in the Data List all open datasets (see the figure below):
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Figure 13.4:

How to Align Multiple 2D Spectra
2D spectra in multiple display can be individually shifted. To do that:

• Select one of the spectra in the lower part of the browser.
• Click one of the Shift Buttons in the desired direction up, down or both (e.g. ) hold and

move the mouse.
The figure below shows a region of two comparable 1H/13C inverse 2D data sets which are
shifted relative to each other.

Clicking the button resets individual scaling and shifting.

How to Display the Next/Previous Name/Expno
To compare a series of spectra you can interactively increment or decrement the dataset
name or expno. A dataset name is incremented according to the Icon-nmr naming convention
of increasing extensions, e.g. name.001, name.002 etc.

• Click one of the following button (button turns green):

Show the previous name/expno/procno of the last dataset.

Show the previous name/expno/procno of the last dataset.
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Set the increment options. Clicking this button will open the following dialog where
you can choose to increment the procno, expno or name, set the expno increment and
switch individual scaling on/off.

How to Scan Rows/Columns
Select desired dataset(s) and click one of the following buttons to activate the scanning
modus. Deactivation needs a second click on the button:

• To scan rows in the 2D spectrum.

• To scan columns in the 2D spectrum.

• To scan rows and columns in the 2D spectrum.
• Moving the mouse in the data field shows the current row or column in separate. Change

the data selection in the Data List to switch between datasets. To switch the modus
quickly use the item Toggle Rows/Columns in the context menu (right mouse click).

To scale up the displayed row/column:
• Click the left mouse button or turn the mouse wheel up.

To scale down the displayed row/column:
• Click the middle mouse button or turn the mouse wheel down.

How to Grab a Row/Column
You can grab a row or column, i.e. keep it displayed in the data window as follows:
1. Scan rows or columns as described above and hold at the desired position.
2. Right-click in the data window.
3. Choose Grab Row/Column from the popup menu.
Note that a grabbed row/column appears in the lower apart of the browser. It can be selected
there and individually scaled or shifted.
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The figure above shows row 619 with the 1D baseline at the center of the data window.

How to Show the Next/Previous Row or Column
To show the next row/column, click the following button:

Show next row/column.
To show the previous row/column, click the following button:

Show previous row/column.
Alternatively, you can turn the mouse wheel, while pressing the Shift key to show the next/
previous rows/columns.

How to Move the Selected Data Set Up/Down in the Data Set List
To move the selected data set up, click the following button:

Move the selected data set up.
To move the selected data set down, click the following button:

Move the selected dataset down.

How to Extract a Row/Column
1. Scan rows or columns as described above and hold at the desired position.
2. Right-click in the data window and choose Extract Row/Column from the popup menu.
3. Specify the row/column number and output procno in the dialog box. Note that the ROW/

COLUMN field is initialized with the grabbed row/column or, if no grabbing was done, with
the current row/column.

4. Click OK.
The extracted row or column is stored as a 1D data set under the specified PROCNO and
displayed in a new data window. In the upper left part of this, the row number and source 2D
data set is specified:
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How to Copy Contour Levels from First to Other Spectra
Click the following button:

Copy contour levels from the first to the other spectra.
Note that the contour levels are only changed on screen, not on disk.

How to Position the Baseline of the Row/Column
To put the baseline at the center of the data window:
1. Right-click in the data window.
2. Choose in Baseline At Center from the popup menu.

To put the baseline at the bottom of the data window:
1. Right-click in the data window.
2. Choose in Baseline At Bottom from the popup menu.
This works both in the scan submode or on a grabbed row/column.

13.3.1 2D Calibration in Multiple Display

How to calibrate data in multiple display
It is possible to align data in a multiple display interactive or in an automated in F1 and F2
direction:

To calibrate data interactively, select a spectra and use the shift buttons ,  to align the

multiplets. Using the calibration button  the following dialog appears:
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Figure 13.5: Spectra Alignment Dialog

The exact shifts are displayed in the dialog. The selection marks the reference data and only
the selected direction will be saved. When confirming the dialog the shifts will be saved in the
processing parameter SR.

In the automated calibration step the alignment will be determined automatically. Use this
feature in one of both ways:

• Click the button  in the multiple display modus. Next, the correctly aligned spectra
will appear on the screen with a dedicated dialog on the top (see the figure above). The
dialog shows the necessary chemical shift relative to the reference. The default reference
in the calculation is the first dataset. Change the reference by changing the data selection.
With the conformation the current result will be saved in the SR parameter.

• Use the command autocalib in the command line or in AU programs (for further
information read more about the command in the TopSpin Processing Manual - Analysis
Commands).

13.4 2D Interactive Calibration
A 2D spectrum can be calibrated, automatically with the command sref or, interactively as
described below.

How to Switch to 2D Calibration mode
• Click the corresponding button in the upper toolbar:

or enter .cal on the command line. The Tab bar of the active data window will be replaced by
a toolbar:
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Figure 13.6: Data window in calibration mode

The yellow button indicates that the data window is in calibration mode.

How to Perform 2D Calibration
In calibration mode:
1. Left-click in the data window at the reference peak.

The following dialog box will appear:

Note that the units for F2 and F1 (Hz or ppm) correspond to the axis units of the display.
2. Enter the F2 and F1 frequency you want to assign to the reference peak.
3. Click OK.
The spectrum will be calibrated and re-displayed. 2D Chemical Shift Distance Measurement.

How to Measure a 2D Chemical Shift Distance
1. Click the following button (button turns green):

Chemical shift distance measurement.
2. Click-hold the left mouse button at one peak position and drag the mouse to another peak

position.
The distance in ppm, will be displayed.

3. Right-click in the data window to quit distance mode (button turns grey).
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Figure 13.7: Data window in distance measurement mode
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14 Data Window Handling

14.1 Data Windows
The TopSpin window has a data area that may contain multiple data windows. The size of the
data area depends on the overall size of the TopSpin window and on presence of the
Browser and/or Processing Guide. The following figure shows the TopSpin window with the
Browser and three data windows.

Note that the three data windows show different data objects: 1D processing parameters, a
1D spectrum and a 2D spectrum.

How to Move a Data Window
• Click-hold the title bar and move the mouse.

How to Resize a Data Window
1. Move the cursor to the window edge until it becomes a double-headed arrow.
2. Left-click-hold that position and move the mouse.
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Depending on the position of the double-headed arrow, you can change the window height,
width or both:

How to Select (activate) a Data Window
The active data window is the window of which the title bar is highlighted. The TopSpin menu,
tool bars and command line commands correspond to and act on that window. Only one data
window is active at a time.
To activate a different data window:

• Click in the desired data window or click its title bar.
or

• Click one of the colored radio buttons above the data area. The pressed radio button (the
green one in the example below) corresponds to the current dataset.

If you hold the cursor over one of the buttons without clicking it and wait a few seconds,
the corresponding dataset specification will be shown.
or

• Click Window => x dataname expno procno dir user
Where x is the number of the desired window and dataname, expno, procno, dir and
user refer to the data set displayed in that window.
or

• Hit the F6 key to activate the next window. Repeat that until the desired window is the
active window.

How to Open a New empty Data Window
• Click Window => New window [ Alt + w- n ].

The new data window will become the active window and will, by default, cover the entire 
data area, hiding possible existing data windows. To open a dataset in the new window, drag
a dataset from the browser or from the Windows Explorer into the new window or click File
=> Open (see also chapter Opening Data [} 46]).

How to Arrange Data Windows
If the data area contains multiple data windows, you can arrange them in various ways. All
the arrange commands arrange the windows left to right and/or top to bottom in the order in
which the windows have been active. The currently active data window will therefore be
positioned at the top and/or left of the data area.
To arrange the data windows as a grid:
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• Click Window => Arrange as a Grid.
Depending on the number of windows, they will be arranged vertically and/or horizontally:

To arrange data windows in stack:
• Click Window => Arrange in Stack.

To arrange data windows side by side:
• Click Window => Arrange Side-by-Side.

To cascade data windows:
• Click Window => Cascade.
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Note that you can instruct TopSpin to open new data windows cascaded rather than
maximized as well configure cascaded windows (command set => Window settings, see
also chapter Opening Data [} 46]).

How to Iconify (minimize) a Data Window

• Click the  button in the windows title bar.
or

• Click Window => Iconify all to iconify all windows.

How to De-iconify a Data Window

• Click the  button or double-click the title bar.

How to Maximize a Data Window

• Click the  button or double-click the title bar.
The window will cover the entire data area. Note that a maximized window cannot be moved
of resized but can be restored (in size and position), iconified or closed.

How to Restore the Size and Position of a Data Window

• Click the  button or double-click the title bar.

Note that this is only possible if the title bar contains the  button. This is only the case after
the window has been maximized or iconified.

How to Close a Data Window
To close the active data window:

• Click File => Close [ Crtl-w].
or

• Click the  button in the windows title bar.

To close any data window:

• Click the  button in the data windows title bar.
or

• Click the title bar and then click File => Close [ Crtl-w].

To close all data windows:
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• Click File => Closeall [ closeall]

How to Iconify all Data Windows
• Click Window => Iconify all.

How to Maximize all Data Windows
• Click Window => Maximize all.

The active window will be displayed on top, all other windows are hidden.

How to Activate the Next Data Window
• Click Window => Next window [ F6].

The windows title bar will become highlighted.

14.2 Window Layouts
A data window layout defines the position, geometry and window type of one or more
TopSpin windows. The following windows types are available:

• Data windows.
• Lock display window.
• Acquisition display window.
• BSMS display window.
• Temperature unit window.

How to Save the Current Window Layout
1. Click Window => Save layout.
2. In the appearing dialog box: Specify the layout File name (extension .prop) and click Save

Layout.

How to Read a Window Layout
1. Click Window => Read layout.
2. In the appearing dialog box: Specify or click the layout File name and click Read Layout.
Windows are arranged according to the following rules:

• Each currently displayed window type gets the position and geometry to the
corresponding definition in the layout.

• If a window type is displayed but not defined in the layout, it keeps its current position and
geometry.

• If a window type is defined in the layout but not displayed, the layout definition is ignored.
• Multiple data windows are, arbitrarily, assigned to the available data window definitions.

How to Swap Data Windows
Within a certain layout, you can easily swap two TopSpin windows with the command swin. If
the data area contains exactly two windows, swin simple swaps their position and geometry.
If it contains more than two data windows, swin opens a list from which you can select any
window to be swapped with the currently selected (active) window. Swapping windows can
also be executed from the Window menu.
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How to Toggle Window Decoration
By clicking Window => Window Layout => Toggle Window Decoration easy toggling of
window decoration is available. Especially users who work with many different windows will
get more space on their monitor by using this function that hides - respectively shows - the
title of the current window and reduces the used font.
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15 Analysis

15.1 Introduction
TopSpin offers various data analysis methods including chemical shift measurement, signal
to noise calculation and T1/T2 relaxation analysis as described in this chapter. Furthermore,
it offers the following structure analysis tools:

• Multiplet Analysis: This allows you to easily define multiplets and deduce chemical shifts,
coupling constants, multiplicities and connections.

• Daisy: (TopSpin 2.0 and newer) This allows you to simulate spectra based on chemical
shifts and coupling constants.

• Solids Line Shape Analysis: This allows you to simulate and fit calculated spectra to
various experimental 1D solid NMR spectra.

• Jmol: A 3D Structure Viewer for displaying chemical structures.
• D molecule structure editor: A program for drawing chemical structures, offering a large

number of drawing tools.
• DNMR (Dynamic NMR) Lineshape Analysis: A program to simulate temperature

dependent NMR spectra, interactively set up and iteratively refine the model parameters
to get the best fit of the measured and simulated 1D NMR spectra.

Structure analysis tools can be started from the Analysis menu. They are all described in the
following manuals:

• Click Help => Manuals => [ Analysis and Simulation] Structure Analysis Tools.
except for Daisy, which is described in the separate manual:

• Click Help => Manuals => [ Analysis and Simulation] Daisy.

15.2 Chemical Shift Distance Measurement

How to Measure a Chemical Shift Distance
1. Click the following button (button turns green):

Chemical shift distance measurement.
2. Left-click-hold at one peak position and drag the mouse to another peak position.

The distance in ppm, will be displayed.
3. Right-click in the data window or move the cursor out of the data window to leave distance

measurement mode (button turns gray).

15.3 1D Signal to Noise Calculation

How to Perform Interactive S/N Calculation
1. Click Analysis => Signal/Noise Calculation [ .sino].
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The current signal region (parameters SIGF1-SIGF2) and noise region (parameters
NOISF1-NOISF2) are displayed.

Data window in S/N measurement mode.
2. Move the mouse into the data window.
3. Left-click-hold and drag the mouse from one edge of the signal region to the other edge.

A horizontal double-headed arrow will indicate the signal region.
4. Left-click-hold and drag the mouse from one edge of the noise region to the other edge.

A horizontal double-headed arrow will indicate the noise region.
5. Right-click any position in the data window. The popup menu as shown will appear:

Choose Start S/N calculation.
The other entries allow you to redefine or clear the regions. After the noise calculation has
finished, the result will appear on the screen.

How to Delete the Signal Region or Noise Region
To delete the current signal region:
1. Right-click in the data window.
2. Choose Clear SIGREG from the popup menu.

To delete the current noise region:
1. Right-click in the data window.
2. Choose Clear NOISEREG from the popup menu.

How to Edit the Limits of the Signal Region or Noise Region
1. Right-click in the data window.
2. Choose Edit regions... from the popup menu.
3. Enter new limit values in the appearing dialog box:
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4. Click OK.
The S/N value is automatically recalculated and displayed.

How to Change the Width of the Signal Region or Noise Region
1. Right-click in the data window.
2. Choose Change region width... from the popup menu.
3. Enter new width values in the appearing dialog box:

4. Click OK.
Note that as you change the width, the right limit is modified correspondingly. The left limit is
kept. The S/N value is automatically recalculated and displayed.

15.4 Deconvolution
The Analysis menu of TopSpin offers the possibility of deconvolution. This line shape tool is
especially useful to interpret complex spectra in which peaks cannot be defined clearly.
Deconvolution calculates theoretical signals with different methods, for example Gaussian,
Lorentzian or a mixture of these line shapes. As a result information of peak position, line
width and integrals of deconvolved signals are available. Furthermore it is possible to display
them graphically. With this auxiliary tool peaks of 1D and 2D NMR spectrum can be
interpreted more easily. Overlapping peaks may be deconvolved into a sum of such line
shapes.
To start deconvolution, expand the spectrum on the display to show the peak or peak group
of interest. Deconvolution can be activated from the command line by typing dcon or from
TopSpin toolbar by clicking Analysis --> Line Shape Fitting --> Lorentz / Gauss
Deconvolution. The following dialog box will appear:
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After clicking OK different adjustments can be made.

For further information about all deconvolution options and the parameters to be set, please
look up the Processing Reference Manual (commands gdcon, ldcon, mdcon, ppp, dconpl
and dcon).
TopSpin shows the deconvolution result, i.e. peak positions, line widths and integrals on the
screen and stores it in the file dconpeaks.txt within the respective procno of the data set:

After closing the editor window which shows the deconvolution result, TopSpin switches
automatically to multiple display mode to show the original spectrum and the sum of the
computed line shapes superimposed:
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With the option Display the Lorentz/Gauss curves of the last Deconvolution of the
Deconvolution window it is possible to display the results of the deconvolution also
graphically:

Please note that the results of deconvolution are approximated achievements to interpret
complex spectra. These amounts are according to reality if the signal is an ideal Gauss- or
Lorentzian shape and if the complete region of the signals is deconvolved.

15.5 Relaxation Analysis
Typically, relaxation data consist of a series of 1D FIDs measured with varying delays and
stored as pseudo 2D data. To analyze these data, TopSpin offers an easy to use T1/T2
Relaxation Guide. Relaxation curves of various experiment types with up to six components
can be fitted.
To start the Relaxation Guide:

• Click Analysis => T1/T2 Relaxation [ t1guide].
This will open the dialog box as shown in:

Click the successive icons and follow the instructions on the screen. Note that holding the
cursor over an icon shows the command line command that is executed when the icon is
clicked. If you prefer to execute these commands from the command line, just click the Close
button to close the Relaxation Guide.



Analysis

180 H9469SA3_2_003

Extract Slice
Prompts you for the FID or spectrum to be extracted for peak determination:

Click FID to extract an FID or Spectrum to extract a spectrum. Note that the latter only works
if the pseudo 2D data have been processed. If you click FID, the extracted FID is
automatically processed. We recommend entering the FID or spectrum number which was
measured with the longest delay. It can be found in the vdlist file in the EXPNO data
directory. Then you can choose between:

• Manual Integration. This will switch to Interactive integration mode. The highest peak in
each region will be used for relaxation analysis.

• Manual Peak Picking. The selected peaks will be used for relaxation analysis.

Peaks/Ranges
Switches to interactive integration or peak picking mode as selected above. Here you can
define the ranges or peaks to be included in the relaxation analysis. Then use  button to
export regions/peaks to Relaxation Module and quit the interactive mode.
Relaxation Window
Switches the 1D data window to relaxation analysis mode:

And performs a default fitting. By default, this is one-component, T1-intensity fitting (Function
type uxnmrt1) for peak 1. If the dataset was already fitted, the previous type of fitting is
performed. The fitting curve is displayed in the data section and a Brief Report is shown in
the parameter section. If this default fitting is appropriate, you can view, interpret and print the
results as described below. If not, you can perform the desired fitting as described below.
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Perform Fitting and Calculate the Relaxation Time
Depending on the experiment, you can perform the appropriate fitting as follows:
1. Select a Fitting type: Intensity or Area. Either every point reflects the intensity of the

biggest peak in the defined integral range or the integral itself. Both of them can be used
but, depending on the experiment, one of them usually give a better fitting curve.

2. Click the  button to open the parameter dialog box. Select a� Function Type and set
the required parameters (see below).

3. Click OK.
4. Perform fitting and calculate the relaxation time:

Fit the relaxation curve for the current peak.

Fit the relaxation curve for all peaks.

Fit data according to the ASCII file t1ascii.
View and interpret the results as described below.

Function Types and Parameters
The TopSpin relaxation routine offers functions for various relaxation experiments with up to
6 components:
uxnmrt1 for one-component T1 experiments. Set the parameter List file name to the list type
used during the acquisition. Set Pick data points to PD or PD0 (see below). The T1 fitting
function is defined by the function:

Where I is Intensity or Area according to the Fitting Type. The best fit is calculated by varying
I(0), P and T1 in an iterative process according to the Levenberg-Marquardt algorithm.

Clicking  and  executes the commands ct1 (current peak) and dat1 (all peaks),
respectively.
uxnmrt2 for one-component T2 experiments. Set the parameter List file name to the list type
used during the acquisition. Set Pick data points to PD or PD0 (see below). A T2 fitting
function is defined by the function:

Where I is Intensity or Area according to the Fitting Type. The best fit is calculated by varying
P and T2 in an iterative process according to the Levenberg-Marquardt algorithm. Clicking

 and  executes the commands ct2 (current peak) and dat2 (all peaks), respectively.
invrec, satrec, cpt1rho, expdec, gaussdec, lorgauss linear, varbigdel, varlitdel,
vargrad, vardamp: these functions can be used for various experiments with up to 6
components, except for cpt1rho and lorgauss which allow only 4 and 3 components,
respectively. They all use the simplex algorithm and require some parameters to be set:

• Enter the Number of components.
• Click the Setup button to set the Iteration Control parameters. For each component, the 

initial guess (G) and step rate (S) can be set. The initial guess for I[0] must be selected
such that the sum of all components does not exceed 1. If there is only one component,
I[0] is usually set to 1.The step rate is usually set to about one tenth of the initial guess. If
the step rate of a variable is set to zero, then this variable is not changed during the
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iterations. Note that the initial guesses can also be set with the  toolbar button. Clicking

 and  executes the commands simfit (current peak) and simfit all (all peaks),
respectively.

The Fitting Function to pick data points can be:
• pd - Pick data points for relaxation analysis (Drift value interpreted).
• pd0 - Pick data points for relaxation analysis at constant peak positions (drift value

ignored).
• pft2 - Pick data points for T2 calculation of 1D raw data.

View the Fitting Results
When the fitting procedure has finished, the fitting curve is displayed in the data section and a
Brief Report appears in the parameter section. The latter consists of:

• The calculated relaxation value.
• The fitted parameters.
• The standard deviation SD.

For further examination of the result, click one of the following buttons:

Show the fitting result of the previous peak/area.

Show the fitting result of the next peak/area.

Switch x-axis to linear scaling.

Switch x-axis to logarithmic scaling.

Switch x-axis to square root scaling.

Switch y-axis to logarithmic scaling. Note that this only works for curves with positive
intensities/areas only.

Import integrals from dataset ~TEMP.

Export integrals to dataset ~TEMP.

Toggle button to hide/show information in the curve field, including algorithm, peak
number and relaxation value.

Show an extended report, including the fitted intensity or area distribution. This consists of
the same information as the brief report plus a table with the intensity or area distribution.
Example:
Dataset : C:/bio/data/guest/nmr/t1test/1/pdata/1

INTENSITY fit :

I[t]=I[0]+P*exp(-t/T1)

12 points for Peak 1, Cursor Point = 7.221 ppm

Results Comp. 1

I[0] = 1.215e+000

P = -2.211e+000

T1 = 19.449s

SD = 3.685e-003
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tau ppm integral intensity

30.000s 7.221 2.5811e+009 1.9737e+008

10.000s 7.221 -3.2898e+008 -2.9056e+007

8.000s 7.221 -7.8525e+008 -6.4616e+007

5.000s 7.221 -1.6289e+009 -1.3101e+008

...

Print, Export of Copy the Fitting Results
To print the fitting curve:

• Click File => Print.
To export the fitting curve as a graphics file:

• Click File => Export.
To copy the fitting curve to the Windows Clipboard:

• Click Edit => Copy.
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16 Acquisition
This chapter describes TopSpin acquisition as far as the interface is concerned. Individual
acquisition command are described in the Acquisition Reference manual.

16.1 Acquisition Guide
If you are a new or occasional user, we recommend you to acquire your data with the
TopSpin Acquisition Flowchart. This will guide you through the typical sequence of acquisition
steps. To start the Acquisition Guide, click Spectrometer => Acquisition Flowchart.

In Automatic mode, the Acquisition Flowchart will simply execute each command when you
click the respective button. This requires the acquisition parameters to be set correctly. In
interactive mode (Automatic mode unchecked), the Acquisition Flowchart will, at each step,
open a dialog box offering you the available options and required parameters. Note that the
last button To processing will open the processing equivalent of the Acquisition Flowchart,
the Processing Guide.

16.2 Acquisition Toolbar
Acquisition can be prepared, started and controlled from Spectrometer menu. Clicking this
menu opens the pulldown menu:



Acquisition

186 H9469SA3_2_003

Here you find several categories of acquisition related commands. Each entry gives access
to a submenu with various commands. The following figure, for example, shows the Setup
submenu.

For most entries, the command line command, for example expinstall, is specified in square
brackets. Furthermore, TopSpin can be configured such that right-clicking any menu entry will
display the corresponding command line command. To do that right-click in an empty part of
the menu bar and choose Define Right-click Action.
For convenience, common acquisition commands can also be started from the TopSpin
toolbar. The right part of the upper toolbar shows the following buttons:

Start the acquisition. Acquires NS scans in the current dataset, over writing possibly
existing data. Equivalent to the command zg.

Halt the acquisition. This stops the acquisition after the current scan has finished. All
data acquired so far are saved. Equivalent to the command halt.

Stop the acquisition. This stops the acquisition immediately. Data acquired after the last
disk write (if any) are lost. Equivalent to the command stop.

Open the online FID display window. Shows the currently acquired FID. Only works
during acquisition. Equivalent to the command acqu.
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Open the Lock display window. Shows the lock signal. Equivalent to the command
lockdisp.
Open the BSMS contrrol suite.

Calculate the experiment time. Shows the total experiment time and file size of the raw
data. Equivalent to the command expt.

Set SFO1, O1, O2 and O3 interactively. Puts a red cursor line in the data window. A left-
click at the desired frequency opens a dialog box where you can set O1, O2 and/or O3.

Set the sweep width to the current region and the spectrometer frequency to the center
of the current region. Update the parameters SW and SFO1, respectively.

Setup a frequency list interactively.

16.3 Data Window Toolbar
TopSpin 2.0 and newer support data set specific acquisition display. It is activated by clicking
the Acqu tab of the data window toolbar. Alternatively to open the Acqu tab you can right
click in the status bar under the TopSpin command line:

From here, you can start various acquisition commands like:

Start acquisition [zg].

Halt the acquisition [halt].

Stop the acquisition [stop].

Probe matching and tuning [wobb].

Interactive Parameter Adjustment [gs].
Data specific acquisition display allows you to open multiple acquisition display windows, one
for each data set.
Note that the Acqu tab is automatically activated when the acquisition is started from the
TopSpin menu, toolbar or command line.
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16.4 Acquisition Status Bar
The acquisition can be followed and controlled from the acquisition status bar. Before you
use the acquisition status bar, it must be configured from the User Preferences window. To
do that:
1. Click Options => Preferences [ set].
2. Click Acquisition status bar in the left part of the User preferences box. This will show

the status bar items:

3. Check the desired entries.
To switch the acquisition status bar on:

• Click Spectrometer --> Acquisition Status Bar On/Off
or

• Right-click in the status line at the bottom of the TopSpin window and choose the popup
menu Acquisition Status Bar On/Off

With the entries selected above, the right part of the status bar will look like this.

Acquisition display (left side) see above.
Acquisition display (right side) see below.

The acquisition status bar not only displays information, it also allows you to perform various
actions, e.g.:

• Double-click the Time field to view detailed time and date information.
• Double-click the Lock field to open the lock display.
• Left-click the Spooler /queued /delayed /cron field to open the spooler main window.
• Double-click on sample field to open BSMS control suite.
• Double-click on VTU opens the edte window.
• Right-click the Fid Flash field to switch on/off FID flashing or to stop the acquisition.
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• For more information about peak power check (POWCHK) please look up the Acquisition
Reference Guide, Chapter 3 - Spectrometer configuration commands. Within the
command explanation of cf you will find the functionality of POWCHK.

• Right-click the Acquisition information field to open the following popup menu:

From this menu, you can start various acquisition commands.
• Right-click the VTU field to open the following popup menu:

Clicking Options will open the following dialog box:

• Right click the Lock field to open the following popup menu:

• Right click the Spooler field to open the following popup menu:

16.5 Command Queuing and Scheduling
TopSpin 2.0 and newer support command queuing (spooling) and scheduling. Acquisition
commands like zg, go, rga and atma are automatically queued, if this feature is on (default
off). This allows you, for example, to enter multiple zg commands on different data sets.
Automatic queuing can be switched on as follows:
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1. Click Options => Preferences
2. In the User Preferences dialog:

– Enable Auto-Spooling under Administration Items
Processing commands can be queued with the command qu. For example, the command
sequence zg ; qu xfb on a 2D data set, will start an acquisition and, when this has finished,
process the data.
Acquisition and processing commands can be scheduled with the command at. Enter help
qu or help at, for more details on the respective commands.
Queued commands can be viewed in the Spooling field of the acquisition status bar. Note
that the spooling field must be activated in the User Preferences window (command set).

16.6 Tuning and Matching the Probe
Tuning and matching of conventional probes, (non ATM), is performed with the wobble
procedure. To start this:
1. Enter wobb on the command line.

The data window toolbar switches to the Acqu tab and the wobble window is opened:

The buttons of the wobble toolbar have the following functions:

Change the number of wobble steps [wbst].

Change the wobble sweep width [wbsw].

Change the wobble frequency.

Switch to the next channel/nucleus (if available).

Stop the wobble procedure.
2. Turn the tuning and matching knobs on the probe until the wobble curve is exactly in the

middle and its minimum reaches the zero line.

Automatic tuning and matching of ATM probe can be performed with the command atma.
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16.7 Locking

The lock display can be opened by clicking the button in the toolbar or entering lockdisp
on the command line. The lock display window will appear:

Here, you can view the lock signal, either during the lock-in procedure or, as shown above,
after lock-in has been successful. At the top of the lock window the following buttons are
available:

Open the user preferences window [ set].

Toggle lock monitor mode.

Lock the magnetic field [ lock].

Toggle lock display mode between single and dual color. Colors can be set in the User
preferences (command set).

Switch grid mode between both, vertical, horizontal and off.

Make the lock display external.

Put focus into TopSpin window.

Close the lock display window.
Note that an external lock display window is independent from the TopSpin window. You can
for example, minimize TopSpin while keeping the lock display open.
The lock display can also be opened by double-clicking the lock field in the acquisition status
bar (see Acquisition Status Bar [} 188])
The lock process can be started by entering lock on the command line. This command is
described in the Acquisition Reference manual.

16.8 BSMS Control Panel
The BSMS control panel allows shimming, locking, sample handling and helium level
measurement. To open this panel:

• Enter bsmsdisp on the command line
The BSMS Control Suite window will appear:



Acquisition

192 H9469SA3_2_003

The individual function of the BSMS control panel are described in detail in the Acquisition
Reference manual.

16.9 Interactive Parameter Adjustment (GS)
Several parameters can be adjusted interactively, while observing the acquired FID. To start
this:

• Enter gs on the command line.
A split window will appear showing:

• The FID display:

• The GS parameter adjustment dialog:
The buttons of the FID display are the same as for the acquisition command zg.
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The GS parameter adjustment dialog offers tabs at the top of the window to select power,
frequency, delay etc. The selected parameter is shown in the middle of the window. The
slider at the right of the window allows you to change the selected parameter. The current
value can be viewed and modified in the field below the slider. The sensitivity of the slider can
be set in the field Sensitivity above the slider.

The effect of the change can be viewed in the FID display, the right part of the window. This
can be manipulated with the FID display buttons as described in Running an Acquisition
[} 193].

At the bottom of the window you find the following buttons:
• Save: Save the value of the current parameter.
• Save all: Save the values of all changed parameters.
• Restore: Restore the value of the current parameter.
• Restore all: Restore the value of all changed parameters.
• Stop: Stop the acquisition and quit the GS window.

16.10 Running an Acquisition
A typical acquisition is performed as follows:
1. Create a new data set.

– Click File => New [ new, Ctrl+ n].
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– Specify the data path variables name, expno, procno, dir and user, select the desired
Solvent and Experiment, enter the Title and click OK.
The data set will appear in the data field with no raw and no processed data available.

2. Click the AcquPars tab to display the acquisition parameters.

– Optionally: click  to show the pulse program parameters only.
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– Click the  button to read the prosol parameters.
or
Set the relevant parameters manually.
As an alternative to step 2, you can set the acquisition parameters interactively in the
GS window (see Interactive Parameter Adjustment (GS) [} 192]).

3. To start the acquisition:

– Click  in the upper toolbar or enter zg on the command line.
The data window toolbar will automatically switch to the Acqu tab and the FID display
window will appear:

The buttons in the toolbar have the following functions:

Show FID in shuffled mode.

Show FID in unshuffled mode, horizontally arranged.

Show FID in unshuffled mode, vertically arranged.

Show FID in unshuffled mode, interleaved.

Switch between FID and spectrum.

Stop the acquisition [ stop].

Halt the acquisition [ halt].

Clicking the button to switch to real time FT, turns the button green and opens two
extra buttons:

Switch between FID and spectrum.
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Real time FT settings.

Toggle calculation of peak with at 50%, 5.5% and 1.1% height (Shown as status
parameters).

Clicking the  button opens the following dialog window:

The acquisition information will appear in the acquisition status bar at the bottom of
the TopSpin window, for example:

4. When the acquisition has finished:
– Enter efp to process the FID.

The processed spectrum will be displayed in the data window that was opened upon
creating the dataset:

From here, the processed data can be analyzed, printed and/or archived.

16.11 Shape Tool
The Shape tool interface allows you to create/manipulate RF shapes and wave format.
To start the Shape Tool interface:

• Click Spectrometer => Shape Tool
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or
• Enter stdisp on the command line.

The Shape Tool window will appear:

This consists of a toolbar, a command line and a split pane with a data section at the right
and a parameter section at the left.
If Shape Tool is opened with a dataset the current dataset will be displayed.
By default, a 1000 point Gauss shape is displayed with Truncation level 1.0.
The TopSpin menu is changed showing the additional Shapes and Manipulate menus and
the adjusted File, Analysis and Options menus.

Note that all functions of the interactive Shape Tool can also be performed non-interactively
with the TopSpin command st. This command must entered with the appropriate arguments
on the command line while the associated dataset is displayed and selected.
A full description of the interactive and non-interactive Shapetool can be found under:

• Click Help => Manuals => [ Acquisition Application Manuals] Shapetool

Easy definition of Shape pulses
The usage of shaped pulses for the selective excitation is a nontrivial task that couples
together all parameters such as the power level, pulse length and the excited region.
TopSpin 2.1 and newer offers easy setup of selective experiments.
For usage Shape tool is typically started by the command stdisp on a finished 1D preparation
experiment.

Define the excitation regions:
Creates a new region on the display. The region is put in the middle of the currently visible
area. By using the mouse position and width can be changed.
Deletes defined regions. This command removes all regions. Single region can be removed
using the region pop up menu.
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Edit the excitation parameters
Opens a region editor. The region extent, the excitation type and the wave form assigned to
the region can be edited. Selection "Use same shape for all regions" button assigns the same
rotation type and wave form to all regions.

The setting of available wave forms depends on the selected rotation type. The following
itemization explains the rotation types:

• Excitation: Used for selective excitation, the magnetization rotates from Iz to horizontal
plane

• Inversion: Inverts the magnetization vector in the vertical plane (Iz to -Iz).
• Refocusing: Inverts the magnetization in the transversal plane (Iy to -Iy).

Calculate the pulse and display the excitation profile
• The resulting wave form is generated and the excitation profile is calculated:
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Store the results
• Pressing the save button writes the waveform on the disk an saves the necessary

parameters (pulse length, power level) to the target data set. Used parameters are set in
Options => Define Parameter Table. The target dataset may differ from the current data
(e.g. the spectrum on which Shape Tool started).

All regions and corresponding parameters (rotation type, waveform name) are stored on the
disk in the directory where the acquisition parameters reside. Following simple text format is
used by the file "Region File":
#Topspin excitation region list
#Mon Apr 30 08:59:43 CEST 2007
#Used format:
# Left (ppm) Rigth (ppm) RotationType Waveform RotationAngle
#Field RotationAngle is not mandatory
5.4886 5.2586 0 EBurp2 93.6
2.4758 2.1678 0 EBurp2 93.6

This region definition is stored automatically after each change. The definition is also read
automatically when starting Shape Tool.
For further information about Shape Tool and its functionalities please refer to the Shapetool
Manual.
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17 Configuration/Automation

17.1 NMR Super User and NMR Administration Password
During TopSpin installation, you are prompted to define:

• The user name for the so called NMR Super user. Under Windows this must be the name
of an existing user. Under Linux it can also be a non-existing user, which is then
automatically created by the installation program. After the installation, the NMR Super
user is the owner of all TopSpin program files. Logging in as this user allows you to
remove these files, change file permissions etc. The name of the NMRSUPERUSER will
be stored in the file:
<tshome>/conf/nmrsuperuser

• The NMR Administration password to be used for TopSpin configuration commands. This
password can be freely chosen and is not connected to any user. It is asked for by
TopSpin commands like cf, expinstall etc. The encrypted NMR Administration password
is stored in the file:
<tshome>/conf/nmradminpassword

Note that the NMR Super user login password and the NMR Administration password have
different purposes and are totally independent. Changing one of them does not affect the
other.

How to Change the NMR Administration Password
The NMR Administration password can be changed as follows:

Under Windows
1. Login as NMR Super user or Administrator.
2. Open a Command Prompt.
3. Enter:

<x>\perl\bin\perl <x>\prog\bin\installnmr <x> <NMRSUPERUSER>
Where <x> in the TopSpin installation directory.

4. Enter the old password and new password as requested.

Under Linux
1. Login as NMR Super user or root.
2. Open a Shell.
3. Enter:

<x>/prog/bin/installnmr <x> <NMRSUPERUSER>
Where <x> in the TopSpin installation directory.

4. Enter the old password and new password as requested.
If you don’t know the old NMR Administration password, you can still define a new one. In
that case, you have to delete the file:
<x>\conf\nmradminpassword
before you run the installnmr script.
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17.2 Configuration
The main configuration steps are performed by the commands cf and expinstall. They can
be started from the:

• Command line.
• Options => Spectrometer tools menu.
• Spectrometer => Setup menu.

However, the Spectrometer menu is only available after cf has been performed once,
choosing Installation for spectrometer.

How to Perform a Default Configuration on a Datastation
A default configuration can be used on a datastation. It is automaticallyperformed (no cf
required) during the installation of TopSpin on a new computer, a new disk or in a new
TopSpin installation directory. The default configuration name is Bruker_default_av500 and
corresponds to an Avance 500 MHz spectrometer.
For manual or interactive data processing, the automatic default configuration is sufficient. If,
however, you want to use AU programs, you must execute expinstall once, selecting
Installation for Data Station (Default).

How to Perform a Customized Configuration on a Data Station
If you want to configure your data station according to a spectrometer other than default, you
must first copy the configuration directory:
<tshome>/conf/instr/<instrum>
From that spectrometer to the data station. Here:
<tshome> is TopSpin home, the directory where TopSpin is installed. Note that this can be
different on the spectrometer than on the data station.
<instrum> is the configuration name.
After copying the configuration directory, you have to perform expinstall as follows:

• Click Spectrometer => Setup => Experiment installation or enter expinstall on the
command line.

Follow the instructions on the screen. In successive dialog boxes check/select the options
below and click Next to continue:

• Installation for Datastation (Customize).
• High Resolution Systems.
• The configuration name as it was copied from your spectrometer.
• The items you want to install.
• Select the desired printer and paper format for the parameter sets.
• The spectrometer frequency, acquisition mode and pre-scan-delay.

In the last dialog box, click Finish. The installation of the selected items will start now. Wait
until this process has finished.
For more details on expinstall, please refer to the description of this command in the 
Acquisition Reference manual.
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17.3 Parameter Set Conversion
The command paracon changes the basic frequency in parameter sets. This allows you to
use parameter sets which were created on a spectrometer with a different frequency. It opens
the dialog box shown in Automation [} 203].
Here you can setup a list of available parameter sets. You can select Bruker and/or User
defined parameter sets and uses a match string. The matching parameter sets appear in the
right part of the dialog box. To start the conversion, select one or more parameter sets and
click OK.

17.4 Automation

How to Install AU Programs
To install AU programs, you have to run the command expinstall (see Configuration [} 202]).

How to Open the AU Program Dialog Box
To get a list of all AU programs, enter edau or:
1. Click File => Run...
2. Click Execute an AU program in the appearing dialog box.
3. Click OK.
A dialog box showing either the Bruker defined or User defined AU programs. The following
figure shows a dialog box with two User defined AU programs.
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Figure 17.1: List with Two User Defined AU Programs

Note that Bruker AU programs are only shown if the command expinstall has been executed
once, after the installation of TopSpin.

How to Switch to the List of User defined AU Programs
• Click Options => Preferences => direcotries => Manage Source Directories in the

menu bar to open the AU program dialog box.



Configuration/Automation

H9469SA3_2_003 205

How to Switch to the List of Bruker defined AU Programs
• Click Options => Preferences => Directories => Manage Source Directories in the

menu bar to open the AU program dialog box.

How to Define the AU Programs Source Directory
1. Click Options => Manage Source Directories in the AU program dialog box.
2. In the field AU Programs: Add or modify AU program source directories.

How to Create an AU Program
1. Click File => New in the AU program dialog box.
2. Enter the AU program name in the field New name and click OK.
3. Enter the AU program lines in the edit field of the appearing dialog box.
4. Click Compile to compile the AU program.
5. Click File => Save to store the AU program.
6. Click File => Close to close the editor.
Alternatively, you can enter edau <name> on the command line to create the AU program
<name>.

How to Edit an Existing AU Program
1. Double-click the AU program name in the AU program dialog box.

Or
Click the Edit button to edit the highlighted AU program.

2. Modify the AU program according to you wishes.
3. Click Save to store the AU program under the name shown in the title bar.
4. You will be prompted to compile the AU program: click OK.
Alternatively, you can enter edau <name> on the command line to edit the AU program
<name>.

How to Execute an AU Program
1. Select the AU program in the AU program dialog box.
2. Click the Execute button.
Alternatively, you can enter <name> or xau <name> on the command line to execute the AU
program <name>.
If the AU program has not been compiled, compilation is automatically performed before the
execution starts.

How to Delete an AU Program
1. Select the AU program in the AU program dialog box.
2. Click File => Delete or click the Delete button.

How to Show Comments (short descriptions) in the AU Program List
To switch on/off the comments in the AU program list:

• In the AU program dialog box: Click Options and select the entry Comment.
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A comment is a short description of the AU program which is also part of the AU program
header.
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18 Regulatory Compliance
TopSpin complies with the FDA 21 CFR Part 11 regulations. Please read the document,
accessible under Help => Manuals => [Good Laboratory Practice] 21 CFR Part 11
compliance. This chapter describes the respective functionalities provided by TopSpin in
detail.

18.1 Audit Trails
A TopSpin data set consists of acquisition (= raw) data and processed data. These are stored
in a directory tree with the following structure:
<dir>\data\< user>\nmr\< name>\<expno>\pdata\<procno>
The acquisition data are stored in the expno subdirectory and the processed data are stored
in the procno subdirectory.

18.1.1 The Raw Data Audit Trail

Each expno sub-directory contains a text file audita.txt, the audit trail of the raw data. This
reflects the acquisition state of the raw data, and contains a checksum for the file itself
(audita.txt) and one for the raw data file (fid or ser). The latter checksum links the audit file
with the raw data. By means of the checksums, any illegal manipulation of the audit file or the
raw data file can be detected, using the TopSpin commands audit or auditcheck. Whenever
an acquisition is started, the possibly existing audit file is overwritten by a new one, belonging
to the new raw data file. By default, the user is warned when the current dataset already
contains raw data, thus preventing accidental overwriting (The option “Override existing fid
without inquiry” is, by default, off (see Options => Preferences => Acquisition).

18.1.2 The Processed Data Audit Trail

Each procno sub-directory contains a text file auditp.txt, the audit trail of the processed data.
It reflects the processing state of the processed data and contains a checksum for the file
itself (auditp.txt), and a checksum for the real processed data files (1r, 2rr, 3rrr, ...). The latter
checksum links the audit file with the processed data. By means of the checksums, any illegal
manipulation of the audit file or the processed data file can be detected, using the TopSpin
commands audit or auditcheck. Whenever a processing command is performed, the current
audit file is updated with this command and its associated parameters. When processing
starts from scratch (from a raw data file), the existing audit file is overwritten. As such, the
processed data can always be regenerated from raw data by applying the commands and
parameters listed in the audit trail.
If the laboratory management does not allow data files or audit trails to be deleted, a
respective saving procedure must be established. For this purpose, TopSpin provides data
copying commands, which may be called in a user defined macro or AU program, before a
new acquisition or processing starts.

18.1.3 Viewing Audit Trails

Since audit trails are regular ASCII text files, they can be viewed or printed with any text
editor, outside of TopSpin. Within TopSpin, you can use the command audit for this purpose.
This opens the dialog box:
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The first two entries allow you to view the audit trail files. The third entry performs an audit
trail check, i.e. a data consistency check. If both raw and processed data are consistent, you
will get the message shown below:

If the data have been manipulated outside of TopSpin, e.g. with third party software, the
checksum will be inconsistent. The next figure shows the message for inconsistent processed
data.

The fourth and fifth entry in the Audit Trail dialog box allow you to add a comment to the raw
or processed audit trail files, respectively.

18.1.4 Audit Trail Contents

The contents of an audit file is grouped in the following way:
(NUMBER, WHEN, WHO, WHERE, PROCESS, VERSION, WHAT)
These entries have the following meaning:

NUMBER
Running number of an entry, starting with 1.
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WHEN
Date of the entry, e.g. <2004-03-30 10:55:36.171 +0200>, where the last value represents
the offset in hours to Universal Time (UTC).

WHO
The user logged in, at the time the entry was generated. It has one of the two forms: <user1>
or <user1/user2>. The user <user1> is always the user who is logged into the operating
system (Windows or Linux user), and who started TopSpin. <user2> only appears, if the
NMR administrator has setup an internal TopSpin user administration, and the option Enforce
"login" for working with TopSpin in the User Administration dialog is enabled (see below,
command uadmin). In this case <user2> is the current internal TopSpin user.

WHERE
The network name of the current computer, e.g. <EOS2>.

PROCESS
The TopSpin process (module) which performed the acquisition or processing.

VERSION
The TopSpin version which performed the acquisition or processing.

WHAT
The type of acquisition or data manipulation performed.
Note that if only the entries NUMBER, WHEN, WHO, WHERE, WHAT are present, than the
audit trail was created by TopSpin 1.3 or older.

18.1.5 Adding a Comment to an Audit Trail

Audit trail entries are normally generated automatically by a respective acquisition or
processing command. However, a user can also add a comment manually, using the audit
command. This will generate a regular entry, the comment will appear under the WHAT
section and is preceded by the tag “user comment:”.
You may also add a comment to the raw data or processed data audit trail from an AU
program, using the macros AUDITCOMMENTA(comment) or AUDITCOMMENTP(comment),
respectively. Alternatively, you can store the comment in a file auditc.txt in the expno or
procno directory, and use the macros GDCHECK_RAW or GDCHECK.

18.1.6 Auditing User Defined Data Manipulations

When manipulating a data file with a user-defined algorithm, e.g. by means of an AU program
or external program, the data file and the respective audit trail become inconsistent
(detectable with the command auditcheck), and the data set is no longer compatible with
regulations. In order to solve this problem, TopSpin provides a function CheckSum File,
which adds the correct data checksum to the audit trails, and a function Audit Append for
additional text (an alternative to the comment function described above). These functions are
described in the AU manual which can be opened by clicking Help => Manuals =>
[Programming Manuals] AU programming.
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18.1.7 Audit Trails in JCAMP-DX and ZIP Archives

The TopSpin commands tojdx and tozip allow you to store a data set into a single file in the
internationally standardized ASCII-type JCAMP-DX format or in the well-known ZIP format,
respectively. Both storage formats retain the audit trails. When unpacking such files with
fromjdx or fromzip, respectively, the original data set in standard Bruker format is restored.
The command auditcheck may be used to check whether the data are still consistent. If, for
example, JCAMP-DX or ZIP file have been manipulated, the data might not be consistent.

18.2 Electronic Signatures

18.2.1 Signing a Data Set

The command esign adds an electronic signature to the raw data or to the processed data of
a data set. It opens a dialog where you can select the data component to be signed, the
signature meaning and, optionally, add a comment. The command esign requires that the
NMR administrator has set up a list of users who are allowed to sign a data set, along with
definitions of signature meanings (e.g. review, approval). See below for details, command
uadmin.

18.2.2 Structure of a Signature

In TopSpin, an electronic signature is realized as a special entry appended to the audit trail of
the raw or processed data. It is therefore linked with the data and protected against
manipulations just like any other audit trail entry. Signatures can be viewed with the
command audit. An electronic signature consists of the following items:

USER ID
The ID of the user logged in at the time esign was executed. This is either the user who was
logged into the operating system (Windows or Linux user), and who started TopSpin, or the
TopSpin internal user. Which of these two modes is applied depends on how the NMR
administrator configured TopSpin: If the option Enforce "login" for working with TopSpin is
disabled (see below, command uadmin), the first mode is active, otherwise the second.
What is the difference between the modes?

• In the first case, the System User (= Windows or Linux user) who started TopSpin signs
the data set. Prior to signing, esign requests this user's password, which is administrated
by the operating system (OS). No internal TopSpin user management plays a role.
Advantage: This mode is entirely OS compliant. Disadvantages: a) TopSpin termination/
restart is required when a different user wants to sign data (alternatively several licenses
would admit simultaneous TopSpin sessions). b) All TopSpin users must have an OS
login.
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• In the second case, any TopSpin internal user who is enabled by the NMR administrator
(with uadmin) may sign. Advantage: Convenient and easy usage. Disadvantage: TopSpin
internal user management is required (internal users and their passwords).

USER NAME
The complete name of the signer as specified by the NMR administrator during user
administration (command uadmin).

SIGNATURE MEANING
The meaning of a signature, e.g. Review or Approval. A user may only select meanings that
were assigned to him by the NMR administrator during user administration.

SIGNATURE COMMENT
Any text.

18.2.3 Displaying the Electronic Signature in the Data Window

The electronic signature can be displayed in the data window by setting the corresponding
display component. To do that:
1. Right-click in the data window and choose Display Properties... [.dopt].
2. Check Electronic Signature in the appearing dialog box and click OK.
The electronic signature will appear, at the upper left corner, below the title.

18.2.4 Plotting the Electronic Signature

When plotting a dataset using TopSpin's plot editor (commands plot and autoplot), an
electronic signature is automatically plotted (unless this feature is disabled), if the last entry of
the audit trail of the data to be plotted is an electronic signature. This ensures that after
signing no more data manipulations have been performed.

18.2.5 Multiple Signatures

The command esign may be applied several times to a data set, for instance if two persons
(say an operator and an administrator) must sign in accordance with company regulations.

18.2.6 Validity and Security of Signatures

TopSpin electronic signatures of data sets must not be confused with digital signatures as
defined in applicable law. Digital signature laws are usually country dependent. They require
the administration of passwords (more general: electronic keys which authenticate the owner
of the document) to be performed by authorized trust centers. In contrast, TopSpin uses OS-
encrypted passwords or internal user passwords encrypted by TopSpin itself.
For this reason, a Standard Operating Procedure (SOP) of the company or institution that
wishes to apply TopSpin signatures must exist defining the role of TopSpin signatures.
For this reason, companies and institutions that want to apply TopSpin signatures must have
a Standard Operating Procedure (SOP), which defines the role of these signatures.
Note that digital signatures complying with respective laws requires special software, and the
involvement of trust centers. Bruker refers to the respective commercial software for this
purpose.
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18.3 Password Controlled Login Identification

18.3.1 Definition of an Internal User

In TopSpin, the NMR administrator may set up a list of internal TopSpin users. An internal
user need not have a user account for the operating system and is only known to TopSpin.
Such a user is characterized by the following items:

USER ID
A short unique string of characters identifying a user (e.g. guest).

USER NAME
A long string of characters, usually the full name of a user (e.g. Franz J. Maier).

SIGNATURE MEANINGS
A list of items separated by comma (e.g. Approval, Review), an empty string or the special
string “-NONE-”. In the latter two cases, this user cannot electronically sign data. In all other
cases, the user is allowed to sign. The esign dialog allows the user to select one of the items
to specify the meaning of the signature.

PASSWORD
A password for this user, required for using TopSpin and for applying an electronic signature.

18.3.2 How to Set Up Internal Users

In order to define or modify the list of internal users:
• Enter the command uadmin.

or
• Click Options => Preferences => Administration items.

Click the Change button to the right of the object Setup users for TopSpin-internal login/
logoff and esign.

You will be prompted for the NMR administrator password. A dialog will appear where you
can add, remove and/or modify users.
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18.3.3 How to Change the Internal User Password

To change the password of the internal user:
• Enter chpwd on the command line.

or
• Click Options => Administration => Change internal user password

And enter the new password twice, as requested.

18.3.4 Login/Logoff

The uadmin command allows the administrator to make a TopSpin internal user mandatory.
To do that, enable Enforce "login" for working with TopSpin at the top of the dialog, click
Save+Close and restart TopSpin. After the restart, a login prompt will be displayed and
TopSpin cannot be used without entering an internal user and his password.
To log off the internal user:

• Enter logoff on the command line.
or

• Click Options => Administration => Log off and enter the user name and password as
requested.

If TopSpin internal user is not mandatory, i.e. the entry Enforce "login" for working with
TopSpin is disabled, you are not prompted to login after TopSpin startup. You can, however,
still login as internal user with the command login.
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18.3.5 Locking TopSpin's Graphical User Interface

TopSpin can be locked, such that it does no longer accept user input via mouse or keyboard.
To do that:

• Enter lockgui on the command line.
or

• Click Options => Administration => Lock TopSpin user interface
A window will appear indicating the locked status and offering buttons to unlock.

Only the current user or the NMR Administrator can unlock the user interface. While TopSpin
is locked, all background activities such as data acquisition and processing continue.
For safety reasons TopSpin can be forced to execute lockgui automatically when no
commands from the command line, menus or toolbar buttons have been entered for a certain
period of time (for instance because the current user has left). In order to enable automatic
locking.
1. Click Options => Preferences [set].
2. Click Administration Items in the left part of the dialog box.
3. Click the Change button to the right of the object Automatic locking of TopSpin when idle

time exceeded.
4. Enter the maximum allowed idle time (in minutes) in the dialog and click OK.
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19 Remote Control

19.1 Remote Control
TopSpin supports remote control. This means, for example, that you can control your
spectrometer from any PC in the laboratory network or, over the internet, from your PC at
home. Using your local TopSpin interface, you have access to the remote data directories
and remotely running TopSpin commands. Furthermore, in TopSpin 1.3 and newer, Icon-nmr
is web-enabled which means it can be controlled from any web browser which is networked
to the spectrometer. Note that remote access is operating system independent.

19.2 How to Establish a Remote Connection from your PC
In order to establish a remote connection, you have to perform a few steps, both on the local
and on the remote system. Note that the local system is the computer you are sitting at, and
the remote system is the computer you are connecting to. Up to 5 local systems can connect
to TopSpin on a remote system.

19.2.1 Setup the Remote System

The remote system must be enabled for remote access and, furthermore, individual data
directories must be exported.

Enable the system for network access
1. Log in on the remote system.
2. Start TopSpin.
3. Click Options --> Preferences [ set].
4. Click Miscellaneous in the left part of the dialog box.
5. Click the Change button to the right of the object Configure remote access.
6. Enter the Administration password as requested.
7. In the appearing dialog box:

– Click Remote Access Enabled
– Click Add and enter the data directories that you want to export for remote access,

e.g.: C:\bio and click OK.
– Click K to close the dialog.

8. Click OK to save and close the preferences dialog.
9. Restart TopSpin.



Remote Control

216 H9469SA3_2_003

A list of exported directories is stored the file:
<tshome>/prog/server/export.conf
Now a running TopSpin on this system can be accessed from any computer in the network.

Identify the port number
To identify the TCP/IP port number used by TopSpin:
1. Start TopSpin.
2. Enter hist.
3. Look for the line.
To connect to this TopSpin .... use host=<xxxx>., port=<yyyy>
In the upper part of the dialog window. The number at the end of this line (<yyyy) is the
desired port number, which must be used to set up the local system (see section 1D
Interactive Phase Correction Details [} 126]). By default, this is port number 5500. Only if this
port is already used by a program other than TopSpin, a different port is used.

19.2.2 Setup the Local System

Define the remote system
1. Log in on the local system.
2. Start TopSpin.
3. Click Options --> Preferences [set].
4. Click Miscellaneous in the left part of the dialog box.
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5. Click the Change button at the entry Setup remote systems. In the appearing dialog:

Enter the following information:
– Server ID: an arbitrary name for the remote system.
– Hostname or address: the host name or IP address of the remote host.
– TCP/IP port number of the remote TopSpin as identified in the section Setup the

Remote System [} 215].
6. Click Add to add the remote host.
7. Click OK to save the changes and close the dialog.
Note that you can define multiple remote systems, for example different spectrometers in
your laboratory.

Connect to the remote system
1. Click Options => Remote connection...
2. Select the desired Remote system from the appearing dialog box and click OK.

Now you are prompted for a user and password (both case sensitive) on the remote
computer.

The TopSpin browser will show the exported data directory trees of the remote system. You
are now ready to acquire, process or analyze remote data.
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19.2.3 Setup the Firewall

A remote system in a network can be protected by a firewall. Any firewall between the local
and remote TopSpin must be configured for TopSpin remote access.
If the remote PC is running under Windows XP with Service Pack 2 or higher, the Windows
Firewall is, by default, installed and running. Consider the following possibilities:

Firewall on PC with Windows XP-SP2 or higher, TopSpin installed
If TopSpin is installed, the firewall is probably configured for TopSpin remote access . If it is
not or you are not sure, you can configure it as follows:
1. Click Start => Programs => Bruker TOPSPIN => TOPSPIN <version> => Bruker

Utilities
2. Click Miscellaneous.
3. Double click Command Prompt.
4. In the Command Prompt window, enter:

cd prog\bin\utilities\Miscellaneous\setfirewall.cmd auto

Firewall on PC with Windows XP-SP2, no TopSpin installed
Configure the firewall as described in the Installation Guide for Windows XP.
On all other systems, the firewall must be configured manually by the network administrator.
To do that view the file:
<tshome>/prog/server/corba.conf

and open the ports specified here, incremented by 50.
For more information, please refer to the installation guides for Windows or Linux or inspect
the contents of the file corba.conf.
Note that the firewall must be configured for TopSpin:

• Spectrometer control.
• Remote access.

TopSpin can be used for processing/analysis on a local data station, even if it is not
registered on the firewall. However, you will get a few Security Alert messages during startup.

19.3 How to Make a Remote Connection without a Local License
TopSpin requires a license to operate on your local computer. However, you can make a
remote connection without a local license.
To do this, you have to start TopSpin as follows:
1. Open a Windows Command Prompt or Linux Shell.
2. Go to the TopSpin installation directory.
3. Enter topspin -client.
4. TopSpin will start up and show an empty data field but no browser. Before startup you will

get the error message: "The program failed to communicate with local ....". Click OK to
continue.

5. Click Options => Remote connection...and establish a remote connection as described
in chapter Setup the Firewall [} 218].

Note that without a local license:
• TopSpin on the remote system must run with a license.
• Local data cannot be accessed.
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19.4 Security of Remote Connections
All data transferred during a remote control session is, by default, encrypted. This ensures
that nobody can see data or commands by observing and recording your network traffic.
TopSpin uses the Secure Socket Layer (SSL) technology for encryption, which is also used
for secure web sites. SSL needs digital certificates on both sides of a connection to achieve a
valid authentication. After a TopSpin installation, default certificate files are provided to
secured connections. There is a chance, however small, such connections are attacked by a
malicious person who also has the same default certificate files. If, for this reason, you want
to create your own set of certificate files, you can do this by executing a script that is installed
in <tshome>/prog/server/make_new_certificates and follow the instructions given there. To
start a remote connection, the new certificate files must be installed on BOTH machines.

19.5 How to Access Icon-nmr from a Remote Web Browser
In TopSpin 1.3 and newer, ICON-NMR is web-enabled. The standard Bruker Automation
Software now provides a built-in website which can be activated to allow remote access to
ICON-NMR from any web browser which is networked to the spectrometer workstation.
Experiments may be cancelled/submitted, the run may be paused or halted and spectra in
PDF format are available from the browser window. No additional software apart from ICON-
NMR and Webbrowser is required and configuration is performed via the standard ICON-
NMR Configuration window. For security a SSL/HTTPS connection is supported. Pocket PC
Internet Explorer is also supported for full spectrometer control via Windows Mobile 2003
(TM) or equivalent. PDF files of spectra may also be viewed on this platform making the
mobile pocket spectrometer a reality.
The configuration of Icon-nmr web interface is described in the Icon-nmr manual, accessible
Help => Manuals => [Automation and Plotting] IconNmr Automation Interface. Note that
Icon-nmr remote control does not require and is fully independent of TopSpin remote control.

19.6 How to Limit IP-Addresses for Remote Control
TopSpin offers the possibility of limiting the IP Addresses for remote control, in order to
permit more security for all spectrometer control. This feature is especially useful for big
companies and concerns that work with different NMR spectrometers and many members of
staff, respectively many PCs.
Please note that the functionality of limiting IP Addresses is a feature for technical
experienced users and IT-Experts, therefore the following description is given by an example.
By default remote connection is disabled. You have to enable remote control first. For
enabling remote control and limiting the IP Addresses the following file has to be edited:
<tshome>/prog/server/omniorb.conf

In this file you have to search for the following section which enables every IP-Address for
remote connection:
To enable the Remote Connection feature using SSL encryption the '#'
character at the beginning of the next line should be removed:
#serverTransportRule = 0.0.0.0/0.0.0.0 ssl".

After removing the ’#’ an unlimited number of IP-Addresses may use remote control. The IP-
Address can be limited as it is shown in the following example by editing the respective IP-
Address line:
serverTransportRule = 149.236.14.0/255.255.255.0 ssl

After editing the IP Addresses belonging to your special requirements, every IP Address of
the permitted subnet may use the feature remote control and all other addresses have no
longer permission to connect remotely.
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20 User Preferences

20.1 User Preferences
TopSpin can be tailored to your preference in many respects. This ranges from startup
options to spectrum objects, menu settings, remote connections etc. Every standard user can
create their own set of preferences.
To set user preferences:

• Click Options => Preferences [set].
A dialog box will appear with, at the left side, the categories that can be tailored:

Click the category of which you want to view/change certain objects. It will become
highlighted and the corresponding objects will be displayed at the right part of the dialog box.
For example, if you click Spectrum, the spectrum objects will appear at the top of the dialog
box. The rest of this paragraph will describe some examples of setting various user
preferences.

20.1.1 Define User Preferences Location for all Users

User Preferences are, by default, stored in the current user’s home directory:
<userhome>/.topspin-<hostname>
During the first TopSpin session, files with default settings are created there. They can then
be modified with the set command and used in later sessions.
You can, however, also store user preferences at one central location, which are then used
by all users. This location can even be a remote drive allowing you to use the same
preferences on all computers in the network.
To do that:
1. Make a backup copy of the file <tshome>/javaenv.cmd.
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2. Open the file <tshome>/javaenv.cmd using a text editor.
3. Locate the line "set SYSTEM_PROPS=-DXWINNMRHOME="%XWINNMRHOME%" -

DCOMPUTERNAME=%COMPUTE........" near the beginning of the file.
4. Append a white space character and then:-DPROPDIR=<dir> to the end of this line,

where <dir> is the definition of the storage directory, consisting of one or more parts (see
below).

5. Close the editor.
The definition of the storage directory for User Preferences can take three forms:

• DPROPDIR=<mydir>
Stores the user properties in <mydir>/prop.
Example: -DPROPDIR="/x y z" (The double quotes are only required if the directory
contains white spaces).

• -DPROPDIR=<mydir> USER
Stores the user properties in <mydir>/<login id>/prop, where <login id> is the id under
which the user is logged into the operating system.
Example: -DPROPDIR="/x y z USER" (Specify exactly 1 space between the pathname
and the string USER).

• -DPROPDIR=CURDIR
Stores the user properties in <tshome>/prog/curdir/<login id>/prop, where <login id> is the
id under which the user logged into the operating system.

Please note that the specified directory must writable for all TopSpin users.

20.1.2 TopSpin Startup Actions

How to Open the Last Used Dataset on Startup
1. Click Options => Preferences [set].
2. Check, under Administration items, the option:

Auto-open last used data set when restarting TopSpin.

How to Define the Startup Actions
TopSpin allows you to define any commands to be executed automatically after startup. To
do that:
1. Click Options => Administration => Edit Startup File.
2. Enter the desired startup command(s), in the appearing editor, for example:

re exam1d_13C 1 1 c:\\bio guest
efp
apk
abs

The above lines would cause TopSpin to display the dataset:
C:/bio/data/guest/nmr/exam1d_13C/1/pdata/1
And execute the command efp, apk and abs on it.
Note that you can use a single forward slash (/) or a double backslash (\\) as path separator.
Note that in TopSpin 2.1 and newer, the file autostart.mac is a regular TopSpin macro. In
older versions, however, the file autostart.prop was used with a different format.
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How to Define Auto-Termination after Idle Time
TopSpin can be configured to be terminated after a user specified idle time. To do that:
1. Click Options => Preferences [set].
2. Click the Change button to the right of the object

Automatic termination of TopSpin when idle time has exceeded .
Enter the NMR Administration password as requested and enter the number of minutes of
allowed idle time.

3. Click OK to close the dialog, click OK to close the Preferences dialog.
4. Restart TopSpin to activate the change.
If the user does not execute any commands (from the command line, menu or toolbar
buttons), a dialog will appear with an OK button (to terminate immediately) and/or Cancel
button (to continue).
Automatic termination frees the license used by this TopSpin instance for other users. This
solves the problem of users leaving TopSpin open and blocking a floating license although
they do not currently use it.

How to Define Auto-Locking after Idle Time
TopSpin can be configured to lock the interface after a user specified idle time. To do that:
1. Click Options => Preferences [set].
2. Click the Change button to the right of the object.

Automatic locking of TopSpin when idle time has exceeded.
Enter the NMR Administration password as requested and enter the number of minutes of
allowed idle time.

3. Click OK to close the dialog, click OK to close the Preferences dialog.
If the user does not execute any commands (from the command line, menu or toolbar
buttons), the TopSpin interface will be locked:

How to Change the Preferred Editor
You can choose your preferred editor as it is used by commands like edau, edpul, edcpd
etc. To do that:
1. Click Options => Preferences [set].
2. Click Miscellaneous in the left part of the dialog box.
3. Click the Change button to the right of the object Preferred text editor enter the desired

Editor and its path. For example for Wordpad under Windows 2000/XP, this would look
like:
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4. Click Save to save the changes.
If no editor is specified here, the TopSpin internal editor is used. It the file being edited is
read-only, the TopSpin internal viewer is used.

How to Configure the Tab Bar
The default Tab bar at the top of the data window consist of Tabs to switch between various
dataset objects like Spectrum, Parameters, Title, etc. You can, however, configure the Tab
bar to contain Tabs for interactive data manipulation like phase correction, integration etc.
These Tabs have the same function as the corresponding buttons in the upper tool bar (see
chapter Getting Started [}  13] and 1D Interactive Manipulation [}  123]) but are easier to
access. You can configure the Tab bar as follows:
1. Click Options => Preferences.
2. Click Spectrum in the left part of the User preferences box.
3. Click the Change button to the right of the object Tabbed pane layout.
4. Check the desired Tabs, uncheck the others.
5. Click OK.
Note that you can change the relative positions of a Tab by selecting it and then clicking the
Up or Down button.

How to Configure the Right-click Menu Function
Right-clicking a pull-down or popup menu, can perform various actions. This can be
configured as follows:
1. Right-click an empty part of the menu bar and choose Define Right-Click Action from the

popup menu.

2. In the appearing dialog (above), select the desired action.
3. Click OK.

20.1.3 Changing Colors

How to Change Colors of Data Objects on the Screen
The color of various objects in a data window on the screen, like 1 st, 2 nd and 3 rd spectrum,
axis, parameters etc. can be changed. To set these colors:
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1. Click Options ’ Preferences [ set].
2. Click Spectrum in the left part of the User preferences box.
3. Click the Change button to the right of the object you want to change e.g.:

4. Select the desired color in the appearing dialog box and click OK
5. Click Apply.

How to Change Colors of Data Objects on the Printer
The color of data objects on the printer is independent from the color of the corresponding
object on the screen. To set print colors:
1. Click Options ’ Preferences [set].
2. Click Printer in the left part of the User Preferences box.
3. Click the Change button to the right of the object you want to change, e.g.:

4. Select the desired color in the appearing dialog box and click OK
5. Click Apply.

How to Change Colors of the Lock Display
The colors of lock display objects can be changed as follows:
1. Click Options => Preferences [set].
2. Click Lock display in the left part of the User preferences box.
3. Click the Change button to the right of the object you want to change, e.g.:

4. Select the desired color in the appearing dialog box and click OK
5. Click Apply.

How to Create a New Data Window Color Scheme
To create a new data window color scheme:
1. Click Options => Preferences [set].
2. Change any color of the objects Spectrum, Spectrum title, Spectrum cursor or Spectrum

parameters.
3. Click Apply.
4. Click Spectrum in the left part of the User preferences box.
5. Click the button Save as... to the right of the object:

Save spectral window colors as a new color scheme and enter a new name in the
appearing dialog box.

6. Click OK.

How to Read a Different Data Window Color Scheme
1. Click Options => Preferences [set].
2. Click Spectrum in the left part of the User preferences box.
3. Click in the list box to the right of the object:
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Change spectral window color scheme and select an element from the appearing list.
4. Click OK.
TopSpin is delivered with two colors schemes:

• Light a white background with black axes.
• Dark: a dark blue background with a white axes.

How to Change Peak and Integral table Color/Spacings
1. Click Options => Preferences [set].
2. Click Miscellaneous in the left part of the User preferences box.
3. Click in the list box to the right of the object:

Table colors (see figure below) for simple tables like peaks, solvents, nuclei tables.
Tree table colors for nested lists like the integral table.
Set the desired colours and spacings.

4. Click OK.

Note that table colors and spacing can also be changed from a table. To do that, right-click
any table entry and choose Table properties...

20.1.4 Changing Lines

How to Create Thick Lines on the Screen
To create thick (double width) lines for high resolution display or screen dumps:
1. Click Options => Preferences [set].
2. Click Spectrum in the left part of the dialog box.
3. Enable the entry Use thick lines.
4. Click OK.

How to Create Thick Lines on the Printer
To create thick (double width) lines for high resolution display or screen dumps:
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1. Click Options => Preferences [set].
2. Click Printer in the left part of the dialog box.
3. Enable the entry Use thick lines.
4. Click OK.

20.1.5 Changing Fonts

How to Change All Fonts of the TopSpin Interface
1. Click Options => Preferences [ set].
2. Click Fonts/Dialogs/Icons in the left part of the dialog box.
3. Set the entry Change size fonts listed above by .... points. You can enter a positive or

negative number. The following figure shows an example of increasing the font sizes by 4
points.

4. Click OK to store the new value.

The figure above shows the same part of the Preferences dialog box after the change of
fonts. Note that:

• The value of all font entries has been increased by 4.
• The font of the dialog box itself is larger.
• The change size has been reset to 0.

How to Change the Font of the TopSpin menu
To change the font of the  TopSpin menu:
1. Click Options => Preferences [set].
2. Click Fonts/Dialogs/Icons in the left part of the dialog box.
3. Click the Change button to the right of the Menu font object.
4. Select the desired name, style and/or size in the appearing dialog box.
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5. Click OK to store the new font.
6. Click Apply.
The default menu font is Dialog/Plain/18 and looks like this:

After changing the font to, for instance, to Serif/Italic/18, the menu looks like this:

A change in menu font also affects all sub-menus and popup menus.

How to Change the Font of the Tab bar

1. Click Options => Preferences [set].
2. Click Fonts/Dialogs/Icons in the left part of the dialog box.
3. Click the Change button to the right of the Spectrum TABS font object.
4. Select the desired name, style and/or size in the appearing dialog box.
5. Click OK to store the new font.
6. Click Apply.
The following figures show a Tab bar with font size 10 and 14 respectively.

Tab bar with font size 10.

Tab bar with font size 14.

How to Change the Font of Dialog Boxes
1. Click Options => Preferences [set].
2. Click Fonts/Dialogs/Icons in the left part of the dialog box.
3. Click the Change button to the right of the Dialog window font object.
4. Select the desired name, style and/or size in the appearing dialog box.
5. Click OK to store the new font.
6. Click Apply.
The following figure shows an example of a dialog box with the font Times New Roman Italic.
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How to Change the Font of the Browser
To change the font of the browser:
1. Click Options => Preferences [set].
2. Click Fonts/Dialogs/Icons in the left part of the dialog box.
3. Click the Change button to the right of the Dialog window font object.
4. Select the desired name, style and/or size in the appearing dialog box.
5. Click OK to store the new font.
6. Click Apply.
TopSpin must be restarted for this change to become effective. Note that this change will
affect all dialog boxes.

How to Change the Font of the Command Line
1. Click Options => Preferences [set].
2. Click Fonts/Dialogs/Icons in the left part of the dialog box.
3. Click the Change button to the right of the Command line font object.
4. Select the desired name, style and/or size in the appearing dialog box.
5. Click OK to store the new font.
6. Click Apply.

How to Change the Font of the Status Line
1. Click Options => Preferences [set].
2. Click Fonts/Dialogs/Icons in the left part of the dialog box.
3. Click the Change button to the right of the Status line font object.
4. Select the desired name, style and/or size in the appearing dialog box.
5. Click OK to store the new font.
6. Click Apply.
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20.1.6 Changing Acquisition Settings

How to Auto-Archive existing expnos
1. Click Options => Preferences [set].
2. Click Acquisition in the left part of the dialog box.
3. Click the Change button to the right of the item Configure Accounting & Data Archiving

after ’zg’:

4. In the appearing dialog, configure archiving as described in the dialog:

5. Click OK.

20.2 Command Line Preferences

How to Resize the Command Line
By default, the TopSpin command line shows one command, the command that is currently
entered, e.g.:

However, you can resize the command line to show the currently entered command plus the
last and second last command, e.g.:

You can toggle between the two different command line sizes as follows:
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• Click View => Resize command line
or

• Right-click in the command line and click Resize command line

How to Set the Minimum and Maximum Command Line Size
By default, the size of the command line can be toggled between 1 and 3. You can, however,
change this minimum and maximum value, respectively. To do that:
1. Click Options => Preferences [set].
2. Click Fonts/Dialogs/Icons in the left part of the dialog box.
3. Specify the Minimum visible command lines (> 0).
4. Specify the Maximum visible command lines (≥ Minimum visible).
5. Click Apply

20.3 Disabling/Enabling Toolbar Buttons, Menus and Commands

How to Hide the Upper and Lower Toolbars
Right-click in an empty area of one of the toolbars and choose Hide the toolbars from the
appearing popup menu (see the figure below).
To restore the toolbars:

• Press the keys SHIFT+ESC

How to Hide the Menu Bar
Right-click in an empty area of the Menu bar and choose Hide the menu bar from the
appearing popup menu.
To restore the menu bar:

• Press the keys SHIFT+ESC

How to Disable/Remove Toolbar Buttons
Buttons of the upper or lower toolbar can be disabled or removed as follows:
1. Right-click a toolbar button.
2. Choose one of the entries:

• Make this button invisible to remove the button from the toolbar.
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• Make this button inactive to disable the button (it will appear grayed).
To restore the complete toolbars, click:

• Reactivate all invisible or inactive buttons to restore the default toolbar.

How to Disable/Remove Menus or Commands
By default, all existing TopSpin commands can be entered from the menu and/or from the
command line. You can, however, selectively disable/remove commands or menus. This is
typically done by system administrators who want to disable certain functions for standard
users.
Open the Menu Configuration table as follows:
1. Click Options => Preferences [ set].
2. Click Fonts/Dialogs/Icons in the left part of the dialog box.
3. Click the Change button of the entry Disable/Enable menus and commands.
The table consists of the following columns:

Command Description Menu Status

You can disable/remove:
• Menus, e.g. Options to be found in the column Menu.
• Sub-menus, e.g. Options => Administration tools to be found in the column Menu.
• Menu entries, e.g. Options => Preferences to be found in the column Description.
• Commands, e.g. set to be found in the column Command.

Note that in this configuration table, each menu entry corresponds to a certain command. In
the TopSpin menu, most commands are indicated in square brackets behind the
corresponding menu entries, e.g.:

• Processing => Fourier transform [ftf]
Menu entries which are not used very often appear without the corresponding command
indicated, e.g.:

• Options => Preferences
However, if you want, you can look up the corresponding command, in this case set, in the
configuration table and use it.
As an example, we will describe how you can disable/remove the menu entry Remote
connection.. in the Options menu:
1. Open the configuration table as described above.
2. Scroll to the Description Remote connection.
3. Set the Status to disabled.
4. Click Apply.
Clicking the TopSpin Options menu, will now show the following popup menu:
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The entry Remote connection.. is grayed and can no longer be used.
Go back to the Configuration table, change the Status of Remote connection... to invisible
and click Apply.
Clicking the TopSpin Options menu, will now show following popup menu:

The entry Remote connection.. has disappeared.
Note that if you disable or remove a menu entry, the corresponding command is
automatically disabled. For example, if you disable:

• Analysis => Deconvolution [dcon] entering dcon on the command line will lead to an
error message.

How to (Re) enable a disabled Command/Menu
1. Open the Menu Configuration table as described above.
2. Set the Status of a disabled or removed (invisible) entry to enabled.
3. Click OK to close the Configuration table.

How to (Re)enable All Commands/Menus
1. Open the Menu Configuration table as described above.
2. Click the Reset button to enable all menus and commands.
3. Click OK to confirm the appearing message.
4. Click the OK button to close the Configuration table.

20.4 Resizing/Shifting Toolbar Icons

How to Change the Toolbar Icon Size
1. Right-click of any part of the toolbar.
2. In the appearing popup menu, click Change Icon Size...
3. Enter the icon size in the appearing dialog and click OK.

How to Shift Toolbar Icons to the Right
1. Right-click of any part of the toolbar.
2. In the appearing popup menu, click Change Toolbar Offset...
3. Enter the toolbar offset in the appearing dialog and click OK.
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20.5 Defining Source Directory for Programs/Lists etc.
TopSpin 2.1 and newer allows you to define the source directories for pulse programs, AU
programs, integral ranges, various lists etc. In TopSpin 2.0 and older, the source directory for
these items was fixed: <tshome>/exp/stan/nmr. Now you can define a individual source
directories for each item. To do that:
1. Open the dialog of any of the items, e.g. with the command edau, edlist or edmisc.
2. Click Options => Manage Source Directories.
A dialog will appear showing a list of items with the current source directories:

By default, two source directories are present, one for user defined items and one for Bruker
items. This list can be modified or extended with your preferred source directories, e.g.:
C:\my-pulse-programs\
C:\ts21\exp\stan\nmr\lists\pp\user
C:\ts21\exp\stan\nmr\lists\pp
You can do this for each item separately. Items will be searched for in the order of the
directories specified.
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21 User Extensions
TopSpin offers various ways to extend the standard commands, buttons, programs etc.

21.1 User Notebook
You can create your own user specific notebook with the command:

• View => Notebook [nbook]

This can be used to store and retrieve any personal notes, information etc.

21.2 Macros
A macro contains a sequence of TopSpin commands. It can be created with the command
edmac. A simple macro for processing and plotting the current dataset is:
Em

Ft

Apk

Sref

autoplot

All entries in a macro file must be written in lower case letters.
In TopSpin 1.3 and newer, a macro may contain Python commands. Any line in a macro that
starts with:
py>

Executes a Python command. An example of such a macro is:
re exam1d_13C 1 1 C:\bio guest

efp

py>NEWWIN() # open new window

re exam1d_1H 1 1 C:\bio guest

efp

py>x = INPUT_DIALOG()

py>if x == None: EXIT()

py>y = 2* int(x[0])

py>MSG("done: y=" + str(y))

Note that commands like NEWWIN(), INPUT_DIALOG(), MSG() and EXIT() are Bruker
defined whereas "x=" and "if" are original Python commands.
Once created, a macro can be executed by entering its name on the command line.
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21.3 AU Programs
An AU program may contain TopSpin commands, AU macros and C-language statements. It
can be created with the command edau. A simple AU program which performs the efp
command on a series of dataset expno’s is:
#include <lib/util.h>
int first, max;
char string[80];
first = expno;
GETINT ("Enter first expno to process : ",first)
max = 10;
GETINT ("Enter number of expnos : ",max)
WPAR("tmpmefp","proc")
expno =first;
TIMES(max)
RPAR("tmpmefp","proc")
EFP
IEXPNO
END
DEXPNO
DELPAR("tmpmefp")
QUITMSG("--- multiefp finished ---")
Note that TopSpin commands like EFP and RPAR and AU macros like IEXPNO are written in
upper case letters whereas C-language statements like "max = 10;" are written in lowercase
letters. Once created, an AU program can be executed by entering its name on the command
line.
For more information on writing AU programs:

• Click Help => Manuals => [Programming Manuals] AU programming

21.4 Python Programs
A Python program  may contain TopSpin commands, User Interface functions and Graphic
functions. It is created with edpy.
The Python program below reads a region of the real part of a spectrum and the
corresponding region of the imaginary part and displays both. The simplest form of
DISPLAY_DATALIST is used.
from TopCmds import *
import math
region = [80, 72] # define region in ppm
# open testdata, don't display
testdata = ["exam1d_13C", "1", "1", "c:/Bruker/topspin", "guest"]
RE(testdata, "n")
# read real and imaginary points of the region
reals = GETPROCDATA(region[0], region[1])
imags = GETPROCDATA(region[0], region[1], dataconst.PROCDATA_IMAG)
if reals == None or imags == None: EXIT()
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# set up list of data to be displayed and respective axis info list
dataList = [reals, imags]# display the data in the list
DISPLAY_DATALIST(dataList)
For more information on writing Python program:

• Click Help => Manuals => [Programming Manuals] Python programming

21.5 Button Panels
A button panel is a window with user-defined buttons for executing TopSpin commands, AU
programs, Python programs or macros. It appears as an integral part of the active data
window and acts on that Bruker delivers a few standard button panels like bnmr and
bnmrsel. To create your own button panels, you can modify one this or write one from
scratch.
In this description we will create a very simple button panel with some 1D processing
commands and print/export buttons:

To write this button panel, take the following steps:
1. Open the Windows Explorer and navigate to the subdirectory:

userdefined
Of the users properties directory (To locate this, enter hist and look for the entry "User
properties directory=".).

2. Create a text file with the name:
cmdpanel_<name>.prop
Where <name> is the name of the button panel.

3. Enter the button definitions including Panel title, Colors, Toggle buttons, op buttons, Panel
layout, Panel buttons and Tooltips.

4. Save the file under a name:
cmdpanel_<xxx>.prop
where <xxx> is the actual name of your command panel.
Make sure the extension of the file is .prop and not .txt, .prop.txt or anything else.

5. Enter bpan <xxx> on the command line to open the button panel.
Here is an example for a small button panel for 1D processing:
# Color definitions used in this file (RGB)

BLUE1=51$ 204$ 255YELLOW1=255$ 255$ 0GREEN1=84$ 196$ 20

# Title definition

TITLE=1D Processing PanelTITLE_COLOR=0$ 0$ 255

# Toggle button definition

TOGGLE_BUTTON=To 2D

TOGGLE_CMD=bpan bproc2d

TOGGLE_TIP=Switch to 2D processing
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# Top row button definition

TOP_BUTTONS=EM$ $FT$ $PK$ $TOP_COLORS=YELLOW1$ YELLOW1$ YELLOW1

TOP_CMDS=em$ ft$ pk

TOP_TIPS=Exponential multiplication $\Fourier transform$\Phase
correction

# Panel button definitions

# LAYOUT format: rows columns hgap vgapPAN_LAYOUT=1$ 3$ 8$ 8

PAN_BUTTONS=Print$ $ EXPORT$ $SEND TO$ $

PAN_COLORS=BLUE1$ BLUE1$ BLUE1

PAN_CMDS=prnt$ exportfile$ smail

PAN_TIPS=Print the spectrum<br>\

as it appears on the screen$\

Export the dataset<br>\to png, jpg, bmp etc.$\Send the dataset by
email

If you type bpan exam, a panel with 75 buttons will appear: 5 rows and 15 columns. The
corresponding panel file is called cmdpanel_exam.prop, which resides in the directory:
<tshome>/classes/prop/English
In the same directory, you can find the files cmdpanel_bnmr.prop and
cmdpanel_bnmrsel.prop, which are used to display the bnmr and bnmrsel panel described
above.
The texts displayed on the buttons can be graphically adjusted in various ways, because the
text may optionally be specified in html format. In the example above, the PAN_BUTTONS
property has no html tags, therefore the texts are displayed in black using the default
TopSpin Dialog window font as specified in the User Preferences (command set). If you
replace the text Print by the following:
<html><font size=10><font color=\"00BF00\">Print<br>Now</font></
html>

then the new text "Print Now" is displayed in green (the color to be specified in RGB hex
code), with 10 points font size. Also, "Now" is display below "Print" due to the html <br> (=
break line) tag.
Note that:

• The Close button and Tips switch are automatically created. You don’t need to specify
them.

• The TOGGLE button is typically, but not necessarily, used to call another button panel. In
this example it calls the panel bproc2d. If TOGGLE_BUTTON is specified without a value,
i.e. the entry is "TOGGLE_BUTTON=" instead of "TOGGLE_BUTTON=action text", the
corresponding button is not shown in the panel.

• Items must be separated with the "$" character, button items with "$ $"
• A "\" followed by "end of line" continues an item on the next line.
• Tooltips may use html tags for text formatting.
• Commands may be specified as single commands like "em" or as composite commands

like "em\nft\npk". Note that in the latter case, the commands must be separated by "\n".
• When the bpan <name> command comes up with an error message, carefully check the

syntax of your cmdpanel file. A common mistake is to specify the button items incorrectly.
With the keyword PAN_LAYOUT you define the number of rows and columns, and the
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number of items will become rows*cols. All specifications such as PAN_BUTTONS,
PAN_COLORS, etc. must have this number of members, otherwise you will get some kind
of TopSpin error. Please insert the "$" separator to make sure the item count is correct.

21.6 Adding User Defined Buttons to the Toolbars
The upper and lower toolbar at the top of the TopSpin window can be extended with user
defined buttons. They can be assigned to any TopSpin command, macro, AU program or
Python program.
To create a user defined button, take the following steps:
1. Right-click at an empty area of the toolbar.
2. In the appearing popup menu, click: Add User-Defined Button

3. In the appearing dialog box:
– Choose between the options text label or icon. The corresponding parameters are

enabled/disabled.
– Enter the command name, the tool tip and the label text or icon file pathname.
– For a text label: set its font, text color and background color.
– For an icon label: specify the icon image filename.
– Set the separator flag to yes or no and select the data dimension(s) for which the

button must appear.
For an icon label, you must store the icon image file in one of the following directories:

• <user-home>/.topspin-<hostname>/prop/user defined (only available for this user).
• <tshome>/classes/prop (available for any user).
• Any directory (the full pathname must be specified in the icon label field).

The formats .gif, .jpg, .jpeg and .png, are supported. Standard TopSpin icons have a size of
16 * 16 pixels. If your own icons have a different size, they are automatically rescaled and
displayed at the standard size.
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In the example above, a button FT is created with a separator, which only appears for 1D
datasets, and executes the command ft.

How do I Remove a User Defined Toolbar Button
Right-click the toolbar button and click: Remove this user-defined button... in the appearing
popup menu.

How do I Shift a User Defined Toolbar Button to the left/right
Right-click the toolbar button and click Shift left or Shift right in the appearing popup menu:

The button definitions are stored in the file toolbar_user.prop which resides in the
subdirectory userdefined of the user properties directory. To locate this directory enter the
TopSpin command hist. A dialog box will show the contents of the history file. Near the top of
this file, you will see an entry "User properties directory=".
For icon image buttons, the formats .gif, .jpg,.jpeg and .png are supported. Standard TopSpin
toolbar icons have a size of 16 * 16 pixels. If your own icons have a different size, they are
automatically rescaled and displayed at the standard size.

21.7 Adding User Defined Menus to the Menu Bar
The menu bar at the top of the TopSpin window can be extended with user defined menus.
They can be assigned to any TopSpin command, macro, AU program or Python program.
They are specific for the dimensionality of the active dataset.
To create a user defined menu, take the following steps:
1. Open a dataset of the desired dimensionality.
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2. Right-click at an empty area of the menu bar.
3. In the appearing popup menu, click User_defined Menus
4. In the appearing dialog box (see figure below).

– Click Add Menu and specify the Menu Name in the appearing dialog.
– Click Add Menu Item and specify the Menu Item (menu entry) name and the

corresponding Command in the appearing dialog.
– Click Apply.

The new menu will appear in the menu bar.
Furthermore the dialog box in the figure above contains the following buttons:

• Remove : Remove menu names and/or menu items.
• Apply+Close : Apply any changes and close the dialog box.
• Up/Down : Move up/down the menu name list.
• Cancel : Close the dialog box discarding any changes.

User defined menu definitions are stored in the file umbar_menubar1d.prop,
umbar_menubar2d.prop or umbar_menubar3d.prop depending on the data dimensionality.
These files reside in the subdirectory userdefined of the user properties directory. To locate
this directory enter the TopSpin command hist.

21.8 Adding User Defined Guides
TopSpin  offers several guides like the Acquisition Guide (command aqguide), the
Processing Guide (command prguide) and the T1/T2 Guide (command t1guide). You can
set up your own guides, which can be adaptations of Bruker guides or new written ones. In
order to do that, you must edit the file toolbar_user.prop and cmdtab_user.prop in the
directory:
<user properties directory>/userdefined/
To identify this directory, enter the command hist in TopSpin.
The file toolbar_user.prop contains the guide definition. If the file does not exist, it must be
created. Here is an example of a user-modified T1/T2 guide.
MyT1T2Toolbar=\

NM=t1fid_40.gif, NM2=$Extract fid, TIP=$Do rser,

CMD=_t1_fid, END=,\

NM=t1spec_40.gif, NM2=$Transform, TIP=$Do ef+apk,

CMD=_t1_spec, END=,\

NM=t1ranges_40.gif, NM2=$Ranges, TIP=$Enter integ. mode,

CMD=_t1_ranges, END=,\

NM=t1screen_40.gif, NM2=$Relax. Window, TIP=$Enter Relax mode,
CMD=_t1_relax, END=,\NM=-, END=,\
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NM=myicon.gif, NM2=$Fit Methods, TIP=$Select fit funcs.,

CMD=_t1_func, END=,\

NM=c:/myicons/myicon1.gif, NM2=$Start, TIP=$ct1,ct2, simfit,

CMD=_t1_start, END=,\

NM=c:/myicons/myicon2.gif, NM2=$Show Report, TIP=$report,

CMD=_t1_report, END=,\

NM=t1print_40.gif, NM2=$Print it, TIP=$print,

CMD=_t1_export, END=

Notes to this guide definition:
• The original Bruker guides are defined in the file toolbar.prop in the directory <tshome>/

classes/prop. The corresponding commands are defined in cmdtab_main.prop in the
same directory.

• The bold lines in the example above are user-modified lines.
• NM=t1fid_40.gif: a Bruker defined icon with a size of 40x40 pixels.
• NM=myicon.gif: a user-defined icon, which must be located in the user properties

directory (Caution: not in its subdirectory userdefined).
• NM=C:/myicons/myicon1.gif: a user-defined icon located C:/myicons. Using the

absolute pathname allows you to store icons in an arbitrary directory.
• NM= Indicates the start of the second icon column.
• NM2= The text to appear underneath of the icon. The $ sign is mandatory.
• CMD= The command to be executed when the icon is clicked. This can be a regular

TopSpin command, a macro or an AU or Python program.
• TIP= The tooltip to be displayed when the cursor is held over the icon. Note that the $

sign is mandatory.
Before you can start a user defined guide, you must edit the file cmdtab_user.prop and define
the corresponding command in the file, for example:
myt1guide=EM=J, MC=N, CL=tutor.TutStarter,
ME=startTutorial,AR=MyT1T2Toolbar;My T1 T2 Tutorial=
Here:

• "MyT1T2Toolbar" is the toolbar identifier as it is used in the file toolbar_user.prop.
• "My T1 T2 Tutorial" is the title as it appears at the top of the guide.

If your guide is a Bruker modified guide, you can also redefine the original Bruker command,
i.e. specify t1guide instead of myt1guide. Note that the original Bruker guide is then no longer
accessible.
If you want to access a user defined guide from the TopSpin toolbar, you have to create a
new toolbar button. To do that, right-click in an empty area of the toolbar and define a button
in the appearing dialog.
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22 Contact

Manufacturer
Bruker BioSpin GmbH
Silberstreifen 4
D-76287 Rheinstetten
Germany
http://www.bruker.com

WEEE DE43181702

NMR Hotlines
Contact our NMR service centers.
Bruker BioSpin NMR provides dedicated hotlines and service centers, so that our specialists
can respond as quickly as possible to all your service requests, applications questions,
software or technical needs.
Please select the NMR service center or hotline you wish to contact from our list available at:
https://www.bruker.com/service/information-communication/helpdesk.html

Phone: +49 721-5161-6155
E-mail: nmr-support@bruker.com

http://www.bruker.com
https://www.bruker.com/service/information-communication/helpdesk.html
mailto:nmr-support@bruker.com
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Glossary
FID

Free Induction Decay (FID) is the observable
NMR signal generated by non-equilibrium
nuclear spin magnetization precessing about
the magnetic field.
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